14 Replies Latest reply: Mar 14, 2006 11:30 PM by Jim Mingin
Steve Cooper Level 2 Level 2 (165 points)
Safari previously operating OK under OS 10.3.9 suddenly starts reporting "Unable to connect to secure server" with a number of (maybe all?) <https://> sites. Explorer doesn't exhibit this problem. Removing Safari .plist, clearing caches, and removing ~/Library/Safari folder do not help.

Any ideas on what to try next?

Thanks,
Steve.

PowerBook G4, Mac OS X (10.3.9)
  • Jim Mingin Level 1 Level 1 (55 points)
    Having the same problem with all secure sites even Apple (running 10.3.9). FireFox is working fine.

    Help!

    Ti PowerPC G4 1GHz   Mac OS X (10.3.9)  
  • RdL Level 1 Level 1 (10 points)
    I just started having problems with my Safari this morning. I'm also on 10.3.9 and yesterday, Safari was running fine. This morning when I try to launch it, it gets stuck and all I see is the spinning icon.

    Firefox is running fine. Any help is appreciated.
  • Jim Mingin Level 1 Level 1 (55 points)
    anyone have any ideas? It is not ISP related because I can connect with FireFox and cannot connect when trying four different ISP's (including AOL dial-up).

    Ti PowerPC G4 1GHz   Mac OS X (10.3.9)  
  • Lavender_girl Level 1 Level 1 (0 points)
    Same thing has happened to my Safari secure server connections I can't even log into my own .Mac account details.

    FireFox is fine but I do my online shopping using Safari...very frustrating.

    Safari version 1.3.2

    Any ideas on how to fix this very welcome.
  • racestang Level 1 Level 1 (0 points)
    I am running OS X 10.3.9 as well. I normally use Firefox as my browser, it runs fine. However all my software updates use Safari as their browser, so I have stopped getting all security updates. Also, I've been unable to access the iTunes Music Store, and Photoshop Elements hasn't worked in a while (I assume they use Safari to connect to the internet).

    Does anyone know of a fix. Or how do I simply get Software Updates, iTunes, and Photoshop to start connecting through Firefox?

    Can anyone help? Thanks.

    Dual 1.25 GHz Power PC G4   Mac OS X (10.3.9)  
  • racestang Level 1 Level 1 (0 points)
    It must be just coincidence, but my software updater just notified me of an update for Safari. Number 1.2 (v312.5). It seems to have fixed my problems (for now?). At least I can get photoshop to work right for the first time in months, and iTunes Music Store is now accessible. I'm sure this is all just a coincidence. If anyone was just about to respond to my question, thanks anyway, but the problem seems to be OK.


    Dual 1.25 GHz Power PC G4   Mac OS X (10.3.9)  
  • Lavender_girl Level 1 Level 1 (0 points)
    Hmmm my Safari is already 1.3.2 (v312.5) problems still happening for me but no problem with the music store.
  • Jim Mingin Level 1 Level 1 (55 points)
    I am already using Safari 1.3.2 (v312.5) also and have been for awhile.

    Ti PowerPC G4 1GHz   Mac OS X (10.3.9)  
  • Barbara Brundage Level 7 Level 7 (22,075 points)
    Photoshop Elements hasn't worked in a while


    Are you using PE 2? That's the only version that can be having an internet related problem (and it has nothing to do with Safari). Quit PE 2, make sure your computer is offline, then go to preferences>adobe online and set Check for Updates to Never. (There never have been any, and there sure won't be any now that PE is up to version 4).

    If you don't have PE 2, then you have a different problem.
  • Mark Silverman2 Level 1 Level 1 (5 points)
    I've been having the same problem not being able to log in to any of my secure sites.

    Solved problem by going under Debug Menu to last item, Security, and changing to Performs Lax Certificate Checks.

    Problem is that each time after quitting and reopening Safari Security preference changes back

    Power Mac G4   Mac OS X (10.3.9)  
  • Jim Mingin Level 1 Level 1 (55 points)
    Thank you Mark! I just did this and it worked!

    Ti PowerPC G4 1GHz Mac OS X (10.3.9)

    Oh! and btw: this is how you add the Debug:

    To enable the Debug agent, open the Terminal located in the Utilities folder in Applications and paste the line below in it, then press return, close Terminal, and restart Safari.

    defaults write com.apple.Safari IncludeDebugMenu 1
  • Jim Mingin Level 1 Level 1 (55 points)
    Only problem with above Debug is that Safari doesn't remember the setting change. You have to reselect Lax upon each start-up unless someone knows how to make this permanent?

    Thanks!

    Ti PowerPC G4 1GHz   Mac OS X (10.3.9)  
  • Steve Cooper Level 2 Level 2 (165 points)
    Thanks Mark! I finally got back to the problem Mac today and this fix worked. OK, you have to do it each time Safari is launched, but that can be addressed simply by not quitting Safari unless you have to.

    All the best,
    Steve.
  • Jim Mingin Level 1 Level 1 (55 points)
    Try this, It fixed my Safari and access to iTunes:

    1. Locate the /Library/Keychains folder on your hard disk. Be careful not to confuse it with the /Library/Keychains folder in your home folder.
    2. Drag this folder to the desktop.
    3. Enter your administrator name and password when prompted to do so.
    4. Restart the computer.


    Ti PowerPC G4 1GHz   Mac OS X (10.3.9)