6 Replies Latest reply: Oct 22, 2013 11:04 AM by SubSpace
donebylee Level 1 (10 points)

If I enable Set Automatically under Date & Time in General settings my iPhone 4s displays the wrong time zone.


Here are the facts:


  • My mac is set to the correct time zone: NYC, USA (so iTunes sync is NOT the problem)
  • My iPhone 4S insists I am in Chicago. I am NOT in Chicago, nor have I been in the central time zone during this phone's lifetime.
  • I have to keep Set Automatically turned off. This is the only way that appointments and important reminders don't get screwed up.


I hope someone here can help.



Mac OS X (10.7.2)
  • donebylee Level 1 (10 points)

    OK, after talking to AppleCare here is what fxed my problem: Reset all Settings, restore as a new iPhone. All my apps and music are still there, but it fixed whatever caused the time zone setting to keep moving to Chicago.


    Very weird software glitch, but an easy fix.


    Hope this helps out others who experience this.

  • russcre Level 1 (0 points)

    Thank you.  I was having the same, odd problem...but only after the recent change to Daylight Savings Time.  The fix that you (via Apple Care) suggest ("Reset All Settings") for my iPhone 4S worked.  Of course, it did mean that I had to update my Sounds, e-mail Signature, etc. from the Default Settings (a consequence of the Reset All)  back to the way I had customized them.  Fortunately, I did not lose any data implementing the fix, and I did not have to re-synch my e-mail or anything else as far as I can tell.  In total, it  took about 5 minutes.

  • kulehandluke Level 1 (0 points)

    I didn't like the reset everything solution; I found this article which was much more useful:


    http://davemeehan.com/technology/iphoneipad-has-wrong-timezone-when-datetime-is- set-automatically


    For me it was an easy thing to fix; I had the timezone setting disabled. This is in Settings > Location Services > System Services (right at the bottom) > Setting Time Zone - make sure this is enabled.

  • TelJones Level 1 (10 points)

    Thanks for this, my iPhone has been sending me to Helskinki!


    Sounds like a bit of a bug, the auto timezone setting should be disabled if the location service is switched off.

  • sir-blah Level 1 (0 points)

    I still have the problem. I had to reset my entire OS on my computer via instructions from the Genius Bar, and reset my brand new phone to stock, and the clock still sets to Cupertino time. I'm in a major business hub city, Phoenix, and I have to set my clock manually because when I have it set to "Set Automatically" it always jumps to thinking I'm in Cupertino  California.

    (Apple's version of Maps also thinks my address is in Brazil though too)

  • SubSpace Level 1 (0 points)

    Since upgrading to the new **** IOS 7+ My iphone as been nothing but trouble.

    I've repeatedly restored the iphone to try fix the WIFI issue a lot of people are having..

    NOW I find my iphone is time-warped back to 1970 the year i was born & I can Not change the year.


    So Now that's 2 problems I've got ..the wifi & year & Date. It seems that upgrading to the Troublesum IOS 7

    as been somewhat of a Massive downgrade & now made my Iphone totally useless & just like any other crap phone out there.



    But OP thanks for this work around I shall go try & see if it works now..