Skip navigation

Why doesn't my disk space free up after moving files to an external drive?

49694 Views 35 Replies Latest reply: Mar 6, 2014 1:14 AM by sidssood RSS
  • Sydney_Aus Calculating status...

    I had the same issue and deleting on my desktop and also using external HD as scratch disk for imovie and deleting never shown at all.

    I ran the disk Inventory X and it shows all the files in hlink folder which is used by "Disk Drill" application... How Diskdrill app avoid emptying trash is beyond me and it also very difficult to get rid of it as well.

    I will avoid disk drill as it shows under hand methods to sell its products.

     

    First once Disk Inventory shows the files use it show in the finder and start deleting this horrible hlink folder.

  • Paintedlevis Calculating status...

    I figured out my problem  I kept trying to delete secure mail but it was ghosted... once i had acutall trash in my trashbin showing I tried again and it was no longer ghosted.. I had almost two million in my trash ..took over a week to delete.. but I am good now with lots of room on my drive..

  • j_t_tomlinson1985 Calculating status...

    I have the same issues.

     

    This may sound like a silly solution, but it has worked for me in the past...

     

    I take my mac to work and connect to their network as well. When i take my mac out of the house and away from my network, the space seems to free up again, so when i get home and re connect, the free space is there! No Idea why it doesn't just do it straight away, but it is what i do to show that I have freed up space.

     

    Maybe take the mac away from your house (and network), try connecting it elsewhere, or ven just use it away from home and then bring it back. See if that works?? Obviously make sure you delete your files before you take the mac away from home.

     

    Sorry for such a stupid suggestion, but it worked for me. Good luck and let me know if you find out your solution

  • varr Calculating status...

    After racking my brain and doing a lot of searching I finally found out why my available space was never going up no matter how many files I deleted.

     

    Read this:

    http://toti.posterous.com/hidden-local-backups-with-mac-os-x-lion-filli

     

    It basically has to do with a lovely hidden file that was introduced in Lion that TimeMachine uses to store local backups in when your laptop is away from its normal external hard drive (.MobileBackups) . And apparently the only way to see it is in the Storage tab of the "About this Mac" window (Backups).

     

    Screen Shot 2013-02-27 at 7.52.56 PM.png

    Mine had gotten up to 207GB!

     

    Run this command in Terminal:

    sudo tmutil disablelocal

     

    Here's after:

    Screen Shot 2013-02-27 at 7.57.40 PM.png

    Zero KB! Lovely!

  • chony Calculating status...

    Thank you. Been searching for a solution for a few days. This was it.

  • arinze Calculating status...

    This link: http://toti.posterous.com/hidden-local-backups-with-mac-os-x-lion-filli is no longer available and I'm having the same issue where I delete files off my internal hard drive, yet the amount of gigs used when I check remains the same.  Can you please provide details as to what was said in that link?  It would be REALLY helpful. I'm at a total loss here.

  • varr Level 1 Level 1 (0 points)

    The only thing that you really need to gleen from that page is to run this command in Terminal:

     

    sudo tmutil disablelocal

     

    and it should solve your problem.

  • larkfromwisc Calculating status...

    I've been having this problem, too and I've had a hard time finding answers.  I tried this command in Terminal, and it did the trick!  Thank you very much, varr!

  • ShinyBlueStars Calculating status...

    I ran the command on Terminal and it still wouldn't do anything.

  • katasta Level 1 Level 1 (0 points)

    First off all you must check what uses most of your memory on your mac.

    I did that with Terminal comand:

    du -sh *

    And found out that it was .cleverfiles    (more then 250GB)

    I did some investigation and found out that it was one inecent backup program Diskdrill that was making backups for my files on my mac. So whenever I deleted a file this program saved it. So there is no chance to make any free space while this program on mac. So I had to delted this backup files to make free space and Diskdrill itself.

    When I put comand:

    sudo rm -r /.cleverfiles

    to terminal, everything came back to normal, no more copies, backups or duble files.


    Try to check if you have any backup program like Disk drill. And choose another way to back up your mac, becouse this is going to kill your mac...

  • LauEl Calculating status...

    Hi,

     

    I too did the error of trying DiskDrill and now I don't manage to free disk space.

     

    I tried to put to terminal both commands "sudo tmutil disablelocal" and "sudo rm -r /.cleverfiles" but all I get is:


    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    Password:

     


    However, when I then try to type something after "password", the terminal won't accept anything.

     

    Help would be greatly appreciated. And if you reply to, could I please ask you to do it in rather clear way as I'm no way any computer expert (I didn't even know what is "terminal" until I googled it just now when this IDIOTIC problem came up)...

     

    I've also got rid of the application Disk Drill, thinking that would solve it but as I've just learned it did not.

     

    Thanking you infinitely in advance.

  • LexSchellings Level 5 Level 5 (5,505 points)

    Do NOT use Onyx for cleaning caches. In fact do not clean caches at all. That does not help; caches are there to make things faster, and caches as they grow, will be handled by the OS: daily, weekly, monthly. When you clean caches they will just grow again, and you win nothing.

    Do not use any "cleaner" app; whatever they promise you, it can only lead to trouble.

    Just remove large files, that you can access from another media when needed.

  • LexSchellings Level 5 Level 5 (5,505 points)

    Do not use Terminal whn you don't understand it.

    Example: when you type "something" after "password:", it will be accepted or not without showing anything, you just hit Enter after typing. As long it is not your account password, it will again ask for "password:"

    Ask somebody here what exactly must be done to stop local snapshots. Or read the famous pages about TimeMachine by Pondini (they may no longer be available since he died shortly).

  • LauEl Level 1 Level 1 (0 points)

    Thanks but I haven't even tried to clean caches.

     

    My trash is empty but still I can't see on my disk new 30GB (at least) space that should be there now.

     

    Another thing I found, but don't manage to get rid of: I found in the Library -> Application Support -> CleverFiles and in that folder an application BackService. I threw it in the trash but when I try to empty trash bin, I get "The operation can't be completed because the item "BackService" is in use.

     

    How do I disable this BackService???

  • LauEl Level 1 Level 1 (0 points)

    Terminal + password: the system doesn't accept any typing, not even one letter.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.