6 Replies Latest reply: Feb 29, 2012 7:57 AM by The hatter
gidpor Level 1 Level 1 (15 points)

My Macpro quadcore2009 has developed quite a headache. On startup it will reach the point where I can see the desktop image , and instantly the screen reverts to the gray screen - keeps going and does the same over and over. From time to time, when in gray, I get a box saying that if I want the applications to load up to where they had been before shut down, I should click yes, otherwise in so many seconds, the machine will restart.

I have started in safe mode,rebuilt permissions, reset pram, and reinstalled the lion system software from the apple site. Nothing helps. Any ideas?

  • The hatter Level 9 Level 9 (60,485 points)

    Do when you did a clean install? of Lion? or installed over the system?

     

    Sounds like your user account.

     

    Delete and disable login items

     

    Create a new user account

     

    move user account to another hard drive

     

    did you upgrade to lion or clean install and then import via Setup Assistant?

     

    When did it begin?

    Check all the RAM and GPU is fully seated or reseat?

  • Linc Davis Level 10 Level 10 (154,505 points)

    There are two ways to resolve this issue: the hard way, and the real hard way.

     

    The hard way is to do a full-system restore from the last Time Machine snapshot before the problem started. You’ll lose all changes to your documents made since that snapshot was taken. You’ll then have to restore those changes from a more recent snapshot, making sure you don’t restore the problem. As long as you only restore documents, not settings, you’ll be safe.

     

    If you can’t do that, or don’t want to, proceed as below.

     

    Back up all data if you haven’t already done so. There are ways to back up, even if you can’t log in. Before proceeding, you must be sure you can restore everything to the state it’s in now. If you’re not absolutely sure you can do that, STOP.

     

    Briefly, you need to delete a preference file in the home folder of the problem account. That file is:

     

    ~/Library/Preferences/com.apple.recentitems.plist

     

    If you’re an advanced user and you already know how to do that, you can skip the rest of this message. Do it, and try again to log in. Otherwise, read the whole message before continuing.

     

    Step 1

     

    Boot in single-user mode by holding down the key combination command-S at the startup chime. If you’re using an external USB keyboard, it must be plugged directly into a built-in port on the Mac, not into a hub. Release the keys when you see a black screen with scrolling white text.

     

    When the text stops scrolling, and you see a line ending in a pound sign (“#”), type the following command, with the short user name of the problem account substituted for the word “fubar”:

     

    rm /Users/fubar/Library/Preferences/com.apple.recentitems.plist

     

    To be clear, you won’t actually type “fubar” (unless that just happens to be the user name.) You’ll type the short login name of the user. That’s a single word with no spaces.

     

    You must type the command exactly as given, apart from the name substitution, with no mistakes. If you don’t feel able to do that, STOP.

     

    Press the return key. You’ll get an error message about a “read-only filesystem” below what you entered. There must be no other error message. If there is, try again until you get it right. You’ll continue to get the read-only error.

     

    Step 2

     

    Once you’ve entered the command correctly, and received the expected error message, enter the following command:

     

    mount -uw /

     

    Again, you must get it exactly right. This time, there should be no output at all. If there is, you mistyped the command, or something else is wrong.

     

    Step 3

     

    When you’ve done step 2 with no error message, press the up-arrow key until the command from step 1 (rm …) reappears. If you got everything right on the first try, you’ll need to press the key only twice. Make sure the command is correct, then press return again. There should be no output. If there is any, make a note of it and post a reply.

     

    Step 4

     

    Enter the command:

     

    exit

     

    Press return. The text will start scrolling again, and then the system will reboot. Try again to log in.

  • gidpor Level 1 Level 1 (15 points)

    I was encouraged by the advice given here indicating mine was likely not a hardware issue - Unfortunately I was not in luck trying to correct/replace/delete the user account settings. Tried hard but in the end resorted to reformatting the drive and hand restoring from the time machine back up. This of course is painful and time consuming. In the end it worked and I am happy to have maintained a current backup !

    The one unresoled issue is a locked Aperture vault - that I cannot unlock ( the unlock feature remains grayed out, Probably also a user permissions issue, but will post for that on the Aperture forum.

     

    Thank you very much for the assistance.

  • The hatter Level 9 Level 9 (60,485 points)

    Did you unhide the LIbrary so you could access the folder easily and get at preference files?

     

    /Users/myaccount/Library/Preferences

  • gidpor Level 1 Level 1 (15 points)

    Yes I did. Initially I started getting a spinning ball a couple of days ago, and then suddenly the issue I had described up top. I had reinstalled the system software for the apple site , so it was not a clean install to begin with.

    All is well now, and I even just solved my Aperture vault issue as well- I copied the vault back on to the pictures folder in the new user account I had created, and once there, was able to unlock the vault from the get info window.

    Here too I was not thinking and tried to restore directly from the backup I had .

    Thanks again

  • The hatter Level 9 Level 9 (60,485 points)

    Isolating an issue by using another user account

     

    http://support.apple.com/kb/TS4053