7 Replies Latest reply: Mar 8, 2012 3:55 PM by Pondini
brianzk1 Level 1 Level 1 (0 points)

Hey,

 

I have a Time Machine Backup of my whole Lion 10.7 system upgraded from Snow Leopard that I am trying to restore to.  I was doing some dual booting with Ubuntu and had changed the partition size of my Lion system.  I wanted to reclaim tha original size of the HD and get rid of Ubuntu and first tried using the Recovery HD and disk utility tools there.  I couldn't so I just made the drive a single partition again with the 10.6 install disk and I restored from my Time Machine backup. 

 

The restore looks like it all goes well (takes about 4 - 5 hours to restore all files) then asks me to restart.  I restart but the boot up hangs at the gray screen with the Apple logo and the spinning gray wheel.  I can boot into Safe User Mode and I can move around the file system in Darwin and I see my files (and it says I have root access etc.)

 

What could be wrong?  Let's see..... I have no Recovery HD that Lion had made anymore.  Could it be because Lion uses that Recovery HD also when it's booting which Leopard doen't make and that's why I can't boot fully?  In Darwin I've done the fsck -fy command and it looked like it checked everything and it said that "File System Was Modified".  I also did a mount -uw and tried to exit / reboot the sytem (which it didn't) but after a forced shutdown / startup it still hangs at the bootup place mentioned above.

 

http://support.apple.com/kb/HT1427 - This didn't help me much as it doesn't mention about what to do if boot hangs at the spinning wheel stage.

 

Hm.. what could it be?  Should I fully install Snow Leopard and try to migrate files using my TM Lion Backup?  That's silly or woudln't work because it's a newer OS right?  Oh, and I am trying to restore onto the HD that created the TM Backup.  So, shouldn't be an issue there.

 

Any ideas?

 

Thanks for any help in advance

 

Brian


MacBook Pro 13" 2.4 GHz Intel Core 2 Duo, 260GB, 4GB RAM, Mac OS X (10.6.3), MacBook Pro 15" 2.16 GHz Intel Core Duo, 120GB, 2GB RAM
  • 1. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    keg55 Level 5 Level 5 (5,925 points)

    So, let's see.....

     

    You repartitioned your hard drive into 1 partition then restored your TM backup of Lion from you SL install DVD?

    As far are your Lion Recovery HD missing, this is because you deleted the Lion partition which houses both the Lion OS and the Recovery HD (hidden at the end of the Lion volume) when you repartitioned into 1 partition. I'm not sure why you're unable to boot from the TM restore. Did you ceate your new single partition as Mac OS Extended (journaled) and GUID partition table?

  • 2. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    brianzk1 Level 1 Level 1 (0 points)

    Thanks for the reply,

     

    Yea, I confirmed that the partition table was GUID and that the file system was journaled.  I'm thinking I can always try and restore from the next latest backup which was only a few days before to see if that does anything different and move over the latest backed up files once I can log in.

     

    Unless there's another suggestion, maybe I will have to get my hands on a Lion boot disk/ drive to try the restore or install from that?

  • 3. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    keg55 Level 5 Level 5 (5,925 points)

    If you have another Mac with Lion installed, use the Lion Recovery Disk Assistant to create a USB thumb drive with the Recovery HD on it. Then you can boot from that and try your restore. Otherwise you would have to redownload Lion and before continuing with the install, capture the InstallESD.dmg file and create a bootable DVD or thumb drive. There are several sites with instructions of how to do this. Here is one.

  • 4. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    Michael.Raymond Level 1 Level 1 (0 points)

    For me it is easier to simply restore your system using your Snow Leopard DVD and reinstall Lion from the App Store.  Reboot into Recovery Mode (command+R) and choose to recover from a Time Machine backup.

  • 5. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    brianzk1 Level 1 Level 1 (0 points)

    Yea, thanks all.  I ended up created a Lion Recovery Disk on a USB via the Lion Recovery Disk Assistant using  a friends OS X 10.7 install. 

     

    I ended up just doing a clean install and then importing all of my information over... it turned out better I think because since then my MBP has been running a little quicker.  I suppose doing the fresh install have it a solid directory and everything.  When I do 'Repair Disk Permissions' in Disk Utility, I only have a few corrections that are made compared to how it used to be.

     

    Thakns again guys!

  • 6. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    keg55 Level 5 Level 5 (5,925 points)

    Glad to hear you're up and going again. Clean installs, for me, have always been the way to go. I've always had issues with installing a new OS on top of the older one.

  • 7. Re: Restore Lion TM Backup w Leopard (no Recovery HD)
    Pondini Level 8 Level 8 (38,720 points)

    brianzk1 wrote:

     

    Hey,

     

    I have a Time Machine Backup of my whole Lion 10.7 system upgraded from Snow Leopard that I am trying to restore to. 

    If you backed-up to a directly-connected external HD, with the GUID partition map scheme, with 10.7.2 or later, there's a copy of your Recovery HD on the TM drive.  You can use it to restore from your Lion (or previous) backups.

     

    See the green box in Using the Recovery HD for details.