12 Replies Latest reply: Jan 1, 2013 4:14 AM by jasonsmith17
tryphonofgerry Level 1 Level 1 (15 points)

Hello!

 

I have the following hardware setup:

1 - A Macmini 2009, Ethernet wired to my router which allows the connection to the internet;

2 - An HP Deskjet printer, USB connected to the Macmini;

3 - My wife's laptop PC, WiFi connected to my Mac.

 

My Macmini handles the internet connection the traditionnal way (Ethernet and PPoE) and has a static IP on it.

(Why a Static IP? Because I run my own Webserver.)

 

I set up a WiFi Home Network in order to allow my wife sharing both my Internet Connection and the Printer Connection.

 

Everything run well: fast and smooth. The PC has Internet and Printer access.

 

Problem is:

After each restart, I must re-create the Airport home network.

System Preferences-->Airport doesn't memorize the name, parameters and credentials of this network.

 

How can I fix this?

 

Many thanks in advance for your replies!

 

Best regards

 

Gerry


Mac mini, Mac OS X (10.6.8), iPhone (iOS 5.0.1)
  • pcbjr Level 2 Level 2 (265 points)

    Not sure if this will help, but:

     

    In System Prefs>Network>Airport, is the "Remember networks this computer has joined" box checked, and the "Disconnect when logging out" box unchecked? Then rebooted?

     

    Have you deleted the com.apple.airport.airportutility.plist in your home folder Preferences and/or com.apple.AirPortBaseStationAgent.launchd from your Root System Preferences, and then rebooted?

     

    I'd try them one step at a time.

     

    And on the last one - make sure you have a current TM update in case com.apple.AirPortBaseStationAgent.launchd file does not recreate itself on reboot, so you can restore it.

  • tryphonofgerry Level 1 Level 1 (15 points)

    Hi "pcbjr"!

     

    Thank you very much for your interest in my concerns.

    But the problem remains.

     

    In the "Advanced" options, the network I created is present.

    But it doesn't appear in the menu "Network Name" on the main interface of Network-Airport Preferences.

    No matter the "Ask to join new networks" Checkbox is checked or not.

     

    As I said in my first posting, Airport is unable to remember the network and to propose it in the "Network Name" Menu or to re-connect automatically to it.

     

    I did everything you suggest:

     

    "In System Prefs>Network>Airport, is the "Remember networks this computer has joined" box checked YES, and the "Disconnect when logging out" box unchecked? YES Then rebooted? YES"

     

    "Have you deleted the com.apple.airport.airportutility.plist in your home folder Preferences and/or com.apple.AirPortBaseStationAgent.launchd from your Root System Preferences, and then rebooted? YES"

     

    "I'd try them one step at a time." Of course...

     

    "And on the last one - make sure you have a current TM update in case com.apple.AirPortBaseStationAgent.launchd file does not recreate itself on reboot, so you can restore it."Of course again...

     

    This is driving me quite nuts!

  • tryphonofgerry Level 1 Level 1 (15 points)

    I was wondering if a command line could exist which could force Airport Preferences to memorize a network created on the computer...

    I'm quite good in Terminal.

  • boink boink Level 2 Level 2 (280 points)

    move contents of /Library/Preferences/System Configuration to desktop, restart your computer, create the airport network, click apply and reboot.

     

    I'd rather get an airport express for this actually.

  • tryphonofgerry Level 1 Level 1 (15 points)

    Thank you for your recommendations which I applied.

    Alas, unsuccessfully... No change at all...

     

    Do you really think I need and should buy an Airport Express?

  • FrenchToast Level 3 Level 3 (645 points)

    Do I understand correctly: your Mac Mini is connected both in Ethernet and WiFi at all times, and you've enforced a fixed IP address? If so, it's normal that the WiFi address gets reset on startup, since Ethernet is natively started at kernel level on OS X, while Airport needs some extra extension to run. Start in verbose, and you'll see your Ethernet NIC starting up long before the Airport chip is activated.

     

    Again, I must have misunderstood, because I don't see the point of connecting your Mac Mini in Ethernet and WiFi at the same time.

  • tryphonofgerry Level 1 Level 1 (15 points)

    Salut, compatriote !

    :-)

     

    No, you don't.

     

    Step 1:

    If you carefully read my first post again, you'll notice that the Macmini is Ethernet connected to the Router and... that's it.

    The static IP has been set up by my ISP.

    I establish my Internet connection from System Preferences-->Network-->PPoE using the credentials recognized by the ISP.

    The connection to the Internet is only handled by the Macmini.

     

    Step 2 (completely different and independent):

    The WiFi Connection is only used to allow my wife's PC to share the above described Internet Connection and also to have the ability to use the Printer which is USB connected to the Macmini.

    It's a small WiFi Computer-to-Computer Network.

    I set it up using System Preferences-->Network-->Airport-->Create Network WEP Password.

     

    Hope this will help you to solve the lack of memorization by System Preferences-->Network-->Airport of the WiFi Computer-to-Computer Network

  • tryphonofgerry Level 1 Level 1 (15 points)

    Oooops!

    I forgot to thank you for your reply.

    I do it NOW!

    :-)

     

    So sorry...

  • boink boink Level 2 Level 2 (280 points)

    tryphonofgerry wrote:

     

    Thank you for your recommendations which I applied.

    Alas, unsuccessfully... No change at all...

     

    Do you really think I need and should buy an Airport Express?

     

    looking into electricity savings that you'll accumumulate from having your mac mini on to act as a DHCP server, router, and as a print server  versus consumption of an airport express should be a good reason. it will make the mac mini live longer too.

  • pcbjr Level 2 Level 2 (265 points)

    I can't see what an Express would do other than extend your range.

     

    I'm no Airport sluth, but have stumbled my way through problems in the past.

     

    Have you tried creating a new "test user" and seeing if the problem persists? It may be something in your Home directory that is causing the problem, and this is a good way to test.

     

    Also, have you reinstalled 10.6 from your SL install disc, and then updated via Software update (using the 10.6.8 Combo)? That won't affect or effect your data, but may repair something hidden deep. Remember, if you do this - have a solid backup (I use SuperDuper) so you can roll back to where you were, should a reinstall mess things up.

  • boink boink Level 2 Level 2 (280 points)

    pcbjr wrote:

     

    I can't see what an Express would do other than extend your range.

     

    I'm no Airport sluth, but have stumbled my way through problems in the past.

     

     

    he is sharing his internet connection via wifi to the PC. meaning, the router is only a wired one. the airport express' usb port will act a print server.

     

    pcbjr wrote:

     

    Have you tried creating a new "test user" and seeing if the problem persists? It may be something in your Home directory that is causing the problem, and this is a good way to test.

     

    creating a new user account wont help. network preferences are global stuff.

  • jasonsmith17 Level 1 Level 1 (0 points)

    Thanks very much pcbjr

    All was working fine with my wifi until I went away for Christmas, since I've been back I have to plug in the ethernet despite doing all the usual things to solve the 'connection timeout' problem.

     

    I've just deleted the com.apple.airport.airportutility.plist file and everything is fine again. Hurrah.