Previous 1 2 Next 18 Replies Latest reply: Jun 29, 2012 12:28 AM by Sunshine65
Catie Level 1 (5 points)

I have a MacBookPro from 2006. Recently had to get a new power cord. If I run the computer on the battery

and then plug the cord into the computer, the battery does not charge. The computer will shut down as

the battery dies and then the cord will start charging. Quite irritating as I have to shut down the computer to get the

computer to recognize the power cord.


Has anyone else had this happen and what can I do to remedy the situation?


MacBook Pro, Mac OS X (10.4.11)
  • John Galt Level 8 (45,943 points)

    Try an SMC reset. Jusifications for resetting the SMC are many, and include the following:


    The computer doesn't respond to the power button when pressed.
    A portable Mac doesn't appear to respond properly when you close or open the lid.
    The computer sleeps or shuts down unexpectedly.
    The battery does not appear to be charging properly.
    The MagSafe power adaptor LED doesn't appear to indicate the correct activity.

  • Catie Level 1 (5 points)

    Reset SMC by removing battery, etc., last night. Thought it might have worked.

    This morning, started up the computer, unplugged the power cord, left it out for a few minutes so it was running off the battery,

    then plugged it back in. The green light on the cord did not go back on and it was running off the battery with the power cord plugged in.

    I shut the computer down and then the power (green light on) started working.



    Am I misunderstanding the way the power and battery work, do I need to reset SMC again, or do I just learn to live with this quirkiness?



  • Andrew Wolczyk Level 5 (5,220 points)

    Is this an apple charger or a cheaper aftermarket one?

  • Catie Level 1 (5 points)

    Apple charger. It is a bit different from the old charger, new design.

  • carl wolf Level 6 (14,625 points)

    The new power adapter is not working propelry, and you should contact Apple.  When you bring in the power adapter to the store, be sure to bring your computer too.

  • tighanleigh Level 1 (0 points)

    I assumed this was normal, I have bought 2 of the newer designed magsafe chargers in the last 2 years and both of them only start to charge when I close my MBP's lid. It isn't any great hassle as long as you remember that you have to do this.

  • Andrew Wolczyk Level 5 (5,220 points)

    There is a firmware update that addresses issues with the new chargers and older macbooks

  • tighanleigh Level 1 (0 points)

    I tried the firmware update but unfortunately it has made absolutely no difference to the the behaviour of my charger.

  • JoeyR Level 6 (8,280 points)

    Do you have the correct wattage?  Which MacBook Pro do you have (what size)?  What is the wattage on the charger you have?

  • tighanleigh Level 1 (0 points)

    I'm not sure if you want the info from Catie or from me! My MBP is a 17" 2.16Ghz Intel Core Duo purchased in 2007 and my chargers are both 85 watts. I apologise if I'm butting in on Catie's problem but the same thing is happening to me.

  • Catie Level 1 (5 points)

    My MBP is a 17" 2.16Ghz Intel Core Duo purchased in 2006 and the old and new chargers are both 85 watts.

    I no longer have the old one since it was useless. I have had my new cord for about 2 1/2 months.


    Seems to me that the problem was inconsistent at first, meaning sometimes it would charge after being unplugged (without) shutting it down, but now it won't. But maybe I wasn't paying all that close attention to it since it was new I just assumed it would all work well.

  • John Galt Level 8 (45,943 points)

    Have you examined the MBP's charging socket? Perhaps there is some contaminant preventing the plug from seating correctly and making electrical contact?


    I realize this is unlikely, given the behaviour you described, but with all this discussion about firmware etc. it never hurts to check the obvious.

  • Catie Level 1 (5 points)

    Yes, I did check the charging socket. It all seems to be fine.


    I know this is strange, but I have unplugged the power cord at the power source a few times rather than from the

    computer, and then plugged it back in. It seems to work then!


    Thank you for all your help. I think I may just have to live with the quirkiness.

  • tighanleigh Level 1 (0 points)

    Do you actually have to shut down your MBP? I have the same problem but all I do is close the lid before plugging the magsafe into the MBP you can then hear it power down and the magsafe light will illuminate. Once this has happened I open the lid and carry on from the screen or application I left - I have never needed to shut down the computer to solve the problem as I only need to let it go to sleep. Hope this is of some help

Previous 1 2 Next