12 Replies Latest reply: Feb 21, 2013 10:35 AM by mabou
Studio Engineer Level 2 Level 2 (445 points)

Hi...

 

as the header suggests...

 

I have millions (litterally) of those warnings in the OS X console while using FCPx... They appear MORE often the farther I am zoomed in on the timeline..

 

here is the warning, in case any of you know how to interpret it:

 

3/2/12 2:22:57.861 AM Final Cut Pro: FigTimeHalve: WARNING: Halving FigTime 12959999/1845569550 is falling back to FigTimeMultiplyByFloat64 - loss of precision

 

 

I constantly watch the console since starting using FCPx as it is very helpful in trouble shooting.

 

 

I really hope apple is going to fix this because I LOVE this app.

 

 

Thanks for any advise

  • 1. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    furrytoes Level 2 Level 2 (205 points)

    I get these as well, though it's usually condensed to say "this line was repeated 131 times"

     

    It's eventually followed up with an error:

    Final Cut Pro[24545]error: FigTimeGetSampleNumber t.timescale == 0 || Non-Numeric(t) || Invalid(t) || sampleDuration.timescale == 0 || sampleDuration.value == 0 (t=inval, sd=0.041667(100/2400))

     

    But only the programmers can really interpret this in the context of what they're trying to do. A "loss of precision" might be harmless, depends what's happening.

     

    I suppose that the warning repeated 100's of times, might be an issue in itself.

  • 2. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    dinky2 Level 1 Level 1 (10 points)

    I am having the same problem and it eventually hangs up my system with the spinning ball of death. I can only power off/on to restart. I don't think FCP is worth the €300 as it is a very expensive iMovie with some added features and if it hangs up my system I certainly will not be going to use it

  • 3. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    Tom Wolsky Level 10 Level 10 (106,230 points)

    It would help to know the specs of your system and the format and media you're working with.

  • 4. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    dinky2 Level 1 Level 1 (10 points)

    My machine is a 4GB iMac 2.8 GHz dual core. The FCP problem is not only related to spilling the log, but it is hanging up my system constantly, be it during editing or exporting. The only way out is a forced reboot. Pitty, because during the scarce moments it is working, it looks like a really nice program, but in the state it is in now, I wouldn't dream of buying it. Apple don't seem to take the problems seriously, so a soution is not to be expected.

  • 5. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    dinky2 Level 1 Level 1 (10 points)

    To add to the problems I get: today FCPX logged out my user when quiting FCP !!

    Other things:

    - background rendering is done, despite setting NOT to do that

    - random crashes

    - random hang of FCP only

  • 6. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    Tom Wolsky Level 10 Level 10 (106,230 points)

    Didn't say anything about the media or about what you're doing. It sounds like a machine problem, and you have way too little RAM for most things.

  • 7. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    dinky2 Level 1 Level 1 (10 points)

    Uhhhh, I am editing a video.....

     

    Format is HD, length app. 10 minutes. Should work on my machine according to system requirements. I accept some slow response, but not hangs, crashes, system locks and all sorts of other unexpected behaviours. If it can't run on a machine my size, Apple should say so.

  • 8. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    Tom Wolsky Level 10 Level 10 (106,230 points)

    Format is HD

     

    That doesn't say anything, sorry. I'd suggest taking it to an Apple store. I think you have a hardware problem, excerbated by the lack of RAM.

  • 9. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    Spinalman Level 1 Level 1 (5 points)

    I have the same issues.   the whole system slows down once FCPX goes into a loop of errors:

     

    10/07/2012 13:35:14.115 Final Cut Pro: FigTimeHalve: WARNING: Halving FigTime 64799977/1586381250 is falling back to FigTimeMultiplyByFloat64 - loss of precision

  • 10. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    dinky2 Level 1 Level 1 (10 points)

    I give up. FCPX is too buggy. It eats up all RAM (there are messages about memory leaks). Today I tried to export a 2 hour movie and all memory is steadily eaten up by FCPX and at 86% it just dies. After rebooting it appears it has created a 103GB !!!!! movie, which obviously cannot be opened. So its back to iMovie for me

  • 11. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    Spinalman Level 1 Level 1 (5 points)

    Yes I agree.  These bugs make a good product unreliable.

     

    I also had repeated issues with encodes stalling at 66% - even with short 8 minute HD ProRes programmes..  I had tried export, share via compressor, share using compressor settings - yet none could bypass the issues.  I troubleshot by removing certain parts of the timeline and trying to encode. Eventually I managed to get a non-stalling encode.. so added back the clips sequentially. Found one clip that seemed to be a cause.. eventually re-ingested it and the encodes were successful.   Encode times are routinely 3 times realtime on a modern MBPro.

     

    Not a great way to run a professional edit facility.

     

    A colleague suggested moving FCP7 into a separate folder so that it didn't reside alongside FCPX.  That may have helped.

     

    This FigTimeHalve issue is so frustrating.  If only we had just an inkling of what it relates too we could at least have a chance of isolating and working around.  Are there no Apple logs of such issues and what FigTime relates to?

  • 12. Re: My OS Console is Over Flowing with "FigTimeHalve" Warnings
    mabou Level 2 Level 2 (350 points)

    Dang.... same issue with the thousands of "Final Cut Pro: FigTimeHalve: WARNING: Halving FigTime 1943889373/1581300000 is falling back to FigTimeMultiplyByFloat64 - loss of precision" in my console....  usually preceeding  yet another beachball of death.

     

    Of note....

    I have been getting Open GL ERRORS (documented by others in other threads) in the console for days. Randomly ending in a beachball hang.

     

    It is just today that I started seeing the Loss of Precision errors that now fill the console log when I run FCPX.

     

    I notice the Open GL errors whenever I mouse-over a thumbnail, when I apply an effect, when I use the slip tool in the timeline.

     

    This is a big problem in that I need to get my work done, and today is the final day of the project.

     

    Mac OSX 10.7.5

    ATI Radeon HD 5770:


    Model Name:          Mac Pro

      Model Identifier:          MacPro1,1

      Processor Name:          Dual-Core Intel Xeon

      Processor Speed:          3 GHz

      Number of Processors:          2

      Total Number of Cores:          4

      L2 Cache (per Processor):          4 MB

      Memory:          26 GB

      Bus Speed:          1.33 GHz