8 Replies Latest reply: Aug 29, 2014 5:11 AM by nicagando
annfromor Level 1 Level 1

I want to delete a recovered amil folder to big to send from ON My Mac mail folder.  Will not delete.

iMac, Mac OS X (10.7.3), Want to delete the folder won't del
  • Wm* Level 1 Level 1

    The easiest way to do this (credit to Harmen Utrecht) is as follows:

    Problem: Mac Mail keeps recovering same messages over and over again.


    Easy Solution:

    Go to Mail Preferences.

    Select the mail account involved.

    Go to tab Advanced.

    Under "Keep copies of messages for offline viewing" select "Don't keep copies of any messages".

    (Don't worry, they are still on the server.)

    Close Preferences.

    If needed: Delete the problem messages from the Recovered Message folder.

    Close Mail.


    Problem fixed.


    If you want, go back into Mail Preferences and reset the choice back to the old "Keep messages for offline viewing".

    Then, everything will be back the way it was, but the problem messages won't come back.

  • Pirate9 Level 1 Level 1

    So far this has helped! Thank you!! So will this delete all the Recovered Messages that were saved on my MacBook Pro? I don't want them to take up my space!! Thanks!

  • Stg531 Level 1 Level 1

    I did the following above and it did not work for me.  I eventually went into my Google Account through Google (not through my Mac Accounts) and deleted the large file there.  I then removed my email account through Mac/System Preferences and then set it up again.  The large files were gone. 

  • REBARUN Level 1 Level 1

    Thanks so much WM!!!! It finally worked!!!!! Thanks so much.

  • Beuntome Level 1 Level 1

    I tried this process, and so far it seem to have worked. I have not set my messages back to the original format yet.  But Thanks Wm!

  • longApple Level 1 Level 1

    Thanks, Mate. It is working!

  • Grayum63 Level 1 Level 1

    Wm*, Awesome stuff mate. Your way worked for me.

    Thanks ever so much.

  • nicagando Level 1 Level 1



    Looked at the "reveal invisible files" method but it seemed much more complicated. This worked a treat!