8 Replies Latest reply: May 31, 2012 2:23 PM by TXRedneck
Chambec Level 1 Level 1 (0 points)

Hello,

 

I am running Mac OS X Server v10.6.8 on my Mac mini and would like to setup printer sharing. I have a printer connected to the mini via usb and would like to share it over the local network. Any assistance would be appreciated.

 

I looked under "Print & Fax" under system prefrences, but did not see the option for sharing, I also looked under "Sharing," but did not see the option to share. Am I missing the options, or do I need to look somewhere else?


Mac mini, Mac OS X (10.6.8)
  • John Galt Level 8 Level 8 (39,420 points)

    You're not seeing this?

     

    Screen Shot 2012-03-02 at 2.44.27 PM.png

     

    (Lion screenshot but SL ought to be similar)

  • Chambec Level 1 Level 1 (0 points)

    Nope, sorry. This is all I get.

    Screen shot 2012-03-02 at 12.04.31 PM.png

  • MrHoffman Level 6 Level 6 (13,005 points)

    Launch the Server Admin tool and (if it's not already present) add the Print service, and configure it, and start the Print service.

  • TXRedneck Level 1 Level 1 (0 points)

    I do have the exact same problem as pointed out by Chambec.

     

    Also, within the Server Admin tool there is no "Printer Sharing" service available to check. There is a "Print" service available but it is checked already even though the "Overview" tab shows it as unchecked. I tried to deactivate the print service and then reactivate it again but that didn't change anything.

     

    Any advice is appreciated.

  • MrHoffman Level 6 Level 6 (13,005 points)

    TXRedneck: to confirm: you running OS X Server 10.6 Snow Leopard Server?

     

    The picture that Chambec is showing is System Preferences from OS X client, which is generally not how OS X Server administers this sort of thing with OS X Server 10.6.    The approach that Chambec would be using (again, with 10.6 server) involves using Server Admin and not System Preferences, and (again, on 10.6) Server Admin could manage printer queues on OS X Server.

     

    To enable print services within Server Admin on 10.6, select the service, check the box to enable it (if it's not already enabled), and the configure it.  This is what I meant by the "Launch the Server Admin tool and (if it's not already present) add the Print service, and configure it, and start the Print service." reply.

     

    AFAIK, OS X Server 10.7 doesn't have printer administration in either Server Admin or Server.app; when last I checked, that seems to have been removed.   (I wouldn't get too wed to this service, in other words.)

     

    On OS X client and probably also on OS X Server 10.7, the closest mechanism available here involves managing CUPS directly from its web interface, and you can investigate that using a web browser.  Enter the address http://localhost:631/ into the address bar.  (Caveat: I haven't tried getting CUPS to share a printer this way, though - all of the printers I deal with are all network-connected, as host-based printer sharing tends toward the unmanagable mess in my experience.)

  • TXRedneck Level 1 Level 1 (0 points)

    Thanks for replying.

    I'm running Mac OS X Server 10.6.8

     

    I did launch the  server admin but I can't configure the print service. I can only check it or uncheck it.

     

    Screen shot 2012-05-31 at 9.19.29 PM.png

     

    Somehow the "Overview" tab at the server admin  still shows the "print" service unchecked, no matter how often I repeat uncheching and rechecking the print service.

     

    Screen shot 2012-05-31 at 9.19.55 PM.png

  • MrHoffman Level 6 Level 6 (13,005 points)

    In that second image, are you intending to not open the disclosure triangle for the services that are available for the server?  That is the triangle located to the immediate left of the macmini.local bonjour name for the server, in the left column of Server Admin.  Open that disclosure triangle, then click on the Print service, then...

     

    There's a good set of documentation available for OS X Server 10.6.   Look around under here for OS X Server 10.6 documentation and details.

  • TXRedneck Level 1 Level 1 (0 points)

    OMG, thanks a lot. How could I have overlooked this?

    It's working now. Again, thank you very much for the great support.