8 Replies Latest reply: Apr 18, 2014 4:54 PM by chenderson22
DJ Duke Level 1 Level 1 (55 points)

Anyway to disable constantly having to put in your password when you move files to other folders or delete them?  thanks

  • baltwo Level 9 Level 9 (62,195 points)

    Only by changing their permissions, but that might muck up other things. Exactly which ones are you constantly wanting to move and delete?

     

    27" i7 iMac 10.6.8 , Mac OS X (10.7.2), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)

  • DJ Duke Level 1 Level 1 (55 points)

    Seems like all the permissions are messed up.  My Logic files are all locked now and I cant save them.   Other items when I try to move it contantly asked for  password.  I am just trying to delete files from my system or move them.  Seems to be worse when I do anything on the desktop.

     

    I just reinstalled Lion, but that did not help at all.

  • Linc Davis Level 10 Level 10 (172,880 points)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy – do not type – the following line into the Terminal window, then press return:

     

    chmod -R -N ~

     

    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

     

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • Autumnatic Level 1 Level 1 (40 points)

    Try Repairing Permissions with Disk Utility.

     

    http://support.apple.com/kb/HT1452

     

    If that does not help or if you've already tried it(exactly as this article instructs you to do) then try to figure out if this happens only with items in your Home folder.

     

    Did you migrate from an older OS?

     

    Thanks,

    Autumn

  • DJ Duke Level 1 Level 1 (55 points)

    OMG!!  I love you... That did it...!  I actually had reparied disc permissions several time to no avail. Reinstalled Lion to no avail.  Even done the second part of your suggestions to no avail (reboot and reset ACL).  However adding the first step of terminal chmod -R -N ~ repaired it!!!!

     

    THANKS!!

  • tvdowntown Level 1 Level 1 (0 points)

    Hi Linc,

     

    I have followed your helpful advice before on my old MBPro, but now with a new MBPro running 10.8.4, I have nto been able to succesfully accomplish what DJ Duke was able to do.

     

    I have noticed that it is only when I move files into an Alias folder that I get asked to "autheticate," however it does nto ask for a password when I move files into in a non-alias folder.  Should I simplystop using alias folders in 10.8.4?

  • Jun92l Level 1 Level 1 (0 points)

    thank Duke i've done what you've told and it worked thanks.

  • chenderson22 Level 1 Level 1 (65 points)

    Nothing is working for me. I get this message: chmod: /Users/majorhenderson/Library/Saved Application State/com.ted.backintime2.savedState: Permission denied

    when I type the command in terminal.