3 Replies Latest reply: Jun 7, 2012 9:50 PM by Paul Duke1
Bill3 Level 2 (270 points)

I often mail webpages while in Safari.  For the first time today I get a dialog box:


     "Safari cannot create an email message because Google Chrome does not support sending webpages from Safari."


I very seldom use Google Chrome and can find no settings in Chrome or Safari that will let me resume using Safari and Apple Mail to send webpages.





MacBook Pro, Mac OS X (10.7.2)
  • Carolyn Samit Level 10 (102,820 points)

    Hi Bill ...



    Might be your Safari prefeerences need resetting ..




    Go to your Safari menu bar click Safari > Preferences then select the General tab.


    Select Safari from the pop up menu next to:  Default web browser


    Quit then relaunch Safari to test.


    And launch Mac Mail. From that menu bar click Mail > Preferences then select the General tab.


    Make sure Mail is selected from the pop up menu next to:  Default email reaeder


    If you still have problems, try troubleshooting the Safari .plist  (preferences)


    Quit Safari. Go to ~/LIbrary/Preferences. Move the com.apple.Safari.plist file to the Desktop.


    Relaunch Safari to test. If that helped, move the .plist file to the Trash. If not, move it back to the Preferences folder.




    edited by:  cs

  • YES Institute IT Director Level 1 (0 points)

    Hi Bill3 - In case you did not find the other reply to help (didn't solve mine), I found this to do it!


    Mail preference has the Defualt MailReader as Google Chrome. Not sure how that got changed, but I suspect some Chrome setting did it.


    Anyway, changing it back to Mail did it!

  • Paul Duke1 Level 1 (130 points)

    Very happy to find the suggestions here. Thanks Carolyn! I'd been wondering for a while why Chrome had taken over the function of sending links to pages... I find Apple Mail easier to use.


    Your suggestion restored the old function for me. Thanks again!