11 Replies Latest reply: Mar 3, 2012 6:01 AM by R C-R
Smash87 Level 1 Level 1 (0 points)

just installed a freshly new mac OS X 10.6.8
note that i just exchanged my HD after a failed one,

made an update about 1.4 GB, unfotunatly another external bootable HD was plugged in, and i found a small locker on the icon, couldn't access anything anymore on that drive, when i restarted the system normaly, the apple icon keeps spining endless, tried safe mode, load for a while but return to load normally forever....tried to boot from that external HD....same problem!

 

NOTE: my DVD rom doesn't read DVDs, spits them off after i insert them....so it would be difficult to run the set-up DVD

 

i SERIOUSLY need help here! i found that problem around everywhere but seems no one solved it yet!
the sarcastic thing that that external was a backup, and i was restoring everything! **** THE UPDATES!


iMac, Mac OS X (10.6.8)
  • Smash87 Level 1 Level 1 (0 points)

    if my external is locked....what shall i do?! i don't want to lose the data on it?! why this happened although that i haven't done anything to it during the update?

    can i solve it using my windows system?

  • ds store Level 7 Level 7 (30,315 points)

    Calm down a bit and carefully explain from the top, what happened, what you did, what is on what drive, what machine you have and so forth.

     

    Sort of summerize it in a chronological order so we can develop a mental picture as we can't see anything and can only go by what you say.

     

    Thanks

  • Smash87 Level 1 Level 1 (0 points)

    i got a new HD, 1 TB, installed the system normally on it

    was pluging in another external HD for restoring backups

    after copying everything, performed a system update, included items - i don't really remember - of 1.4 GB, installed them, restarted the system, now it opened normally, but there was a little locker on the external drive...and i couldn't access it, although that i even not booting from it, so i went to the root user, to attempt accessing it, but when i logged out from my account, and log in to the root, only the desktop bg appears without menu bar, dock, icons, etc....

     

    so i logged out immediantly from there and got back to my normal admin account...the same problem, no doc, menu bar, icons, etc....just stuck there

     

    so i restarted system and only the apple icon with the spining cirlcle below it keeps spining and the system didn't boot, i tried safe mode, the loading bar load for a while and then disappears and returns to the spining circle again....tried to boot from that external HD but the same problem!!

     

    i may reinstall the system again, but what really concerns me now, about the locker on the external, if it is locke, how can i resolve this problem to get my back up data on it?

  • ds store Level 7 Level 7 (30,315 points)

    Root user is turned off by default for a reason, it leaves your entire machine open to chnages/attack.

     

    The initial first user when you install OS X is Admin and it's sifficent for most users.

     

     

     

    If this is a more recent iMac in the last year or two, Apple has installed something on the hard drives for heat control, only Apple can replace the hard drive now.

     

     

     

     

    I think you should first:

     

    Disconnect all drives

     

    1: c boot off the 10.6 disk and use Disk Utility to erase with zero the new internal drive, then partition format Options: GUID, format OS X Extended (j), give it a name and click apply.

     

    2: then quit and install 10.6 on the new internal drive and reboot, then use Software Update to get to 10.6.8

     

    3: next hook up the external drive with your files again and transfer a copy to another drive so you have more backups

     

     

    In your first post you said your DVD drive is not working, well Snow Leopard can be installed via a USB key, but you will need another Mac to copy the 10.6 DVD to the USB

     

    http://www.maciverse.com/install-os-x-snow-leopard-from-usb-flash-drive.html

     

    Once you have that you can hold option key and boot from the USB and install it.

  • Smash87 Level 1 Level 1 (0 points)

    how to use disk utility when i can't boot in either the external or internal HD or load the installation DVD?!

    i have a pc machine, it can see the DVD, can i do something here?!
    is there a way that i can make a start up flash drive?!

  • ds store Level 7 Level 7 (30,315 points)

    Apple didn't cut off holding the option key and booting a external clone.

     

    What is on the external drive? Is it TimeMachine that was on 10.7 previously?

     

    I don't have enough information here what you had, what your were trying to do and where is everything now?

     

    Were you trying to revert back to 10.6?

     

    Please more information.

     

    Details please. thank you.

  • Smash87 Level 1 Level 1 (0 points)

    no it was just a normal data, libraries, etc....i copied them and everything was ok

    i made the update to the internal HD system

  • ds store Level 7 Level 7 (30,315 points)

    Smash87 wrote:

     

    no it was just a normal data, libraries, etc....i copied them and everything was ok

    i made the update to the internal HD system

     

    Well if your DVD drive doesn't work, how then did you get 10.6 onto the new internal 1TB drive?

     

    Or how did you get 10.6 onto the external 1TB drive?

     

    Still there are glaring lack of details, I'll have to go now as this has turned out to be fruitless.

     

    Post your question once you have figured out what you did.

  • Smash87 Level 1 Level 1 (0 points)

    one important thing i forgot to mention, i click on get info of the main internal HD and changed the permissions to everyone just before i restarted...since then the problem exist...

     

    i tried to repair permissions through single user mode with this:

     

    /usr/sbin/diskutil repairPermissions /

     


     

    but it tells me these lines

     

    "unable to run because unable to use the DiskManagment framework.

    common reasons include, but are not limited to, the Diskflrbitration framework being unavailble due to being booted in single-user mode.

    :/ root#"

  • Smash87 Level 1 Level 1 (0 points)

    HORREEEEEEEY!
    finally did it

     

    seems that it was disk permissions problem from the begining, i just made disk permissions repair through a third party instalation using my pc machine based on this:

     

    http://support.apple.com/kb/HT2129

     

    i could start up my mac remotely, but this took a looooooooooong time of loading - depending on my network connection.

     

    using disk utility/first aid
    http://support.apple.com/kb/TS1417

     

    i choosed my HD volume and clicked on "verify disk permissions", and when completed clicked on "repair disk permission"

     

    when done, restarted my system normaly, and everything was just fine
    yet, still having that issue that my external HD is still locked for unknown reason...i tried disk utility but the verify or repair permissions buttons are inactive....i only wanted to use it for time machine back-up!
    and how to make an emergency bootable flash drive from pc?!

     

    thnx DS for your patience

  • R C-R Level 6 Level 6 (15,930 points)

    Smash87 wrote:

     

    ... still having that issue that my external HD is still locked for unknown reason...i tried disk utility but the verify or repair permissions buttons are inactive...

    Permissions verify or repair are only applicable to HD volumes that have a bootable OS installed on them. (Other volumes lack the database of expected permissions settings, & even if they did it would be invalid.) Also note that it is not necessary to run the verify before running the repair -- the verify is useful only if you want to check permissions settings without changing them.

     

    I strongly suggest that you not try doing anything from a PC that you don't have to -- this may be part of the reason you are having problems with the locked disk. It's OK to use "Remote Install Mac OS X" with a PC's optical drive to reinstall Snow Leopard if you follow Apple's instructions exactly, but don't try a permissions repair this way. Instead, run the repair after the OS is reinstalled from that copy of the OS running on the Mac.

     

    Also, don't use single user mode unless you have to -- this is equivalent to logging in as the root user so the normal safeguards that prevent you form doing things that can damage the OS or file systems of attached disks don't apply.

     

    If you want more useful help with this, you really need to explain everything you have done as clearly & completely as possible. For instance, we still don't know how you managed to install the OS on your replacement internal drive without a working optical drive. If you explain exactly how you did that, it might give us a clue about why you are still having problems.

     

    One other thing: when you say the external disk is locked, do you mean that "Get Info" for it shows a lock icon in the bottom of the window, or that you can't access anything on it? If it is just the lock icon in the Get Info window, this is normal. To unlock it, you need to click on the lock icon & supply your admin user info. However, do not do this to make changes unless & until you are certain the disk's contents are not accessible through the Finder or it can't be selected as a Time Machine backup and you have posted in detail what you did to make sure this is true.