Previous 1 2 Next 18 Replies Latest reply: Jan 26, 2016 1:56 PM by ptbird66
russellfromedinburgh Level 1 (0 points)

As Someone new to Apple I am finding problems. One is that since upgrading to "Lion", when using Safari, it will suddenly expand and become almost unusable.  For example, when filling in a form and the screen suddenly enlarges, I can continue to fill in the form but I cannot submit it. I have to either go back a page, or come out of Safari totally, and restart.  does anyone have an answer to this problem?


MacBook Pro, Mac OS X (10.7.3)
  • b j t Level 4 (3,670 points)
    • To expand to full screen, click the arrows in the top-right corner of an application window:Button for entering full screen
    • To move from one window to another in full-screen view, swipe left and right, or press the arrow keys on your keyboard.
    • To return to standard view, click the arrows in the window’s top-right corner:Button for exiting from full screen
  • russellfromedinburgh Level 1 (0 points)

    This does not tell me how to stop the Safari screen making an uncovenanted expansion and becoming virtyally unusable.

  • Dale Gillard Level 5 (4,365 points)

    Hi

     

    I'm guessing you're double tapping a web page in Safari - this enlarges the screen. It's a feature of Lion called Smart Zoom.

     

    http://support.apple.com/kb/HT4721

     

    I've got a MacBook Pro too. If I use two fingers and double-click the track pad, my Safari page enlarges. I also have a Magic Mouse and when I double right-click it then my Safari web page enlarges.

     

    NB Repeating the same action reduces the Safari web page to a normal size.

  • PeterBreis0807 Level 7 (34,587 points)

    It is an annoying feature of the magic mouse combined with the gesture used for zooming being very close to the scroll gesture.

     

    It is really hard to both get right, and to get out of.

     

    We can expect much more of the same with Mountain Lion.

     

    Peter

  • Carolyn Samit Level 10 (103,365 points)

    Russell ...

     

    Sometimes deleting the cache associated wtih the app can help...

     

    Go to ~/Library/Caches/com.apple.Safari/Cache.db

     

    Move the Cache.db file to the Trash.

     

    Restart your Mac, try Safari.

     

    And since you're running Lion v10.7, most folks are having better luck with Safari by disabling the Lion "resume" feature. It tens to cause issues with the cache.

     

    Open System Preferences > General

     

    Deselect:  Restore windows when quitting and re-opening apps

     

     

     

    edited by:  cs

  • Linc Davis Level 10 (192,897 points)

     ▹ System Preferences ▹ Universal Access ▹ Seeing ▹ Zoom: off

  • ~Bee Level 7 (31,425 points)

    Dale,  I believe you are correct here.  I found my Magic Mouse doing the same thing.  I hadn't realized that when waiting for a menu to come down, or a new page to load, I absent-mindedly tapped the mouse.  With my mouse, that's a zoom.

  • dynalo Level 1 (0 points)

    I am having this same problem on my MacBook Pro. It started a few days ago and I can't make it stop. I lose the window that allows me to insert a url, I lose the navigator bar, and I lose the dock at left side of my window. I can get back these things by clicking on the double arrows in upper right but it's a terrible nuisance. I want the window to remain stationary as it always has. I've cleared the cache, reset PRAM, and reset Safari. No good. What else can I try?

  • russellfromedinburgh Level 1 (0 points)

    As everyone says, the problem is in the mouse.  I changed to a tracker

    pad and that solved the problem of uncovenanted zooms.

  • ~Bee Level 7 (31,425 points)

    Good, I'm glad you came back to tell us that it was tapping the Magic Mouse.

  • dynalo Level 1 (0 points)

    I'm already on a tracking pad. No magic mouse. I have not had this problem until the past few days. Now I can't get rid of it. Am wondering if I accidentally hit some keys that changed a setting?

  • EvaJager Level 1 (10 points)

    I experience the same problem, from time-to-time. I cannot pinpoint what causes it (a certain movement of the mouse or something else...). But pressing cmd and 0 simultaneously restores the previous state. Try it and good luck!

  • SnellsBeachComber Level 1 (0 points)

    Simple solution

     

    system preferences>mouse> turn off smart zoom

  • farkee Level 1 (0 points)

    I use the tracker and the same thing happens on a fairly regular basis.  Pressing cmd and 0 did nothing unfortunately.   Nor did tapping twice return the screen to  normal size.  

     

    LInc Davis,  Thanks for your solution--it worked for me before.  

     

    But this time  my screen size went unusable jumbo size again with the zoom off.   

     

    Still   I did what you said  again --go to System  Preferences,  then Universal Access ,  Seeing  ,  but as the Zoom was already OFF  I clicked it back ON  and the screen size went normal.    Go figure--doesn't make any sense.   But at least the problem was fixed.  

    I then clicked Zoom Off again.   Screen still stayed normal size.

     

    I then went to track pad and for good measure turn off  the fancy finger work 'tricks'  just  in case they played a role in enlarging screen inadvertantly.

     

    Thanks again for the simple fix that is needed time to time for some unknown reason. 

Previous 1 2 Next