Previous 1 2 Next 24 Replies Latest reply: Nov 27, 2015 7:23 AM by boxswatter
rimacuser Level 1 Level 1

Suddenly, when I drag a file to the Trash from my dekptop, I get a warning, "Are you sure you want to delete “XYZ File”? This item will be deleted immediately. You can’t undo this action." I wasn't having this problem until yesterday.

 

I have run Disk Utilities, verifying disk and repairing permissions, and even resinstalled Lion, but the problem continues. Curiously, if I allow someone to sign in as a Guest, the Trash works fine for them but that obviously doesn't solve my problem.

 

What do I do?

  • shldr2thewheel Level 7 Level 7

    open finder>finder preferences>advanced tab>uncheck "show warning before emptying the Trash".

  • rimacuser Level 1 Level 1

    shldr2thewheel, your suggestion would get rid of the warning. That's not the issue - in fact I like the warning.

     

    I want to put things in the trash folder and have them stay there until I WANT to empty the trash - not delete automatically simply oupon dragging them to the trash. I'm going to try jsd2's solution and will report back.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy – do not type – the following line into the Terminal window, then press return:

     

    chmod -R -N ~

     

    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

     

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • suthercd Level 1 Level 1

    Are the files from a network drive? If so, they will always be deleted immediately.

  • macjack Level 9 Level 9

    Choose your Home folder "Get Info" (command-i) and be sure you have "read & write" in the Sharing & Permissions section. Check under "General" section to be sure it isn't locked. If that is correct, launch Applications/Utilities/Terminal and at the prompt copy & paste this command…

    mkdir ~/.Trash

    If you get a message that the folder already exists, copy & paste these commands...

    sudo chown $UID ~/.Trash

    Press return Enter your admin password (it will be invisible) Press return.Then enter

    chmod u+rwx ~/.Trash

    Press return. Log out and back in, or restart.

  • Joyce from Trafalgar Level 1 Level 1

    I had the same problem and I followed the directions here: 

    See

    http://www.thexlab.com/faqs/trash.html#Anchor-Files-46919

     

    It worked!  Thanks!

  • Theo Gluck Level 1 Level 1

    NOPE - I get "undefined" variable.  No prompt for system password

     

    I also went through the steps as listed above in the xlab posting - and still no luck.

     

    My trash prompt remains "delete immediately" without the trash purgatpry until I go in and delete

     

     

    Any other suggestions or am I missing a key point here?

     

    Thanks

  • cuz789lol Level 1 Level 1

    Worked for me! Thanks!

  • Jp Duberg Level 1 Level 1

    Thanks macjack ... setting the admin permission to read & write worked for me!

  • derekk1998 Level 1 Level 1

    Thanks macjack you fixed my problem

  • bodin0231 Level 1 Level 1

    had same issue as original post and followed macjack's solution.  fixed issue right away.

  • R. Lucas Level 1 Level 1

    Same issue with deleted files deleting immediately following asking for password but nothing in Trash.

     

    Followed Macjack's solution and now no password prompt and prevously deleted files showed back up in Trash where I could delete normally!

     

    Thanks!!

  • smkrsm Level 1 Level 1

    I used macjack's method and trash is working properly again.  Thank you.

Previous 1 2 Next