2 Replies Latest reply: Mar 4, 2012 5:52 AM by wooner
wooner Level 1 Level 1 (0 points)

Yesterday I started having problems with my iPhone 4s - there would be no sound when a text or call came through, the ringer buttons on the side of the phone didnt display the volume dashes when pressed, and for most of the day the signal just said 'searching' and would only occassionally connect to the wifi.

 

Tried to plug it into the mac last night (latest operating system, only a few months old) and the phone wasnt recognised on itunes nor would it back up.

 

Gave up, and having left it over night I tried plugging it in to iTunes this morning and after a couple of attempts of unplugging it and plugging it in the phone was finally recognised and I managed to do a back up. As the phone still hasn't been working properly I thought I would try a restore, however the phone is now stuck in 'recovery mode' the iphone screen just shows the connect to itunes picture, although its plugged in to the mac, nothing is happening. The phone is now stuck in no mans land and I can't get it to connect to iTunes, the couple of occassions it did connect it wouldnt restore and just came up with error code 1604.

 

I've tried different usb cables and different usb ports and have never had a problem connecting until yesterday, have also tried to restore the phone by pressing the home and power button but I cant get past the connect to itunes screen.

 

Am at a loose end as to what to do now... any help/advice appreciated.

 

Thanks


MacBook Pro (13-inch Early 2011), iOS 5.0.1