5 Replies Latest reply: Oct 22, 2012 7:08 PM by cam81222
cloudofeyes Level 1 Level 1 (0 points)

My dear iBook G4 died 2 months ago so my dad, while visiting me in Sweden, brought me his old macbook. However he forgot the new admin password he set when he reinstalled OS X a few weeks ago. I don't need the password to log in, but it's recquired to install new apps. Since I don't have the OS X installation DVD here, I cannot reinstall from scratch... Is there a way to retrieve the lost password?

 

Tack så mycket,

 

Éric


MacBook, Mac OS X (10.6.8), 2.4 GHZ Intel Core 2 Duo, 2Gb RAM
  • Frank Caggiano Level 7 Level 7 (25,720 points)

    See Mac OS X: Changing or resetting an account password

     

    Just realized it needs the install disk

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    OK this should work (found at numerous web sites) tried on Lion.

     

    Note this procedure will make the mac think it is being booted for the first time. You will need to enter in your registration information again. This procedure will create a new admin account, you will supply the information for the name of the account. Do not use the name from an existing account. Create a dummy account. Once the procedure is done you will log into this dummy account and change the password on the existing admin account.

     

     

    Boot into single user mode:

    1. Reboot
    2. Hold comand + s down after you hear the chime.

    You will see a black screen and a bunch or writing scroll past. Then you will get the single user prompt.

     

    When you get text prompt enter in these terminal commands. Type return after each line

    • mount -uw /
    • rm  /var/db/.AppleSetupDone
    • shutdown -h now

     

    Now reboot the machine, enter the registration and dummy account information. Ignore the system setup screen and then  using System Preferences->Users & Groups change the password of the original admin account.

     

    You can  delete the dummy account and just use the original admin account once you know it is working.

     

     

    good luck

  • cloudofeyes Level 1 Level 1 (0 points)

    I tried this and terminal answered something like :" no such file or directory exists". Then I realized that maybe there were no password set up at all to strat with, and it was the case!

     

    Thanks! I know what to do next time it happens for real.

  • mkane1983 Level 1 Level 1 (0 points)

    Will this also work with Mac OS X version 10.6.8?

  • cam81222 Level 1 Level 1 (0 points)

    Will this work on Snow Leopard?

    thanks.