9 Replies Latest reply: Mar 11, 2012 6:31 PM by Linc Davis
Robens Level 1 Level 1 (0 points)

I bought my 27" iMac (2.7 GHz Intel Core i5, 4GB RAM) maybe 6-7 months ago...and it has had NO problems. Even after updating to Lion. Smooth.

 

But after the most recent graphics firmware update (Feb 29) and software update (late Feb/ealry March 2012...can't remember exact date)...now my iMac is so sluggish! Running more than one application really makes my iMac run slow. And I'm not talking about Photoshop...I'm talking about Firefox, Safari, Mail, iTunes. Basic ones. Especially bad when I play video...very choppy.

 

Any clue what's going on? I ran Disk Utilitiy (all good, repaired permissions), Clean My Mac, CCleaner...all say good and healthy. So I am at a loss.

 

Any help would be greatly be appreciated. I'm still under warranty...but I don't think I need to bring it in do I?

 

Thanks!


iMac, Mac OS X (10.7.2)
  • vea1083 Level 3 Level 3 (685 points)

    Hi and Welcome to Apple Support Communities,

     

    I would suggest a few things.

     

    Run a Permission and Disk Repair:

    To do this turn on your Mac and hold the "Option" key. You'll see your bootable partitions, select the one that says "Recovery HD". Once you get in the Recovery HD select the Disk Utility option, that should launch the Disk Utility App. Once you are in the App select the Macintosh HD and in the "First Aid" tab select the "Repair Permissions Option" after that, run a disk verification. Click "Verify Disk" and if there are errors click the "Repair Disk" option until no errors are reported.

     

    Reboot your Mac.

     

    If the issue persists, I would suggest visiting your nearest Apple Store to have your iMac cheked. You can make an appointment at your local Apple Store Genius Bar here.

     

    Hope this helps!

  • macjack Level 9 Level 9 (50,625 points)

    There are some simple troubleshooting steps you can take.

     

    Be sure you drive is not overly full. Rule of thumb would be over 85%.

     

    (First, be sure you have a good backup, or create one now.)

     

    Create a new User go to System Preferences > Users & Groups > "+" (make it an admin acct) and test the apps in this new account, if they work the problem is isolated to your User and not systemwide.

     

    If the issue is limited to your user account try starting up in Safe Mode  (It will take more time to startup because it runs a directory check.)

     

    If your apps functions correctly that way, go to System Preferences >> Accounts >> Login Items and remove them. Boot normally and test.

     

    If the issue is systemwide then, you may be able to repair by booting cmd-r to your recovery Volume and re-installing Lion. This will be an "install in place" and shouldn't effect your data and settings.

  • Linc Davis Level 10 Level 10 (154,575 points)

    Please read this whole message before doing anything.

     

    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software – potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions – they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Copy or drag – do not type – the line below into the Terminal window, then press return:

     

    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
    

     

    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.)

     

    Step 2

     

    Repeat with this line:

     

    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
    

     

    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.

     

    Step 3

     

    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
    

     

    Step 4

     

    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
    

     

    Important: If you synchronize with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5

     

    osascript -e 'tell application "System Events" to get name of every login item'
    

     

    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer – no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • Robens Level 1 Level 1 (0 points)

    Hi, I tried what you suggested...but it says my HD appears OK. I then checked the "Verify Permissions", but as I do this from time to time as I install new software...it was mostly ok (just one issue that I then repaired). So I guess it's not a hard drive issue. When I restart my computer...everything goes back to normal...but then gets sluggish with time. Maybe that suggests something else. I will try what the others have suggested (3rd party software causing problems as Linc Davis suggested) and see if that fixes it up. If not, I'll bring it in to get checked before my warranty is over. ;-)

     

    Thanks a million for your help though!

  • Robens Level 1 Level 1 (0 points)

    Hi MacJack, my drive is only about 25% full (keep most of my movies, photos, and music on a external HD)...so I think that shouldn't be the issue. I noticed that once I restart, the computer seems okay again...just gets sluggish with time. I think I will try what you suggested the next time it gets sluggish...I'll switch to a different user (already created a guest user) and see if it still feels sluggish. If so, I will then proceed to your suggestion to remove the Login Items from the main account and see if that helps.

     

    I will also try the terminal commands that Linc Davis suggested to see if it is a 3rd party app that is slowing my system down too...

     

    Thanks again!

  • Robens Level 1 Level 1 (0 points)

    Hi Linc Davis,

     

    I am trying the Terminal commands as you suggested. I am copying and pasting the output below:

     

    Step 1 output:

     

    com.Cycling74.driver.Soundflower (1.5.1)

     

    Step 2 output (after password):

     

    com.microsoft.office.licensing.helper

    com.machangout.glims.loader

    com.citrixonline.GoToMyPC.CommAgent

     

    Step 3 output:

     

    com.citrixonline.GoToMyPC.LaunchAgent

    com.adobe.CS4ServiceManager

    com.macpaw.CleanMyMac.volumeWatcher

    com.macpaw.CleanMyMac.trashSizeWatcher

    com.macpaw.CleanMyMac.helperTool

    com.google.keystone.user.agent

     

    Step 4 output:

     

    /Library/Components:

     

     

    /Library/Extensions:

     

     

    /Library/Frameworks:

    AEProfiling.framework

    AERegistration.framework

    Adobe AIR.framework

    AudioMixEngine.framework

    GlimsAdditions.framework

    HPDeviceModel.framework

    HPPml.framework

    HPServicesInterface.framework

    HPSmartPrint.framework

    NyxAudioAnalysis.framework

    PluginManager.framework

    iLifeFaceRecognition.framework

    iLifeKit.framework

    iLifePageLayout.framework

    iLifeSQLAccess.framework

    iLifeSlideshow.framework

    net.juniper.DSApplicationServices.framework

    net.juniper.DSCoreServices.framework

    net.juniper.DSNetworkDiagnostics.framework

     

     

    /Library/Input Methods:

     

     

    /Library/Internet Plug-Ins:

    .DS_Store

    AdobePDFViewer.plugin

    Flash Player.plugin

    GlimsAdditions.webplugin

    JavaAppletPlugin.plugin

    OfficeLiveBrowserPlugin.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    SharePointBrowserPlugin.plugin

    SharePointWebKitPlugin.webplugin

    Silverlight.plugin

    flashplayer.xpt

    huludesktop.webplugin

    iPhotoPhotocast.plugin

    net.juniper.DSSafariExtensions.plugin

    nsIQTScriptablePlugin.xpt

     

     

    /Library/Keyboard Layouts:

     

     

    /Library/LaunchAgents:

    com.adobe.CS4ServiceManager.plist

    com.citrixonline.GoToMyPC.LaunchAgent.plist

    com.machangout.glims.agent.plist

     

     

    /Library/LaunchDaemons:

    com.apple.remotepairtool.plist

    com.citrixonline.GoToMyPC.CommAgent.plist

    com.machangout.glims.loader.plist

    com.microsoft.office.licensing.helper.plist

     

     

    /Library/PreferencePanes:

    Flash Player.prefPane

    GoToMyPC.prefPane

    Perian.prefPane

     

     

    /Library/PrivilegedHelperTools:

    com.microsoft.office.licensing.helper

     

     

    /Library/QuickLook:

    GBQLGenerator.qlgenerator

    iWork.qlgenerator

     

     

    /Library/QuickTime:

    AC3MovieImport.component

    AppleIntermediateCodec.component

    AppleMPEG2Codec.component

    Perian.component

     

     

    /Library/ScriptingAdditions:

    Adobe Unit Types.osax

    Glims.osax

     

     

    /Library/Spotlight:

    GBSpotlightImporter.mdimporter

    LogicPro.mdimporter

    Microsoft Office.mdimporter

    iWork.mdimporter

     

     

    /Library/StartupItems:

    Aladdin

     

     

    /etc/mach_init.d:

     

     

    /etc/mach_init_per_login_session.d:

     

     

    /etc/mach_init_per_user.d:

     

     

    Library/Address Book Plug-Ins:

    SkypeABDialer.bundle

    SkypeABSMS.bundle

    YMsgrCallABPlugin.bundle

    YMsgrMsnABPlugin.bundle

    YMsgrSmsABPlugin.bundle

    YMsgrYimABPlugin.bundle

     

     

    Library/Fonts:

     

     

    Library/Input Methods:

    .localized

     

     

    Library/Internet Plug-Ins:

    BrowserPlus_2.9.2.plugin

    GlimsAddition.notplugin

    Picasa.plugin

     

     

    Library/Keyboard Layouts:

     

     

    Library/LaunchAgents:

    com.apple.AddressBook.ScheduledSync.ABExchangeSource.1B4BA2C7-8ACA-4857-8BDE-B6F 9698BABA2.plist

    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.1F0D2067-5983-4134-AD50-A70 652DAED7C.plist

    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.A4130F93-370D-42FD-86A0-CD8 4B1494812.plist

    com.google.keystone.agent.plist

    com.macpaw.CleanMyMac.helperTool.plist

    com.macpaw.CleanMyMac.trashSizeWatcher.plist

    com.macpaw.CleanMyMac.volumeWatcher.plist

     

     

    Library/PreferencePanes:

    BrowserPlusPrefs.prefPane

    Growl.prefPane

     

    Step 5 output:

     

    2012-03-11 22:38:01.741 osascript[408:707] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:

              /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper

    osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.

    GrowlHelperApp, Skype, Nokia Multimedia Transfer, Quicksilver, Dropbox

     

    _____________________________________________________

     

     

    Ok...I hope you can see if there are some 3rd party apps that are slowing down my system Linc Davis...please let me know okay?

     

    Thank you very much for your assitance!!!

  • Linc Davis Level 10 Level 10 (154,575 points)

    Please read this whole message carefully, especially the warnings, before doing anything.

     

    WARNING: The changes to your configuration suggested here should be regarded as provisional; they may not solve your problem, or they may remove functionality that you consider to be useful. If a third-party system modification that you want to keep is causing the problem, you’ll have to seek help from its developer.

     

    WARNING: Back up all data if you haven’t already done so. Before proceeding, you must be sure you can restore your system to the state it’s in now, even if it becomes unbootable -- which might happen. If you’re not absolutely sure you can do that, STOP – DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not help, if you ignore this warning.

     

    You should either update or uninstall the following system modification(s), if an update is available from the developer:

     

    N/A

     

    and definitely remove at least the following:

     

    BrowserPlus

    Citrix GoToMyPC

    † CleanMyMac

    † Glims

    Hulu Desktop

    Juniper Network Connect

    Silverlight

    Soundflower

     

    All of the latter must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool provided, if any, or to follow the developer's instructions. In some cases it may be necessary to re-download or even reinstall the software in order to get rid of it. I can't be more specific, because I don't install such things myself.

     

    WARNING: Trying to remove complex system modifications by hunting for files by name usually will not work and may make matters worse. If you can’t remove the modifications any other way, you’ll have to erase your boot volume and perform a clean reinstallation of the Mac OS.

     

    I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future Mac OS updates, so it may not be clear which one is at fault.

     

    Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

     

    If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • Robens Level 1 Level 1 (0 points)

    Hi Linc Davis,

     

    Thank you for your suggestions. I think many of the unnecessary third party softwares might certainly be slowing down my system. I have tried uninstalling:

     

    BrowserPlus

    GoToMyPC

    Glims

    Hulu Desktop

    Sliverlight

     

    CleanMyMac? Really? I find it quite useful application and it has gotten some really good reviews by CNET and various Mac sites (MacWorld, MacNN, etc.). Is there a reasons why you suggest to unstill this application?

     

    Juniper Network Connect I unfortunately need to connect to the VPN with my work...so cannot uninstall.

     

    Soundflower...I cannot find. Either in the applications folder or even if I search on Spotlight. Any idea where this might be hiding?

     

    Thanks again! Hope removing those other programs will help.

     

    OH! Interestingly...when I uninstalled BrowserPlus (via their uninstall option), my computer crashed. So I had to restart manually with the power button. Not sure if that might suggest it was doing something strange with my system or not...

     

    Thanks again!

  • Linc Davis Level 10 Level 10 (154,575 points)

    It's not clear whether you've seen an improvement from the changes you made. If not, you should uninstall the remaining system modifications and test again. I have never used "CleanMyMac" and can't tell you anything about it. It's a modification, and therefore has to be ruled out as a suspect. As for the Juniper client, you can uninstall it temporarily and test. If it's contributing to the problem, you'll have to get help from the developer, or from your IT staff, as I wrote above.