Previous 1 2 3 Next 35 Replies Latest reply: Feb 17, 2014 3:47 PM by Mac OS 9000 Go to original post
  • Mac OS 9000 Level 2 Level 2 (270 points)

    Neville Hillyer wrote:

     

    Mac OS 9000 wrote:

     

    It's not working for me. After I do sudo ln -s /private/tmp /tmp, it says "ln: /tmp/tmp: File exists". Then I try ls -la / | grep tmp again, and it still shows the wrong permissions.

     

    Should I just "sudo rm -rf private && sudo rm -rf private/var/tmp" then remake those directories?

     

    Don't do that.

     

    Have you tried repairing permission?

    I did with no effect at first... then it was fixed after a reboot (which I couldn't do before), not sure if the permissions repair had anything to do with it. However, this is the third time this has happened out of nowhere.

  • Neville Hillyer Level 4 Level 4 (1,855 points)

    My tests indicate that repairs of these files always needs a reboot to be effective. See my earlier post with a script.

     

    The reason I said "don't do that" is because the instruction (sudo rm -rf /private) would destroy your OS. The private folder contains folders other than tmp. These other folders contain files which are required by the OS and would probably have to be replaced by a new OS install.

     

    I am not sure why it happens. Do you use OS 9 on the same Mac? Do you try recovering from utilities such as TimeMachine or Carbon Copy Cloner? It is unlikely that normal applications cause the problem. Do you use any non-Apple utilities to 'clean' your Mac?

  • Mac OS 9000 Level 2 Level 2 (270 points)

    I did restore with Carbon Copy Cloner, but I don't use anything but Disk Utility for maintainance, and I don't have OS 9. Actually, the problem started occuring again today. I fixed it by rebooting without even repairing the permissions. So I might have a different problem. It's rare, so I'm not very worried about it.

  • Neville Hillyer Level 4 Level 4 (1,855 points)

    If my Mac ever did that I would do a clean install before the issue developed into something more serious.

  • WhiteDog11 Level 1 Level 1 (0 points)

    A clean install is great if you don't have too much stuff, particularly third-party applications, on your Mac. But for some of us that is the absolute last thing to try - though I have done it, as I've said above, when nothing else worked. Still, an occasional problems like failing drag and drop and copy and paste functions is a sign of significant damage of one kind or another. If you cannot fix it permanently, chances are it will eventually grow more serious. So you may choose to ignore it or procrastinate dealing with it, but you can be sure that sooner or later it will hamstring your system.

  • Mac OS 9000 Level 2 Level 2 (270 points)

    Actually, I misspoke. I didn't restore with CCC; that was earlier. My current bootup disk is a fresh installation, and I copied over the home folder and my applications with Migration Assistant.

     

    I keep backups, so I'm not worried about risking system stability.

Previous 1 2 3 Next