Previous 1 2 3 4 5 6 Next 89 Replies Latest reply: Jan 20, 2016 3:52 AM by Ebraheem000 Go to original post Branched to a new discussion.
  • RobRoo Level 1 (0 points)

    Software Updater was patched on the iMac last week and is working normally again, so someone must know something definiely for OSX and presumably the other operating systems ? Though a bit of a Catch 22 if you can't receive the patch in the first place ! I haven't checked but are there any manual updates around if the DNS change doesn't work ?

  • MattBieneman Level 1 (0 points)

    My original post referred to iOS, not OS X.

  • RobRoo Level 1 (0 points)

    Agreed but Googling around a variety of Apple products had the problem and the suggestions in this discussion sorted my iMac out. OSX appears to now be fixed, which would imply someone at Apple must have an idea that will help you ? Others are suggesting via iTunes rather than OTA can work if you haven't tried that and I'd guess in that case changing the DNS settings on the PC may indirectly help ?

  • MattBieneman Level 1 (0 points)

    Again, the problem is with iOS, not OS X. It has nothing to do with the App Store or iMacs. iOS is an operating system that runs on iPhones, iPods, and iPads only. Changing DNS settings is a "placebo" cure. It has nothing to do with the problem. I tried it anyway, on the off chance that it would clear the DNS cache. It had no effect. It probably works for some people because they had originally had DNS cache problems, a bad DNS server, or had just been trying when Apple's servers were busy. I have two other iOS devices with identical network settings, one of them an identical device, and they worked perfectly on the same network; and I tried my problem device both before and after the other updates worked perfectly. So it has nothing to do with any network problems or network settings. It is a bug somewhere in Apple's update software.

  • giosdeveloper Level 1 (10 points)

    Matt - As the thread clearly suggests there seem to be two issues.


    1. Some ISPs seemed to (for a time) not resolve the Apple update servers correctly.  You suggest this was placebo.  I assure you it was not.  I could take any iOS device that could see the OTA update and put it on a SKY network (UK) and it would fail to see the update when connected.   This may well be resolved on most networks now, but this was very much a legitimate issue.
    2. The second issue seems to be an iOS software fault.  This fault is getting alot less press as it is uncommon, but this is the issue I had on one of my devices.  No matter what network I connected to, the iPhone would just give the error "Unable to check for update".  As per the answer to this thread, I was able to resolve it by resetting and restoring my device.


    I suspect that you are getting a problem similar to number 2 on your device which is why you are so adamant that the DNS fix is placebo.  There are two separate issues here.

  • Bob Evans Level 1 (0 points)

    My experience for 1. was also very consistent for 3 different devices. If did not configure my router to use the suggested setting for DNS, fail. Configure DNS, succeed. 3 Devices spread across several days. Failed everytime on default ISP settings. Succeeded first time on alternate settings for each device. Using as ISP in the US, by the way.

  • Aymàn The 007 Level 1 (0 points)

    i Have the Same Problem with iOS 6.1 iPhone 4S & iPad 3 ..

  • Stokies993 Level 1 (0 points)

    Just switch to a different wifi network, works for me every time

  • AhmDMCU Level 1 (0 points)

    thanks it helped me too

  • KE0 Level 1 (0 points)

    I tried the first steps, still not working. But I don't want to reset. Maybe it's because iOS 7 is due to come out today. My iPod touch is acting wired all day, randomly opening apps and such.

  • James Jewell Level 1 (10 points)

    I've had the same problem trying to update a friend's iPad 3rd Gen from iOS 6 to 7.0.4. I did a hard reboot to no avail, then I removed the wifi into and reaffirmed my login to the wifi, still nothing. I have two seperate wifi networks, so I switched to the other network and the error message disappeared and allowed me to begin the update. It downloaded the update in about 6 minutes, was Preparing Update for about 8 minutes, the progress bar was beyond 80% done then it stopped and gave me an error thet the update failed. It claimed I needed more space for the update on icloud. Removed need space. Repeated update and everything went along fine.

  • andi technician Level 1 (0 points)

    i had this issue nothing worked for me so i reset my wifi connection totally forget the network and re set up including password let it pick its new range and connection succsess remember if you have connected and backed up in the past a simple reset at minimal level should suffice to test if it is ya wifi then simply use your 3g/4g this may not or will not let you download but will show the update to prove you have no hardware errors or other issues and is simply wifi connection

  • JustMyBrain Level 1 (0 points)

    Done upgrade issue. I've just restarted my internet modem. Updated my IOS 6 to IOS 8.

  • SANKAM84 Level 1 (0 points)

    Sorry but this didn't work on my Iphone 5S.I receive the same error message.then what to do next?

  • Ebraheem000 Level 1 (0 points)

    I am using ISO9.2 but when  i am going to update its showing me an error occurred while checking for a software update.

Previous 1 2 3 4 5 6 Next