Previous 1 2 Next 29 Replies Latest reply: Jul 18, 2014 10:53 AM by PetiteMac
RF03064 Level 1 (0 points)

I am trying to transfer my backup data to a new hard disk and I get this message.


WD 3TB External Disk, Mac OS X (10.6.8)
  • baltwo Level 9 (62,215 points)

    Most likely the new disk needs formatting. Some are factory-formatted as case-sensitive. Macs normally don't use those. Just erase and format it as Mac OS Extended. That should allow you to use it with for your backup data.

  • Pondini Level 8 (38,740 points)

    Most likely, your backups were on a case-sensitive disk (especially if you let Time Machine format it for you).  If so, the drive you copy them to must also be case-sensitive.

     

    Click the partition (indented, under the main line for the old TM disk) via Disk Utility (in your Applications/Utilities folder).  The Format is shown towards the lower left:

     

    Screen Shot 2012-03-07 at 6.46.51PM.png

     

    Format the new drive the same way.  See #1 in Using Disk Utility for instructions.

  • baltwo Level 9 (62,215 points)

    Thanks for popping in. Didn't know that TM formats disks as case-sensitive.

  • Pondini Level 8 (38,740 points)

    Yeah, apparently because someone may want to back up a case-sensitve volume.   We try to advise folks to format drives as case-ignorant themselves, but . . .

  • baltwo Level 9 (62,215 points)

    So, TM defaults to case-sensitive formatting? That's strange, since Macs normally don't use that for anything.

  • Pondini Level 8 (38,740 points)

    Yes, I understand that, but the operative word is "normally."

     

    If TM formatted the drive as case-ignorant, and a user did backups from the OSX drive for a period of time, then wanted to also back up a case-sensitive volume, it would be impossible.  The user would have to erase the drive, losing all the previous backups, or start over with a different one.

     

    By formatting it as case-sensitive, TM can back up  case-sensitive and/or case-ignorant drives. 

     

    There's only one pretty rare situation where a problem arises:  if you've changed the capitalization of some names and try to restore the old versions.   If the case-sensitivity on both volumes is the same, TM (actually, the Finder) gives you this prompt (one for each file, unless you check the box):

     

    shapeimage_7.png

     

    If the OSX drive is case-ignorant, and the backups are case-sensitive, however, it puts up this one:

     

    shapeimage_8.png

     

    One message only, no matter how many files there are, and no names, not even in the log.   So in a few cases, involving many files, it can be a significant hassle.

  • baltwo Level 9 (62,215 points)

    thumbsup.gif As always, thanks for the lesson.

  • TrevorGerzen Level 1 (0 points)

    Glad this thread exists. I was having this exact problem.

  • mollib Level 2 (460 points)

    Thank you for this! I was having this exact same problem. Hadn't yet thought to look at the formatting on the original drive. Thank you!

  • crichards Level 1 (0 points)

    I have run into this issue as well, but unfortunately my data is too important to just format over. Did anyone find a resolution that would permit you to keep and use the backup of your data before formatting the drive?

     

    Thanks for any help or guidance you might offer.

    CR

  • Pondini Level 8 (38,740 points)

    It can probably be dealt with, but in some cases it's quite difficult and time-consuming.

     

    What, exactly, is your situation, and how are the drives in question formatted?  Are any of them network drives?

     

    Are you trying to make backups, restore from backups, copy a set of backups, or what?

     

    What kind of Mac do you have, and what version of OSX it is running?

  • crichards Level 1 (0 points)

    iMac 27" running latest mountain lion 10.8

     

    No network drives; seagate 1.5TB  formatted case sensitive. The backups are irreplaceable since apple has deleted my original drive and data.

     

    My primary drive was just replaced by apple under warranty. The drive hadn't failed but was one that apple had identified as a drive that was likely to fail. I am trying to restore a backup from the 1.5TB. finder sees the backups but gives me the case sensitive error when I try to restore from the drive.

     

    I tried to copy them from this drive to the desktop but got the same error.

  • Pondini Level 8 (38,740 points)

    crichards wrote:

    . . .

    I am trying to restore a backup from the 1.5TB. finder sees the backups but gives me the case sensitive error when I try to restore from the drive.

    How are you restoring?  Are you doing a full system restore, after starting from your Recovery HD?  If not, that's your best bet.  See Time Machine - Frequently Asked Question #14 for instructions and the gory details.

     

    Or are you doing something else (if so, what)?

     

    How are your internal HD and the exernal HD formatted?

  • crichards Level 1 (0 points)

    I've tried restoring both ways. Comman R on power on and by just launching tm

     

    The internal drive is the standard Mac format. I believe it was OS extended journaled.

     

    The external says case sensitive.

Previous 1 2 Next