7 Replies Latest reply: Aug 16, 2013 12:58 PM by doncarlosdon
doncarlosdon Level 1 (0 points)

What is going on here?

I have always used bootcamp and previous OSX successfully with Windows, until LION.  Now I am able to boot to windows from a "power off".power on>option button down.select windows icon HD.  But cannot do so on a simple restart (no HD's icons are displayed), and in system preferences Startup Disk pane..windows is not there, and in disk utility my windws disk is idenitfied by disk0s4 (not mounted, MS DOS Fat, no files, but 100gb size is there).


Perhaps someone has some insight or suggestins on this. 



1) Installed LION using bootcamp.



2) Now, choice for duo boot is only after power down>power up>push option button, if I simply do restart it never shows the duo boot icons (with option key down).



3) Inside of Lion, the windows icon in [I]startup disc in preferences [/I]is missing



4) Disk Utility shows Mac Volume and a Volume titled disk0s4 (not mounted) and format is shown as MS-DOS FAT (but yet in windows 7 it shows it as a NTSF)



Like I said W7 does work fine and I can boot back to LION using the bootcamp icon.



-I have tried disk repair from booting off my USB Utility,  Repair is not possible on the disk0s4 (like I said it does not mount, does not show files, does show the correct partition amount of 100gb.



[B]Here's how it looks. MAC SIDE[/B]



Disk Utility show current drives: Mac and disk0s4






Disk Utility showing disk0s4, not mounted, no files MS DOS(fat)






StarUp disk in preferences. Only Mac drive is shown:




[B]Here's how it looks WINDOWS side[/B]




[B]Here's how it looks from EASUS view:[/B]




Window 7 work fine but I cannot choose a startup disk from inside of Lion nor is there a Duo boot icons if I just hold option from a simple restart (again I do have that duo option choice of displayed hard drive icons, if I start from a power off only).



1) I am guessing that the bootcamp volume disk0s4 is not really formatted as NFTS or is not recognized by LION as an NTFS volume and so it doesn't show it mounted and is not displayed in the disk startup pane; and hence will not show up even with an option button down or a simple restart of mac.



2) Doubtful if there is a way or program that could simple covert the disk0s4 volume to NTSF?



3) I have reinstalled twice ob Bootcamp and had the same results.


I coulld leave the way it is and just power on my mini each tme I want windows, but this shouldn;t be like this correct?


Any thoughts or suggestions are appreciated.

  • doncarlosdon Level 1 (0 points)

    Disregard.   After several days of work on this, I got the matter completely figured out and resolved. 

    Thanks for all of your thoughts suggestions and input that you could have provided

  • The hatter Level 9 (60,925 points)

    I assume you saw and knew that there are:


    128MB EFI along wtih a GPT (GPT is 200MB)


    Windows 7 requires a 100MB system reserved for actual boot


    Lion has its own Recovery Partition. Depends on how you upgraded but could come after Mac HFS.


    Wndows 8 now uses a 300MB (if you use native UEFI booting, but Apple doesn't support that); AND still has 100MB EFI partition (on Windows only too).

  • flyingpostaldude Level 1 (0 points)

    ok I have the same problem. how did you solve it? can you post your solution?


  • mingster Level 1 (0 points)

    Same here, would the OP mind sharing with us his solution to this issue please!! I'm in the exact same situation without a solution...

  • doncarlosdon Level 1 (0 points)


    I see a couple responses/questions after my original post. Sorry, but I never knew they were there until this last question arrived.


    Currently I removed the Bootcamp partition to recover the hard drive space since I really had no use for windows.

    I kinda of forgot the resolution, until I serached posts I made at my macmini forum back then. here is the post, and the soultion was pretty simple and straighforward..


    I also include the post previous to that concerning BootChamp as a way of adding a quick boot icon to you mac menu.


    Hope this helps, let me know.




    My original two post from macmini fourm in 2012......................


    I upgraded the HD on my mac and when I was finished, decided to leave Windows 7 off it for awhile. Two weeks ago, I had a heck of time after I reinstalled to successfully boot into it from within mac. It didn't show up on preferences start up pane, nor did it show up in the Disk Uitlity sidebar........ Very very long story.....but unless you wants specifics....it boiled down to that although W7 was indeed alive and working, the bootcamp partition appeared as a strange volume called disk0s4, an unmountable FATS 32 something or other. Even though W7 was in fact an NTSF volume (that;s what it showed within W7 and thats what it showed even on a third party Easus program.

    Despite help from two apple phone techs and a genius visit....no one could correct this. Lion was loaded repeatedly from USB, self made DVD's, and partitions were expanded, shrunk, created, deleted,(my drive was formatted, reformatted, deformatted, unformatted, downformattted upformatted, and overformatted). LOL....All experts surmised that it had something to do with Recovery partition. When an Apple Tech Supervisor said "Hey now let's try first formatting the entire drive to NTSF, then format over that HFS+, then install LION fresh, set up a dummy mac account and then Bootcamp W7 and then after that works, then migrate your LION backup from time machine.........Yikes, I knew that they had no answer. Rolling Eyes

    As I said......W7 existed and worked great and booted back to LION, but W7 was not seen in DiskUtilty or anything else, hence no restart to W7 from inside Mac was possible. And that was my major issue, every time that I successfully installed W7, as the last step after trying all their nonsense.

    Too many hours lost over this and short of trying a south american shaman, I decided to take a leap and try something simple. Idea Alas, BootChamp. I reloaded a fresh BootChamp copy, and it came through where Apple and a multitude of advice givers could not. Now I can reboot to W7 from inside of my mini. Bootchamp is TOPS !!!!    -Don




    My post concerning BootChamp and it's ability to add a quick boot and icon for windows................


    I was always frustrated by the fact that there was not a reboot icon on the Mac desktop to go to windows (like the Bootcamp icon on the W7 task bar).

    Well "Lo and Behold" check out BootChamp http://www.macupdate.com/app/mac/28468/bootchamp

    Developed by Kevin Wojniak http://www.kainjow.com

    Works great, and easy to install and use. The windows icon is located at the top toolbar.

    I even wrote to Kevin and he responded back to me immediately. Make sure you download the latest version from his sitehttp://www.kainjow.com , and be sure that you uncheck Next Restart Only and leave the check by Launch At Startup, if you want the icon to appear at every restart. It kind of threw me off until I did that.

    The first time you boot to windows it will ask you for your password, then after that it does not any further.

    Makes for one less step when you want to boot to windows from your desktop.

    Bravo Kevin for developing this free tool. This should have came with Bootcamp....perhaps Apple should buy it off of him. -Don

  • mingster Level 1 (0 points)

    Thank you for responding, Don!


    I will look into the BootChamp application, but were you able to fix the "disk0s4" grey drive in Disk Utility so that it became mountable/accessible in the Mac OS side of things? Or figure out the FAT32/NTFS issue?

  • doncarlosdon Level 1 (0 points)

    You know I can't recall and it may sound odd but I almost think that Bootchamp caused the disk0s4 to show that it was mounted. Something did after I ran Bootchamp, because I didn't have to mess with it any further.  I think that the bootcamp drive was actually always mounted which would explain why you could boot it up from the start up option.  For some reason though the partition was screwy and would never display that it was mounted.  But again, seems that it showed it was mouted after adding BootChamp. I have no idea why, but things were fine after that.


    When I finally decided to wipe the Windows/Bootcamp off for good, everything appeared to look okay.


    I know that I could view the hidden partitions such as recovery and the windows disk, using the "debug tab" in disk utility, you have to run the terminal command   defaults write com.apple.DiskUtility DUDebugMenuEnabled 1      After you close and reopen disk utility that Debug tab is now present   Debug>show every partition.   So wghen I added that it always displayed all partitions including recovery and all, iand windows/bootcamp was always there when I looked and it was mounted.  


    The problem as I understand it, was always caused by that addition of the added recovery partition, and the order in which it fell, in respect to Bootcamp partition.


    Also, keep in mind that my mini is a mid-07 C2D and system that can only run up to Lion OS, and that the recovery partition was not native (the recovery partition came as an added update for Lion).  It may or may not have some bearing on this issue.


    It has been over a year since I talked to Apple, perhaps they acknowledged the problem and have an official solution, if any of my suggestions are not useful.  You can ultimately get to a tech if you just are persistent on the phone tree.