Previous 1 2 3 Next 30 Replies Latest reply: Apr 14, 2014 9:30 AM by fruhulda Branched to a new discussion.
NurseMarci Level 1 Level 1

I've read several posts about this issue and would really appreciate if someone could really simplify it down for me . . . .(nicely, please!)


I upgraded to Lion OS. I opened a document that I created pre-upgrade. First problem was, it told me the document was locked and I couldn't make changes, that I didn't have permission to do so.  What?  "The document is locked. If you would like to make changes click unlock." I clicked unlock. Made changes. Tried to save . . .clicked "Save a Version" (this was a new option to me). Got this message, "Document could not be saved, document is locked. Do you want to save anyway?" Clicked "save anyway" and the response was "You do not have permission to change the file."  How is that possible when I was the one who created the file?  Had to open the document in Finder > Get Info, then unlock the document. Did so. Then the box popped up saying "Document could not be auto-saved, document was changed by another application."  I assumed that meant that since I changed it in Finder, I'd have to close the document and reopen it.  It wouldn't let me close it without clicking "save anyway" (which didn't work) or "revert".  Clicked revert. Reopened document. Shortly the message came up again, "Document could not be auto-saved, has been changed by another application."  Tried to "save anyway." Still says I don't have permission, even though Finder > Get Info shows document unlocked with me as holding "read & write" privileges.


Am I going to have to unlock every single document every single time I want to work with it??


Can someone explain what revert, duplicate and save a version mean?  I hesitate to use them b/c I don't want a bunch of duplicate files on my computer.


And now, a file that I've been working with for a few days is telling me it "could not be reverted." What does that mean??


I am relatively new to Mac, I love it but I am frustrated because these changes just came out of the blue.  Any help would be appreciated.



Pages, Mac OS X (10.7.3)
  • NurseMarci Level 1 Level 1

    And now, I can't even get the document off of my desktop. I try to close it, it says "Document could not be auto-saved. Has been changed by another application." Click "save anyway" get "File could not be saved" with no other explanation.  Click "revert" get "document could not be reverted" with no further explanation.


    I think something else is going on here . . . This is getting ridiculous.

  • Dale Gillard Level 5 Level 5

    Have a read of this document to find out about locking, auto save, save a version, etc. Then let us know if you believe there's still an issue with your Mac.


  • NurseMarci Level 1 Level 1

    Thanks for the input. I read that document but I still seem to be having issues with Pages.  Every document I try to work with pops up with a warning saying it cannot be autosaved b/c it has been changed by another application. I click revert and it loses the changes I tried to make.  In addition, when I make changes, sometime another warning will pop up says that I don't have permission to change the document. 

    So I do still there is some other issue going on.

    I don't know what else to do with this.

  • PeterBreis0807 Level 7 Level 7

    I feel your pain and IMHO Apple has made a right mess of a number of Lion "features".


    Something entirely predictable and should have come up in even elementary testing, which maybe Apple skips these days with its absolute certainty in its "rightness".


    Give Apple feedback:


    Menu > Pages Provide Pages Feedback



  • Dale Gillard Level 5 Level 5

    Every document I try to work with pops up with a warning saying it cannot be autosaved b/c it has been changed by another application.


    Have you opened the document in another app? Or Pages?


    I had the same thing happen at work last week. A person swore they did not have the document open but when I screen shared with them, they did.


    I click revert and it loses the changes I tried to make. 


    Have you tried duplicating the document instead? (File > Duplicate, File > Save.) This would save the changes you've made so you wouldn't lose them.


    In addition, when I make changes, sometime another warning will pop up says that I don't have permission to change the document.


    What are the permissions for the document? Can you insert a picture into one of these replies showing the Finder's File > Get Info window for this document?

  • Jerrold Green1 Level 7 Level 7



    My advice is to ignore the warning and Save Anyway. I believe that the warining is a false alarm. I get it from time to time and have never had a problem with going ahead and saving, never reverting.



  • PZS Level 1 Level 1

    I have the same issue and have ignored the warning numerous times for months without resolution.  Any other input?

  • Jerrold Green1 Level 7 Level 7

    Here's an update: I continue to ignore the warning and Save Anyway and I still have not ever noticed a problem, nor have any of the other users here reported a problem arising from ignoring the warning.



  • PZS Level 1 Level 1

    Reverting does seem to save the changes in pages, but for pdfs, I could not keep the changes.  In order to modify I would have to duplicate the doc.  The fix I discovered with an Apple Sr advisor was to email the affected docs to myself, and then for some reason, the issue resolved.  Not sure why this works, but it does.

  • jmelashenko Level 1 Level 1

    I would add that I'm also having this problem.  I can't save a new document to the Desktop, Documents, or anywhere else on the drive for that matter.  As soon as autosave tries to save for the first time, an error message pops up saying it can't be saved because permission is denied.  Permissions appear to be set correctly, for example, the Users documents /Documents folder has permissions set to the User having R/W and everyone having No Access.


    My computer (same image as student computer) has the same permissions set, and I have no issues saving.  I have also run Disk Utility 'Verify Disk Permissions' and 'Repair Disk Permissions'.  There are errors (nothing pointing to User's Documents folder), so I'm not sure if perms are really mangled and that is contributing to this issue.


    Any help would be most appreciated.



  • Number22 Level 1 Level 1

    I have similar problems as described.  I worked on Apple Computers since OS 6.   At no time have I encountered so much nonrequired gimmickry that prevents ordinary word processing functions like making corrections to typing errors, deletions, or saving of the documents and any stage with a simple "Save As...".


    From discussions above it is evident that nobody knows how to handle this.


    Quite frankly I think Apple has some inside Techs who appear to have done everything possible to sabotage the good repute Apple has had with its users in the past, and no wonder its stock has faltered.


    My solution: Use your much simpler e-mail application to type your word processing documents, then copy if you see a need for  an import to Pages.

  • ROGER BURTON Level 1 Level 1

    I agree with number 22 - I've just spent 10 minutes trying to do what I could have done with "Save As" in 10 seconds, it's ridiculous too complicated all I want to be able to do is open an existing document, edit it and save it with a different name, I 'Saved' and was offered no options to rename, it just overwrote the original file so I had to open all versions and renamed one, that didn't work, I then duplicated etc etc ... madness !



  • AKH1 Level 1 Level 1

    Pls, I'm new to Macbook Pro What do u mean use your much simpler e-mail applicatioin to type wp documents then import to Pages.   I don't mean to be stupid here but I just lost a very important document on Pages and I'm sick over it.   Not sure what you mean by 'email application to type up docs then import to Pages'?  Thank you.

  • PZS Level 1 Level 1

    HI AKH1,


    There may be hope!  If your new to mac, and assuming you have lion or mountain lion, then there's a good chance you still have your old document saved in 'versions'.  What is versions?  It's Apple's way to auto-save documents.  You search for older versions as you would backups in time machine.  Do a search for how to use versions and hopefully your doc is still there somewhere.



Previous 1 2 3 Next