9 Replies Latest reply: Mar 11, 2012 9:43 PM by addygarg
pmdykstra Level 1 Level 1 (0 points)

I tried to update to ios 5.1.  The software downloaded, and when I click "Install Now", it "verifies download", then I get an "Unable to Install Update" and that "An error occurred installing iOS 5.1".   The dialogue box gives me options for either "close" or "settings".  I've restarted the iphone to no help.  The software was downloaded directly to the phone via wifi network.


iPhone 4, iOS 5.0.1
  • Michael Black Level 6 Level 6 (18,765 points)

    I had the same thing with my iPhone 4 doing the update over the air on the phone itself.  While the error certainly needs to be more explicit, it was the fact I have restrictions on both my accounts and location services (I disallow changes to both under the restriction settings).

     

    All I did was go into settings, and allow changes to accounts and locations (might have only needed to do accounts, but I just did both) and then went back to try the update again, and it went fine.  It did not even have to redownload it - the updater was cached so it just went right into installing it.

     

    I'm guessing that parts of the update need to be able to alter some code related with iCloud accounts or some such feature, and the restriction setting was not allowing it to overwrite the stuff it needs to.

  • pmdykstra Level 1 Level 1 (0 points)

    I already have the allow changes for both on.  No restrictions were set up. 

  • indianhead Level 1 Level 1 (0 points)

    Hello !!

    For the first time, since I use iPhone, that I am not able to install the suggested up date.

    I use MacBook Pro and iPhone 4, via Wifi or usb cable connected I am not able to "update"

    on the iPhne i get the messsage " Unable to Check for Update" and via USB cable/ITunes, the same happens

    Any suggestions please Thanks.

     

    iPHONE.jpg

  • Michael Black Level 6 Level 6 (18,765 points)

    pmdykstra wrote:

     

    I already have the allow changes for both on.  No restrictions were set up. 

     

    I don't know what else to suggest - it is likely just an individual setting that needs to be changed (on to off or some simple swithc like that), but I don't know what else it could be.  The release notes are here  - http://support.apple.com/kb/DL1504 but they don't give me any insights.

     

    Maybe try connecting via USB to iTunes and see if it works there?  It should not make any difference but then again, it should have worked already.

     

    Sorry - it's an odd (and horribly vague) error and all I know is what worked for me.

  • indianhead Level 1 Level 1 (0 points)

    Michael !!

    Thanks for your help.......I will survive.

  • pejakel Level 1 Level 1 (0 points)

    I'm having the same problem. I'm going to try to plug into the computer and complete the install tonight.

  • indianhead Level 1 Level 1 (0 points)

    .....as I wrote, I did it both ways, Wifi and then USB cable connected to iTunes......nothing resulted.

    Good luck and up date me if you can.

  • Turninthepaige Level 1 Level 1 (0 points)

    I am having the exact same problem. I get the same screen and "network connection could not be established" message. I've never had any problems doing an update before. Help!

  • addygarg Level 1 Level 1 (0 points)

    Hi,

     

    I was trying to update to iOS 5.1 from iOS 5.0.1 on my iPhone 4. I was doing it OTA. Update size was 177mb but after it gets downloaded, it is not installing. For few seconds it says "verifying" but right after that it says cannot update, some error.

     

    Please help me out with what I should do in order to install the update.