Previous 1 2 3 4 Next 80 Replies Latest reply: Dec 17, 2013 10:58 PM by Eme Go to original post
  • tomtheedom Level 1 (0 points)

    holding down 'menu' and 'down' to do a reset worked for me. it obviously didnt work for everybody, but it did for me after recieving the 'please try again later (789)' error message.

  • shenyu Level 1 (0 points)

    For me, the menu + down reboot did not work. However, I tried unplug the power for 15 seconds, and when I went back in, Netflix is working again.

  • diffengr Level 1 (0 points)

    Even hard boot didn't work. I just got this thing, and I'm disappointed, in lots of ways. Neftlix is my primary use case, and needs to be rock solid. I'm pretty sure I'm kicking it back to Apple in my 14-day period, unless there's a significant rev coming out of WWDC.

  • mrl2012 Level 1 (0 points)

    I have tried everything, reset, reboot, go back to factory settings, etc.... and it still does not work.  It says "netflix is not available, please try again later"  but does not have any error number or anything like that. 

    Any ideas why this is happening?  My ATV is gen 3, and netflix works fine on my mac, ipod, ipad, etc.... the problem is just with the ATV.   Thanks

  • Obasi Level 1 (0 points)

    I got mine working.

     

    All you need to do is visit the Netflix site, request a password reset, update your details.

     

    Once done, stream some shows online, then watch the same show on the Apple TV.

     

    Everything starts to work fine after that.

  • SuperSizeIt Level 3 (575 points)

    Tried resetting Netflix Password. Tried Soft Reset. Tried unplugging the ATV3 for an hour, No HDMI, No Power. Tried hard reboot. Nothing. Still get "Netflix is not available try again later".

     

    Two iPad with Netflix logs in and works fine. One other ATV2 in bedroom logs into Netflix and works fine.

     

    It's just the ATV3 that is not connecting all of a sudden. It has been working fine even before the latest OS update was released.  So I updated the ATV3 to see if it will fix it.  Nope. Still get the same message.

     

    So I call Netflix. The rep tells me to uninstall it from ATV... Are you kidding me? Then rep tells me that its not a NETFLIX problem. It's an Apple issue.  Despite the fact that I told the rep that everything else works on ATV3. Everything but NETFLIX.  She goes on and says, exactly. If your ATV3 works with everything else but NETFLIX, then its must be your ATV3 that has a problem. Ahahahah.... OMG... then she disconnects me and a satisfaction automated question comes up. Yes I hit disasstisfied.

     

    So now I will try a Restore after I have just changed my password again on Netflix from the website.  Lets see if that fixes it.  If not, I'll try and reboot my Cable and AX to see if that helps.

  • SuperSizeIt Level 3 (575 points)

    Nope that didn't work either. Now going to try Cable Modem and AX Router reboot.

  • SuperSizeIt Level 3 (575 points)

    Complete fail. Resetting Cable Modem, AX Router and same results. Looks like Netflix has just decided that my one Apple TV 3 is not allowed to connect to it. Yet all my iPads, iPhone, Mac and my 2nd Apple TV v2 are allowed to play in Netflix land.

     

    Don't bother calling NETFLIX they will blame Apple.  Looks like Apple and NETFLIX still has a way to go before they can seemlessly work toghether.  Might as well wait it out as others have and eventually it will resolve its connection. Some users has posted several weeks before it just started to work again.  Ridiculous.

  • Larcatian Level 1 (0 points)

    I have the same experience now as SuperSizeIt. I have rebooted ATV, reset ATV, factory restored ATV, left ATV unplugged (HDMI and power) overnight, and reset my Netflix password and validated streaming on other platforms... and am still not able to access Netflix on my ATV. I can access Netflix through XBox, iPad, iPhone and various computers throughout the house, but not ATV.

     

    Honestly, based on this behavior, I don't know where the fault lies. Either Netflix is not handling the request properly from the ATV or Apple is munging the request to Netflix causing failure. This is insanely frustrating, though.

     

    Let's push to get this resolved - one way or another.

  • Larcatian Level 1 (0 points)

    Any updates?

  • SuperSizeIt Level 3 (575 points)

    I even tried the google dns method, didn't work. I gave up. I'll stream iPad to ATV for now. It's stupid but it works. I've already sent apple product feedback.

  • Jerome Del Ray Level 1 (65 points)

    Mine broke last night.  Netflix not available, even after resetting passwords on ATV3.

     

    Realized I could stream from iPad but felt that's kind of silly.

  • Jerome Del Ray Level 1 (65 points)

    By the by --

     

    NETFLIX SUPPORT SEEMS TO BE AWARE OF THIS ISSUE NOW

  • landin_t Level 1 (0 points)

    Just talked to Netflix support. The latest software update for ATV caused a glitch between Netflix and ATV. According to Netflix support both engineering teams are working to resolve it and to check back daily. He also said that if the problem lingers subscribers will be refunded

  • mrl2012 Level 1 (0 points)

    Thanks, let's hope it works soon!

Previous 1 2 3 4 Next