Previous 1 2 3 4 5 6 Next 80 Replies Latest reply: Dec 17, 2013 10:58 PM by Eme Go to original post
  • mrl2012 Level 1 (0 points)

      I have changed the settings to 720 and 1080 manually and mine does not work, that really *****!!!  I still get the message "Netflix is not available, please try again latter", and it does not have any error number. 

    I will keep trying but it is quite frustraiting because my Netflix works with other devices, and the ATV works perfectly with the rest of the apps.  GRRRRRRR!!!!!


    If any one has another solution, please post it,  thanks!!!!

  • landin_t Level 1 (0 points)

    Switching to 720p worked for me, so thanks for that workaround. I did that a couple days ago and then yesterday I tried selecting 1080p (not auto) and it worked as well. Hopefully this thing is just about resolved

  • Mango Carrot Level 1 (0 points)

    I'm having the same issue. Just keeps saying its not available, I've tried changing the resolution to all of the options with no success. Also tried restarting each time... Now condsidering a full reset.


    Rather annoyingly I only signed up to Netflix on Wednesday which was after I'd updated the software, so I'm not sure where the issue lays

  • bac21 Level 1 (0 points)

    The resolution change from Auto to 720p does not help me either. I attempted to contact Apple about it, but I could not get past the intial, non-technical operator without paying them a fee of $29.95. I tried to explain that this was not just a fault with my personal equipment, but a larger problem with Apple TV devices that required a general resolution; that I was hoping one of there techs had developed a work-around.


    However, the "call director" would not let me finish. Each time I tried to explain the issue she would just say "Excuse me!" in a loud voice and begin talking over me until I stopped speaking. She would then reiterate that my complimentary software fixes ran out after 90 days from purchase and the only way she would continue with the call was if I paid the fee. I reminded her that I am an Apple customer and just want the opportunity to explain the problem without being interrupted and dismissed; but she simply reminded me that I hadn't paid the fee and she was not a technical person, so there was no point in continuing. VERY HELPFUL! I had heard good things in the past about Apple customer support, but this was one of the worst experiences of customer care I've ever had. It was shockingly bad. There's content I want on another streamer anway, so I will not remain an Apple TV customer. I'm glad for the rest of you whose problems were fixed, and best wishes to those of you still searching for a resolution. : )     

  • Mango Carrot Level 1 (0 points)

    Sorry to hear that :( I've always had excellent support from Apple over the years... Not that it helps you


    Anyway, I did a 'reset' (Settings > Genetal > Reset) of my ATV3 and now Netflix is working again! I couldn't begin to tell you what the issue was though. It's a bit of an inconvenience having to put all your passwords back in, but worth it I guess


    Hope it helps!

  • Jerome Del Ray Level 1 (65 points)

    NETFLIX fixed it on their end.  One night it just worked.


    Took 4 or more days.

  • louiewu Level 1 (0 points)

    So what did they fix...I have tried all the suggestions on my ATV 3 and nothing is working but my tivo which is hooked to the same ethernet hub as the ATV is streaming just fine.... as is my iphone, my ipad gen 1 and the tivo i have hooked up wi-fi downstairs. The only other item not working is my ATV gen 2 which is hooked in via wi-fi.

  • cheryl_79 Level 1 (0 points)

    I just purchased this for my fathers birthday and now I'm trying to fix it for him.  I tried all of the recommendations mentioned but it doesn't work.  I even updated the software and nothing.  HELP!

  • edvea Level 1 (0 points)

    I believe it is a Netflix problem...but I don't think they've fixed it yet.  I've got an ATV2 and an iPhone doesn't work on either...still.

  • Larcatian Level 1 (0 points)

    @cheryl_79 If you can list all of the things you have tried, in the order you have tried them, I would be happy to try and help troubleshoot. I believe many of us have been able to make this work.

  • Jazspaz7 Level 1 (0 points)

    Great suggestions everyone... I changed the resolution to 720, 1080, rebooted, reset, unplugged... all of the recomedations, but so far... nada! pretty frustrating; did the most recent update two days ago, now not working - anybody have this problem and figure it out?

  • danfromparksville Level 1 (0 points)

    Whenever I have trouble with Netflix I call their help line and they fix it from their end.  It often involves unplugging and re-pluggin the ATV unit, but they can walk you through it.  Just go directly to them.


    Hope it works.

  • nestaselect Level 1 (0 points)

    Unplugging for 15 seconds worked for me.

  • Zacharias Beckman Level 1 (100 points)

    This happens a lot on Apple TV. Unfortunately, Netflix is clueless about it (suggesting that you "delete your browser cache" and things like that -- obviously they have no idea what an Apple TV is). I'm betting Netflix is automatically blocking the Apple TV device for some reason. It happens to us pretty often -- at least a few times a week. When I check Netflix on the computer, it's fine and operational. Usually by the next day, the Apple TV is working again. Bottom line, Netflix servers don't play nice with Apple TV, or the Apple TV is doing something Netflix doesn't like. It tends to fix itself, eventually, but takes hours or days.

  • GarrettO Level 1 (0 points)

    I as well have tried all of the above.... 720p setting, menu/down button reset, unplug for 30 seconds, and even doing a headstand while attempting to login. Someone mentioned that with the recent software update, it screwed up the link between Netflix and Apple TV. I suppose we'll just have to wait for another update and hope for the best.