Previous 1 17 18 19 20 21 Next 346 Replies Latest reply: Aug 15, 2014 1:20 PM by Icain E.L. Go to original post Branched to a new discussion.
  • Cafuski Level 1 (0 points)

    Here's what happened and what fixed the issue for me...

     

    ...was downloading and installing apps quite happily on new iPad this evening.  Then kicked off a download of a podcast in iTunes, this particular podcast always downloads slowly so it was going to take a while.  Went back or organising/downloading apps and hit the "waiting" problem - couldn't update any apps, couldn't download any new ones.  Tried soft reset, syncing with iTunes, logging out/in of app-store, turning wi-fi off/on, plugging into power... nothing worked.

     

    Then I 'paused' that downloading podcast...tried to get new app again and it worked straight away!

     

    Not sure how common ths situation will be to others, but might be useful to someone.

  • billd25 Level 1 (0 points)

    I had the same problem... here's what fixed it for me...

     

    Go to itunes > More > Downloads.   

     

    If something is there stuck delete it, or let it download.      Simple fix.

     

    Bill

  • Shankie-san Level 1 (0 points)

    The 'connect to wifi and plug in to wall adapter' trick worked for me. Thanks bbmertz

  • sup2069 Level 1 (0 points)

    This helped me out vini, but instead of having a podcast, I had a tv episode downloading. Just deleted and all my apps are now updating.

     

     

    It seems like downloads in itunes on the iphone have priority over any other download on the phone.

  • Gorilla93711 Level 1 (0 points)

    Do u have anything downloading in the app store or iTunes store?

  • Angel75c Level 1 (0 points)

    I was having the same problem.  Then discovered that my iTunes on my iPhone had a Podcast that wouldn't download.  I paused the download and then deleted it.  After that my apps started downloading again.

  • sagthe1 Level 1 (0 points)

    Thanks Angel75c, it worked for me !!

  • balibod Level 1 (0 points)

    I need help with a similiar issue but my problem is updating aps. I can download aps from itunes store via my phone. I can log into my account via my phone. I can buy aps via my phone. Whenever my user name/password is prompted I type it in and it goes thru. Its when I try and update my aps I type in my user/name and password and I get this message "Cannot connect to iTunes Store". I have tried going thru my computer to update and it seems to update BUT I still see on my iphone that I have 7 updates and I cant connect to store. Any suggestions?  Its driving me crazy!!!!

  • Gorilla93711 Level 1 (0 points)

    Balibod,

    Check you wi-fi

  • Gorilla93711 Level 1 (0 points)

    It worked 4 me!  

  • El77 Level 1 (0 points)

    Another issue can be that there is not enough on the device to allow the app update to commence. Which mean that some apps or songs or other data needs to be deleted. Before the app updates (or any other download that is not working properly) will begin to progress.

  • balibod Level 1 (0 points)

    The main issue is I can't connect to the store to even try and update my aps. It only gives me that error message when I try and log on to UPDATE APS. I can log into iTunes for everything else but to update aps. And the wifi is not the issue. Thanks for trying to help Gorilla93711.

     

    I was told to back up everything and just reset. That will be my last resort.

  • Northernlights 2 Level 1 (5 points)

    My iPad will not update the apps either.  They all sit in the 'waiting' state.  Then it comes up with unable to purchase.  I checked all downloads, nothing to download.  Did a complete restore of the iPad.  Still no luck.

    I'm at a loss at what else to do....  Does Apple have an answer?

  • mewzikluvr Level 1 (0 points)

    Thank you so much!! This totally worked for me! ^_^

  • NBrener Level 1 (0 points)

    I had 20 apps needing updates, and when I clicked "update all" it prompted me to put in my password, but then everything said pending. I tried to manually update one app and it would say "waiting" and then "unable to update application. Done or retry." I have tried for days. I then deleted the other 19 apps in hopes that I would just emilinate any problematic app. I also did the back-up to iCloud. My iPad software is up-to-date, and I am nowhere close to using even half of my memory space. I really don't want to have to delete this app because it is the iStudio flashcard app that has much needed study material.

     

    Suggestions?

Previous 1 17 18 19 20 21 Next