Skip navigation

after ios 5.1 update apps won't download

285344 Views 345 Replies Latest reply: Mar 1, 2014 8:30 AM by Eleanor Ryan RSS Branched to a new discussion.
1 2 3 ... 24 Previous Next
dodiscom Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 9, 2012 7:12 AM

I had trouble downloading the ios 5.1 update, but found a thread on here that pointed me to an open dns address, so i typed that in the dns field and it worked. I have the updated ios 5.1. I went back and deleted the dns address, connected to my local wi-fi and the internet and all functions seem to work fine, but when i try to download an app, whether it's one i used to have or a new one, it won't download. It begins to, then the icon flashes waiting/loading, waiting/loading, then a screen pops up that says "unable to download application. "imovie" could not be downloaded at this time. done, retry"


It's not just imovie, I've tried others as well.


i turned off and turned on. I can't sync now because i'm away from my laptop. i have verizon iphone 4s.

1 2 3 ... 24 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (11)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.