8 Replies Latest reply: Mar 11, 2012 6:47 AM by GilGonsalves
erpeden Level 1 Level 1 (0 points)

I have been trying to update my IPad for the last two days but all I get is the message on the screen saying Connecting to IPad Software update server and goes no further. I have restarted my computer three times, updated to the latest ITunes. What is wrong??


iPad 2, iOS 5.0.1
  • Ralph9430 Level 6 Level 6 (16,100 points)

    Does your iPad already have iOS 5.0.1 on it? If so go to

    Settings > General > Software Update and see what happens.

     

    You do not have to be connected to your computer to update to iOS 5.1 from iOS 5.0.1. You should be able to do it directly from your iPad.

  • corus666 Level 1 Level 1 (0 points)

    I am also in a similar situation, although think I may have diagnosed the situation a little more.

     

    I have an iPhone 4S, iPhone 3GS, and 2x iPod touch 4th Gen all running iOS 5.0.1. I also have an iMac running 10.7.3 and all latest software, MacBook running 10.6.8, Time Capsule and a Netgear router provided by my UK ISP Sky Broadband. I also have an Apple TV on 4.4.4 than needs updating to 5.0.

     

    When attempting a software update on an iOS device itself (Over-The-Air updates) on my home network I cannot connect to the server, and get an error. Switching my iPhone 4S to 3G allowed me to find the 5.1 update, but not download it as it requires WiFi. Apple TV hangs on estimating time for download (I think).

     

    I have also attempted to download the actual ipsw file from Apple Servers using links readily available on the net (Google 'felixbruns'). I get the grey 'Safari could not connect to the server' style message. At one stage I connected to the Netgear router via WiFi rather than through the Time Capsule, and was able to connect to the direct link (although I paused it to try on iPhone). I have never since been able to connect to this direct link via any method.

     

    While in the supermarket today I was able to connect to their free public WiFi and update my iPhone 4S, slowly but successfully.

     

    I have reset the Netgear router back to factory settings, along with the Time Capsule, and still cannot connect through either. I'm beginning to be paranoid that it's my ISP blocking the site, although that seems highly unlikely??

     

    I have never had such an issue with software updates in the past 5+ years! This really confuses me, as I'm no novice Mac user...

  • Scott Spindler Level 1 Level 1 (10 points)

    Corus666, I've done a similar thing. I'm not able to connect to the server via my wired iMac or wirlessly with my iPad or iPhone, but I was able to get the download via wireless on my iPhone via my office's WiFi network, so that tells me it has something to do with my network. I have a D-Link wired gaming router and 2 Airport Expresses for my wireless access. I haven't rebooted my cable modem or my wired router yet. I did renew the routers DHCP lease, but that didn't help. I'm also having trouble downloading App updates from the app store on my iPad wirelessly. I can connect to other aspects of Apple like the iTunes Store, so I'm not sure what's up. I haven't made any changes to my routers.

  • Scott Spindler Level 1 Level 1 (10 points)

    I just rebooted my cable modem and router and still can't connect to the server through iTunes. I guess I'll need to do some more investigation. If anyone else finds something please respond.

  • erpeden Level 1 Level 1 (0 points)

    I just found another post on here that said change the DNS Server on your computer using the following link.

    http://code.google.com/speed/public-dns/docs/using.html

     

    It worked and my IPad is updating. Going to update my IPhone next.

  • corus666 Level 1 Level 1 (0 points)

    Yes! Changing the DNS to Google's public '8.8.8.8' and '8.8.4.4' has now allowed me to access the downloads! It does seem to have slowed my network however, but I can always switch back after.

     

    Thanks erpeden!!!

  • Scott Spindler Level 1 Level 1 (10 points)

    Yes! Thank you erpeden, your solution worked for me as well. I only had to enter this in my router. I made no changes to my computers as I was pretty sure it wasn't something with my internal network. I added the single IPv4 address info. into the DNS for my router and it worked like a champ. The update came up instantly. I have not noticed any decrease in network speed. I guess this issue points to my ISP?

  • GilGonsalves Level 1 Level 1 (0 points)

    This is it!!!! Thank you, I've been trying this for days with no luck, but changing the DNS server worked.  Anyone having a similar problem, follow the above link - the directions are clear.