Previous 1 2 Next 21 Replies Latest reply: Feb 2, 2013 10:47 AM by Mattiej
Mattiej Level 1 Level 1

Anyone else having issues updating thier firmware? Software update shows the 1.6 firmware update needing done, I go throught the process, it reboots and never installs the firmware. System profiler still showing the old version. I tried downloading the file from Apple's website and manually installing and it does the same thing. I'm at my wits end here. It doesn't really bother me except that it constantly shows up in software update.


Mac mini, Mac OS X (10.7.3)
  • den.thed Level 7 Level 7
  • Cattus Thraex Level 4 Level 4

    My guess is that you downloaded it, but not installed it. Unlike software updates proper, i.e. the ones, which are installed on the hard disk, firmware updates install unto the chips of hardware components, and should be installed separately.

    It worked OK here with my same mini.

  • Mattiej Level 1 Level 1

    Yes, I know this. I even tried shutting down and holding the power button in until the power light flashes but still nothing. I installed it form the package which says that it requires a restart and i let it do it's thing, restarted and all i get is the regular splash screen. no progress bar like it usually does duringa firmware update. when it comes back up i check the firmware and it's still the old version. tried installing it separatly as the stand alone package, still the same thing. This is my firmware... Screen Shot 2012-03-10 at 9.53.36 AM.png

  • lost.carrier Level 1 Level 1

    ...same problem here... Boot-ROM-Version is "MM51.0075.B00". Any solutions?

  • Ian Williams5 Level 1 Level 1

    Exactly the same problem on my end. Same Boot-ROM-Version as above.

     

    Tried three times to update the firmware with EFI 1.6, but when the Mac Mini restarts, it turns on and off a couple of times, then restarts as normal with the firmware not installed.

     

    I replaced the stock HD in my Mac mini server 2011 with an SSD (OCZ Octane 256GB) but according to a thread on Macrumors, it's happening regardless of HD:

     

    http://forums.macrumors.com/showthread.php?t=1345445

     

    anyone else out there?

  • Ian Williams5 Level 1 Level 1

    Bumping the thread in the hopes somebody figured this out. Anyone?

  • gobmcb Level 1 Level 1

    I was having the same problem with my MacBook pro, here is what I did to solve it. Go to 'check for updates' then after it finds your updates click on the button that shows each individual update.  In the list I had one that is apparently an update for the Software Updater that fixes this problem. Ironic.... I know.  Anyway uncheck all the updates but this one and run it by itself.  On mine it this worked and then after it installed and restarted I was then able to run the rest of the updates and firmware upgrade. Hope that works for you.

  • BDAqua Level 10 Level 10

    Great clue/tip, thanks!

  • Mattiej Level 1 Level 1

    wow, thanks for that, I didn't even notice that an update had come out. I'll let you all know how it pans out, hopefully it'll work.

  • Mattiej Level 1 Level 1

    didn't work for me, still the same problem, did anyone else besides gobmcb get it to work?

  • Ian Williams5 Level 1 Level 1

    nope - I'm not getting a "software update" update, I'm just continually seeing the Mac mini EFI Firware 1.6 update, since it never installs.

     

    Any Apple people reading this? Or Mac Mini specific techs? What's going on with this?

  • useme2305 Level 1 Level 1

    there is no "software updater" update. but why would you make up such BS around here?

     

    i really want this problem solved.       

  • gobmcb Level 1 Level 1

    Here is a link to the software update update. Take note that in my previous post I said I have a Macbook pro., although this is for anyone running 10.6.8.

     

    @useme2305  Learn to read and maybe even write a complete sentence before you start talking again.

     

    http://support.apple.com/kb/DL1512

  • Ian Williams5 Level 1 Level 1

    OKAY, SO...

     

    I think this is a 3rd-party hard drive issue.

     

    I got it to work, finally, by removing my SSD (I was using an OCZ Octane 256GB) and putting the original hard drive back in the Mini. I had never used that original drive, so I had to go through the whole setup process. Then I downloaded and installed the 10.7.3 OS update (NOT anything else).

     

    After the restart, I downloaded the firmware update SEPARATELY from Apple's website, and it installed and restarted fine. Now the Mac Mini is up to date, and I'll swap the hard drives back.

     

    Don't know if everyone else here with the issue is using a different brand of hard drive than the one Apple ships, but that seemed to be the problem with mine.

Previous 1 2 Next