7 Replies Latest reply: Mar 11, 2012 8:22 PM by Lendo56
iambuddy Level 1 (0 points)

I have tried updating my ipad to the new iOS 5.1 and when I do it via USB Cable I get this error, "There was a problem downloading the software for the iPad.  The network connection could not be established."  When I try to do the update through the iPad itself I get this error, "Unable to check for update.  An error occurred while checking for a software update."  I have tried to turn off and also do a hard reset on my iPad and that has not worked.  Any help is appreciated.



iPad 2, iOS 5.0.1
  • Barry Hemphill Level 8 (37,155 points)



    I tried everything and could not update - either from my iMac or iPad2.  I searched the forums and found a solution (which seemed bizarre, but it worked).


    I changed my DNS settings to (Google's Open DNS server).  Behold, the update started and successfully completed.  There was no logical reason why this worked (except a problem between Apple's server and my ISP).  I changed the DNS settings back (they work for everything else).



  • Phillyint Level 1 (0 points)

    This worked for me.  I tried a couple of times and then I went on and changed my DNS and that did the trick...

  • Mike Benanti Level 1 (5 points)

    I too had the problem.  Changing DNS to resolved the issue.   I changed it back to my gateway address when complete.

  • Cwant Level 1 (0 points)

    Nice. I've been having the exact problem. I changed the DNS server on my iPad 2, and the problem persisted. I changed the DNS server on my MacBook and updated through iTunes, and it worked like a charm. Thanks for the solution.

  • Lendo56 Level 1 (0 points)

    Had exactly same problem on iPad1. "Unable to check for update. An error occurred while checking for a software update".  Been getting this since 3/7/2012.  Apple support said probably server overload.  Checked these comments and found answer that worked.

    -- Reset device

        . Backup your iPhone/iPad to iCloud (very important). Settings>iCloud> Storage and Backup>Backup Now (at the bottom)

        . Erase your device.  Settings>General>Reset>Erase All Content And Settings

        .  Device will reset and wipe itself

        .  When it restarts follow the instructions on screen and setup your device.

            You're choices here do not really matter except for restoring From a  backup.

            Do not restore a backup, chose "Set up as new".

        .  When complete, the Software Update should now work which will install IOS 5.1

        .  When installed, Erase the device again (see Above).

        .  Once erased, follow the Wizard but this time select that you wish to restore from a backup

            In iCloud.  Select the backup that you took in first step.

         .  Your device should be back to normal and with IOS 5.1.


    This takes time to complete but it worked. Thanks to Glosdeveloper for this.  By the way this was an "over the air" update (as opposed to plugged in.

  • iMatters Level 1 (0 points)

    I have had the same problem for days with my iPad2. Changed DNS numbers, tied iTunes download, tried ipad download, tried another network, tried changes to security and checked for third party conflicts. Has taken ages and still not sorted.

  • Lendo56 Level 1 (0 points)

    Should also note that I changed DNS (as suggested by some others) to, before I did the stps mentioned above.