10 Replies Latest reply: Apr 28, 2013 7:43 PM by esombers
wallina Level 1 Level 1

how do i eject a cd from the macbook pro

  • Niel Level 10 Level 10

    Click the button next to it in the Finder's sidebar.



  • Kappy Level 10 Level 10

    Six ways to eject a stuck CD or DVD from the optical drive


    Ejecting the stuck disc can usually be done in one of the following ways:


    1. Restart the computer and after the chime press and hold down the left mouse button until the disc ejects.


    2. Press the Eject button on your keyboard.


    3. Click on the Eject button in the menubar.


    4. Press COMMAND-E.


    5. Click the eject icon in the Finder's sidebar.


    6. If none of the above work try this: Open the Terminal application in your Utilities folder. At the prompt enter or paste the following:



         /usr/bin/drutil eject


    If this fails then try this:


    Boot the computer into Single-user Mode. At the prompt enter the same command as used above. To restart the computer enter "reboot" at the prompt without quotes.

  • wallina Level 1 Level 1

    there seems to be just a hole there, no button. Is this normal?

  • sig Level 8 Level 8
    Mac OS X

    Did you read Kappy's solutions? Did you try them? There are no buttons. No holes either unless you figure the slot is a hole.

  • Kappy Level 10 Level 10

    It should look like this:


    Screen Shot 2012-03-11 at 3.14.37 PM.png


    The name of the disc will different from what you see listed above.

  • bbfc Level 3 Level 3

    Press the EJECT button, located to the top right of the keyboard above the backspace key (near the power button).

  • OGELTHORPE Level 8 Level 8

    Two more ways to get a CD/DVD out of a MBP optical drive if the afore mentioned steps fail:


    Hold the MBP with the slot towards the ground, shake with a vacuum cleaner engaged.


    If that fails, open the MBP and take the cover off of the Optical Drive ( or have the Apple store genius do it) and take out the CD/DVD.



  • andychapel Level 1 Level 1

    In my case VMWare's Fusion had held up the CD drive.  When I shut down the Windows VM then everything worked.

  • William Schnitz Level 1 Level 1

    Thanks, Kappy.   I thought for sure the disk was physically stuck but

      /usr/bin/drutil eject

    in Terminal worked!

  • esombers Level 1 Level 1

    MY daughter managed to put the dvd's into a macbook pro, while using terminal.


    command drutil eject and waiting for sound of computer trying to eject, i put doublesided tape (so it wouldn't be too sticky) on believe it or not another cd.


    i pulled all three out and cd still working.


    i don't think i would have even needed to use the eject command from the terminal program.  Obviously I feel lucky after i took the case apart and unscrewed some of the cd/dvd screws which I did't think would lead me to the answer.


    I hope if someone tries this it doesn't screw anything up and works.   like i said dvd is writing, playing, ejecting, etc.