9 Replies Latest reply: May 1, 2012 7:49 PM by davidme
JohnZonie Level 1 Level 1 (30 points)

I am in AZ and have the time zone set to Phoenix. When Set Automatically is enabled, the location changes to Cupertino, changing some (but not all) of my appointments. As I read the iPhone guide, shouldn't the location remain Phoenix when I enable Set Automatically?


This happens on two 4S phones so it is apparently by intent (or by bug).

  • wjosten Level 10 Level 10 (93,995 points)

    When set to "automatically", your phone gets time/date info from your carrier. So, call them & complain.

  • keg55 Level 5 Level 5 (7,070 points)

    I'm in Arizona too. And I have not seen "Set Automatically" go to Phoenix ever. During Standard time, I always show Denver (Mountain). During Daylight Savings, it shows Cupertino (Pacific). For both, the time is always correct on the phone, Reminders and Calendar.

  • manitoban Level 1 Level 1 (0 points)

    I had this issue too on my iPhone, except I'm in Canada and it changed my time zone to 2 provinces west. I was fine yesterday, then toward the evening noticed I was an hour out with it automatically set to another city. This was before I did the OS upgrade. After doing the upgrade, still had the same issue and tried everything on these message boards. Only thing that worked for me was this from the apple site:


    Select a different city (other than your closest city) in Settings > General > Date & Time > Time Zone. Turn off iPhone, then turn iPhone back on.


    I chose a city in a time zone east of me, turned off my phone and back on, then changed the setting to automatic and it finally came up correctly. Tested with my email, etc. and times are now showing correctly. Seems like no single solution works for the general population so I guess you've got to try different things. Some got it to work correctly by turning Airplane mode on/off or a hard reset.


    Good luck! Apple needs to fix this issue. Strange since I didn't have it during the last daylight savings time though.

  • dffdce Level 1 Level 1 (30 points)

    Don't know about you but the displayed time is correct however calendar entries made on the iPhone before Sunday are now all an hour off.  It's not a carrier issue as other smart phones in the Phoenix area on AT&T are correct.


    Rumor has it it is a problem with Apples implementation of this: http://en.wikipedia.org/wiki/NITZ


    Also it wouldn't hurt to provide feedback here:  http://www.apple.com/feedback/

  • manitoban Level 1 Level 1 (0 points)

    Yes, that was exactly my issue too. Clocked looked correct, but time zone was wrong and calendar entries wrong. Only thing that fixed it for me was:


    Select a different city (other than your closest city) in Settings > General > Date & Time > Time Zone. Turn off iPhone, then turn iPhone back on.

    (I chose a city in a different time zone for this)

  • dffdce Level 1 Level 1 (30 points)

    Thanks for the tip but that didn't work for me, still (virtually) in Cupertino even though I'm physically in Phoenix.



  • JohnZonie Level 1 Level 1 (30 points)

    Thanks for the ida but no luck here. Set it to Chicago, power cycled, came back up at Chicago time, selected automatic and went back to Cupertino. I guess the iPhone just doesn't want to leave home.


    Sounds like a bug to me - either Apple's or AT&T's. I'll leave it on manual and Phoenix.

  • JohnZonie Level 1 Level 1 (30 points)

    I just tested this issue with a Verizon and ATT 4S side-by-side here in the Tucson AZ area. Either both Verizon and ATT haven't programmed time zone info correctly or it is indeed an Apple bug. Both iPhones showed Cupertino when time zone is set to automatic!

  • davidme Level 1 Level 1 (0 points)

    For AZ iPhone users, I think John hit it on the nose. There appears to be a bug in iOS that sets the date/time to either Denver or Cupertino depending on if DST is in effect. This messes up any calendar entries that are made before or after the DST start or end dates. I clearly saw this when some of my calendar entries shifted. Those entries were made before DST. When I turned on time zone support, that entry showed Denver. But, my current time zone was set to Cupertino.