Previous 1 2 3 Next 30 Replies Latest reply: Apr 20, 2012 3:13 PM by thesmallviking Go to original post
  • GR-Toulouse Level 1 Level 1 (0 points)

    Go to your applications folder, right click on safari, "get info" and uncheck the "32bits" option. Works for me as well. Actually I didn't know my Safari was working in 32 bits mode.

  • Fidy Yuan Level 1 Level 1 (0 points)

    I have a 64bit MBP (Penryn processor). By default, Safari should run in 64 bit but mine had the 32-bit mode checked. Kind of weird for sure but at least it's fixed. Now, if only Safari would stop breaking Springpad now.

  • Andrew Fite Level 1 Level 1 (0 points)

    I can confirm this same problem and solution.  Safari running in 32bit mode will not render Gmail properly (probably because the new 32bit version of Safari has some sort of javascript bug).  Once I unchecked the 32bit option from the Safari Info pane, GMail returned to normal.  So for some reason only the 64bit of Safari works properly right now.

     

    I am working on a 6-core Mac Pro.

  • vea1083 Level 3 Level 3 (685 points)

    Did any of you force-ran Safari in 32-bit before upgrading to 5.1.4? Or did the update defaulted to 32-bit mode Safari?

     

    Thanks for the further explanations.

  • Andrew Fite Level 1 Level 1 (0 points)

    I can only speak for myself, but I had been using Safari in 32bit mode before the update because some plugins are not compatible in 64bit mode.  So for me, the previous 32bit mode was working fine.  After the update I had to switch to 64bit mode to fix Gmail.

  • iMatt_Muc Level 1 Level 1 (45 points)

    Thank you SO MUCH!

     

    On my system (iMac i7 OS X Lion) Safari was also tagged to 32-bit-mode. No idea why.

    But now with 64Bit several problems with Safari just disappeared.

     

    Matt

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    Good catch, was having the same probem and  switching it back to 64 bit fixed it.

  • ben.howe Level 1 Level 1 (0 points)

    Same issue.  Same solution.  Thanks!

  • eastcoastgirl02375 Level 1 Level 1 (0 points)

    I'm having the same problems and I unchecked 32 - bit  but how do I set it in 64- bit?

  • Andrew Fite Level 1 Level 1 (0 points)

    1. Go to your Applications folder. 

     

    2. Find Safari.

     

    3. Right click (or control+click) on Safari and choose Get Info. (a window will pop-up)

     

    4. Uncheck "Open in 32-bit mode" and close the window.

     

    5. Restart Safari and your done

  • eastcoastgirl02375 Level 1 Level 1 (0 points)

    Thank you very much...I did as you posted and it worked.

  • Pichicanes Level 1 Level 1 (0 points)

    Thanks very much indeed. I did follow your guideline and my problems were blown.

  • Morwatz Level 1 Level 1 (0 points)

    For everybody, try Sparrow lite (App store). It's free!!

  • Mitja Okorn Level 1 Level 1 (0 points)

    In the last week or so my Safari is going crazy. THis is frustrating and I dont know where the problem could be... I just know that I wouldnt like to switch to other browsers and I would still like to use Safari. But this is too much...

    So I have a one year old Mac Book Pro 2.3 ghz Intel Core i7 8gb memory

    MAC OS X version 10.7.3

    Safari 5.1.4

     

     

    So what is / was happening.

    Firstly I couldn't see any of my emails in my gmail mailbox. I could see my emails if I could go back to the old look. But I wanted to have the new GMAIL look so I Was wondering what to do.  At the same time in youtube which ever button i pressed nothing happened. If I pressed the videos button so I could see more videos from the user nothing opened. If I pressed show more button to get more info on the video nothing happened. So then I googled a little to see if somebody else has a problem and then somewhere it was written to uncheck the "open in 32bit" box and I did that. And so there was some progress. Even though I would still like to know why I need to do that and what is the difference if you are opening Safari in 32bit or you are not opening it in 32bit... Anyway at least now I could see my emails in my inbox on gmail and when I pressed the youtube buttons stuff worked. But still YouTube doesnt work the way it is suppose to work. When I open some videos - most of the videos I have huge problems with the slider timeline scrolling option (I dont know if that is the right name for it). Anyway this slider doesnt work at all. The video is loading and playing at the same time and then at one moment the slider stops or jumps at the beginning while the video is still playing. And I cant jump anywhere on the slider. The video plays till the end, I cant even pause it and when it comes to the end I cant play it again... I need to reload. SO once again. The slider stops and the loading trace disappears but the video plays on... And I have no control over it - I can not jump in time I can not go to the beginning - all I can do is either watch the video or reload the page...

     

     

    Plus my safari keeps on reloading after a certain time. This can be a total pain in the *** when I write a long reply to somebody on Facebook or write a new thread on MacFumours and it reloads and what I was writing is lost forever. Again frustrating.

     

     

    Does somebody else have the same problems and what should I do about this ******** Safari. Will they fix these problems are they fixing them?

  • Pichicanes Level 1 Level 1 (0 points)

    Try to apply the solution explained above in some posts. I was suffering multiple problems and all of them were blown when I di change the 32 bits mode to 64 bits mode (I was not aware on such a setting).

    Go to App folder, mark Safari icon and then press the keys "Cmd and i". A new small window will appear with information. Uncheck the box saying 32 bits mode.

     

    Good luck