Previous 1 2 Next 16 Replies Latest reply: Aug 15, 2012 9:19 PM by Endurion
Bruce Kieffer Level 2 Level 2 (150 points)

It appears this new version of Safari breaks Google Docs. All I did was install Safari 5.1.4, and now I cannot work in a Google Doc.


iMac, Mac OS X (10.7.3)
Previous 1 2 Next