Previous 1 2 3 4 Next 59 Replies Latest reply: Oct 1, 2014 1:23 AM by turingtest2
K Gazow Level 1 (0 points)

"The installer has insufficient privileges to access this directory. C:\ProgramData\Microsoft\Windows\Start\Menu\Programs\iTunes. The installer cannot continue. Log on as administrator or contact your system administrator."

 

System specs: Windows 7, x32 or x64, fully patched & SP'd

 

I just worked with my cousin in Colorado over Skype to get this resolved.  This is a fairly obscure error, and if you try to edit the permissions of the folder, run the installer as an administrator, log on as an administrator and run it, no actions seemed to resolve the problem.  We did get it fixed, which involved the following steps.  Not all of these may be strictly required, but hey, it worked for me. ;-)

 

1.  Download the latest iTunes installer

2.  Rt. click the installer, select 'Properties'

3.  Click on 'Unblock', then click Apply, then OK.

4.  Click on the Windows icon and type 'uac' (no quotes)

5.  Click on 'Change User Account Control Settings'

6.  Move the slider down to 'Never Notify' (NOTE: This will require a reboot)

7.  Rt. click the installer and select 'Run as administrator' from the context menu

8.  Let the installer complete (it should now)

9.  Open 'Change User Account Control Settings'

10. Return the slider to the position you found it on (likely 2nd from the top)

 

Hopefully this helps you resolve this issue.  All the best, iTuners!

 

Kurt


iTunes Installer, Windows 7, Installer, Insufficient privileges
  • ashleyrobin1 Level 1 (0 points)

    I waded through TONS of message boards w/all kinds of interesting but useless & ineffective suggestions. THIS WORKS!! FYI am running Windows 7 w/ iTunes 11. Tried "just run w/ admin priv", uninstall Quicktime, uninstall Bonjour, repair through uninstall, etc. If you are getting "insufficient privileges" error msgs, I highly suggest trying this easy fix 1st!

  • secularactivist Level 1 (0 points)

    Oh, THANK YOU!!  I *love* you for this!!  Thanks so much!

  • K Gazow Level 1 (0 points)

    Glad I could help; thanks for the feedback!

  • mother1986 Level 1 (0 points)

    Hello Kurt,

     

    I am trying to download Itunes 11.0.2 update.  The update was dowloading, checking for new software, and brought up the User Control Panel up asking for the program to make changes.  When I clicked "yes", the Apple Software Update window opened where Itunes was dowloading then installing, then I received the above error.  I also received an Apple Software Update error stating:  Errors occurred while installing the updates.  If the problem persists choose Tools - Dowload Only and try installing manually.  I tried that and ended up with the same error message:  Insufficient Privileges.  I am logged in as Administrator.  I am definitely not savvy with this type of stuff.  So to follow your instructions above, where - or how - do I dowload the Itunes installer?

     

    Thanks so much for any help you can provide this novice.

     

    --Terri

  • K Gazow Level 1 (0 points)

    Go to this link, uncheck the two boxes for 'Email me' and 'Keep me up to date', and click on 'Download Now'.  That should detect your OS and get you the right install package.

     

    http://www.apple.com/itunes/download/

     

    Cheers,

    Kurt

  • mother1986 Level 1 (0 points)

    I have a nice Thank you for dowloading Itunes, but I don't have anything installing...?

  • K Gazow Level 1 (0 points)

    The installer should be in yoru downloads folder (varies depending on which browser you're using).  Once you track it down, use the instructions I posted up top.

  • mother1986 Level 1 (0 points)

    I tried dowloading the new version of Itunes in Firefox and IE and still get the same error when it tries completing the update.  I don't see the new Itunes in my dowload folder in either brower.  In my dowload folder, I do see the last Itunes update from February 18th -  iTunes64Setup.

  • mother1986 Level 1 (0 points)

    Hi Kurt,

     

    The update finally actually dowloaded and, with your suggestions, is now up to date!  Thanks a million!

     

    --Teresa

  • K Gazow Level 1 (0 points)

    Glad it worked for you!

  • RavenLordX Level 1 (0 points)

    THIS is the only solution that WORKED.  I, too, scoured the internet repeatedly for a solution and never found one that worked. I repeatedly restored my computer to an earlier restore point to undo all of the other suggested fixes and attempts to update iTunes over the last several months.  I was convinced that I would never update iTunes again.  Finally, I stumbled onto your solution, and it actually worked.  THANK YOU so much!

  • K Gazow Level 1 (0 points)

    Thanks for the feedback, RavenLordX!  Hopefully Apple can figure out what is causing the update lock insofar as its interaction with the OS and fix it in a future release.

  • wilsonczr Level 1 (0 points)

    Hi to all, this is what i found out and help me:

     

    I had an issue with my Start Menu folder so I had to delete the whole "Start Menu"/Programs folder, then ran the installer again with no issues, then recovered the programs folder from the recycle bin.Do that for any folder it said it does have problem. I just move  whole directory back and forth and it worked

  • ckkong Level 1 (0 points)

    Hi

     

    I am on Windows Vista.  When I tried to follow your instruction, after I click the properties, I cant find the unblock button.  Do you know how do I find it in Vista?

     

    Many thanks

     

    CK

Previous 1 2 3 4 Next