Skip navigation

Can't Update Garage Band or iPhoto

18191 Views 29 Replies Latest reply: Jan 11, 2013 3:08 PM by oldkingdom RSS
1 2 Previous Next
nneeaall69 Calculating status...
Currently Being Moderated
Mar 13, 2012 6:53 AM

I notice a lot of people are having this problem when it comes pre installed. HELP

I can't update from the appstore and I can't update from the program itself.

When I use software update it will say all software is up to date.

I checked the versions of the software that I have installed and they are not the new, current versions so yes i do need to update

App store says I need to update Garage Band and Iphoto but I need to use the other account that was used to purchase the software.

I have only ever had one account. This is not cool

I have had this computer for 4 months now and this problem has been on going for 3.5 months !!

I have a new macbook pro and osx lion was pre installed along with garageband iphoto and iMovie

MacBook Pro, Mac OS X (10.7.3)
  • Carolyn Samit Level 10 Level 10 (84,095 points)
    Currently Being Moderated
    Mar 13, 2012 9:45 AM (in response to nneeaall69)

    Hi ...

     

    I have a new macbook pro and osx lion was pre installed

     

    The updates for those apps will only be available from your Apple menu > Software update since the apps were pre-installed. If you had purchased the apps directly from the app store, then you would update from there.

     

    Others with similiar issues are providing feedback to Apple > Apple - Mac OS X - Feedback

     

    The more feedback received by the developer's hopefully the sooner the problem is resolved >  Apple - Mac OS X - Feedback

  • Dah•veed Level 7 Level 7 (29,535 points)
    Currently Being Moderated
    Mar 13, 2012 5:36 PM (in response to Carolyn Samit)

    The updates for those apps will only be available from your Apple menu > Software update since the apps were pre-installed. If you had purchased the apps directly from the app store, then you would update from there

    That has not been true of new Macs with pre-installed iLife apps since last year after the MAS was introduced and Apple stopped selling boxes sets of the iLife suite. It is not true of any Mac that came with Mac OS X Lion 10.7 preinstalled. All iLife apps preinstalled on new Macs, especially those that came with Lion, are the MAS versions and must be accepted into the users MAS account on the Purchased pane before they can be updated.

    '09 Mac mini, iPad 2, iPhone 4S, Mac OS X (10.7.3), iOS (5.0.1) Mac fanboi since 1984!
  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 5, 2012 4:54 AM (in response to nneeaall69)

    I too have this issue.  And My MBP came with Lion installed.

     

    Mac App store shows 2x needing update (iPhoto and Garage Band) yet it directs me to "software update" for the solution, but the updater says all is up-to-date?

  • Dah•veed Level 7 Level 7 (29,535 points)
    Currently Being Moderated
    Apr 5, 2012 5:34 AM (in response to Jared@Halifax)

    Did you ever go through the process of Accepting these apps into your MAS account?

     

    Try this;

    1 - Exit iTunes and the Mac App Store (MAS)

    2 - Go to System Prefs/Users & Groups/~user/Password and enter the Apple ID connected to your iTunes/Mac App Store account. Close Sys Prefs

    3 - Delete /Mac HD/Library/Caches/com.apple.appstore/adoption.plist

    4 - Reboot your Mac

    5 - Open Mac App Store

    6 - Go to the Purchased pane and Accept the three iLife apps. Enter iTunes/MAS username/password if prompted.

    '09 Mac mini, iPad 2, iPhone 4S, Mac OS X (10.7.3), iOS (5.0.1) Mac fanboi since 1984!
  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 5, 2012 6:12 AM (in response to Dah•veed)

    Hi there,

     

    Mmmm.  Well I went through you suggestion.  I have no such file in the directory you point me too...?  As in the pic that folder is empty.

     

    My Apple ID is in my system settings.

     

    Jared

     

    Screen Shot 2012-04-05 at 10.08.20 AM.png

  • Dah•veed Level 7 Level 7 (29,535 points)
    Currently Being Moderated
    Apr 5, 2012 6:20 AM (in response to Jared@Halifax)

    Then I am not sure how to help you.

     

    What do you see regarding those apps in the MAS Purchases pane?

    '09 Mac mini, iPad 2, iPhone 4S, Mac OS X (10.7.3), iOS (5.0.1) Mac fanboi since 1984!
  • bhillinger Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 5, 2012 6:34 AM (in response to nneeaall69)

    I had the same problem. I contacted Apple via ExpressLane and after a few E-Mails an employee sent me three serial numbers for iPhoto, iMovie and GarageBand. I deleted the existing iLife apps, went to the Mac App Store and entered the Code on the "Redeem" page. And since then it worked all fine.

     

     

    Here's the link to ExpressLane: http://expresslane.apple.com

     

    Be sure you choose "More Products and Services" and then "Mac App Store".

  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 5, 2012 6:31 AM (in response to Dah•veed)

    Here is what I see.

     

    Screen Shot 2012-04-05 at 10.23.50 AM.png

    So the Mac App Store Says.....

    Screen Shot 2012-04-05 at 10.29.55 AM.png

     

    Then if I open the app....

     

    Screen Shot 2012-04-05 at 10.21.22 AM.png

     

    But when I go to the Software Update....

     

    Screen Shot 2012-04-05 at 10.21.58 AM.png

     

    The version of Garage Band for example is 6.0.4 on my Mac. 

    The App store has 6.0.5, as does the Apple web page reference.

     

    Not a big deal.  Just always looking at the Mac App store icon with the "2" on it.

     

    But there seems to be a disconnect in the App Store and the Software Updater.

     

    Jared

  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 5, 2012 6:34 AM (in response to bhillinger)

    Ya.. that is what I figured. 

     

    By that reality of actual event; I would think that the updates are no longer coming through the Updater which would make sence - given the iOS intergration; and therfore you need to have got them from the App Store for updates to take place.

     

    I will email them.

     

    Thanks,

    Jared

  • Dah•veed Level 7 Level 7 (29,535 points)
    Currently Being Moderated
    Apr 5, 2012 6:37 AM (in response to Jared@Halifax)

    I asked about the Purchased pane. You are showing me the Updates pane!

    '09 Mac mini, iPad 2, iPhone 4S, Mac OS X (10.7.3), iOS (5.0.1) Mac fanboi since 1984!
  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 5, 2012 6:48 AM (in response to Dah•veed)

    Right... need coffee.... same deal. 

     

    They are there and will not update!   I have emailed Express Lane!Screen Shot 2012-04-05 at 10.44.30 AM.png

     

    Thanks to all... !

     

    Let's see what Apple has to say.  I will post back after I hear form them.

     

    Jared

  • mattcandy Calculating status...
    Currently Being Moderated
    Apr 6, 2012 8:52 AM (in response to Jared@Halifax)

    interested in hearing how you get on with this....  I have similar problem

    - macbook air with lion preinstalled.

    - iphoto and garageband in app store both tell me there are updates available

    - when i go to update in app store, i get the following error message:

     

    "We could not complete your request.

    There was an error in the App Store. Please try again later. (null)"

  • Jared@Halifax Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 13, 2012 11:41 AM (in response to mattcandy)

    Hey folks,

     

    Oddly enough the iPhoto App just uppdated for no reason that I cold see as I had not done any of what follows herein, really weird. 

     

    So for the last app - Garage Band here is the scoop.

     

    About 4 emails to get to this. 

     

    Basically - make sure you are logged in to the App store and that you have accepted the lincence agreements for the preinstalled apps, and that they show up in the purchased section of the app store.

     

    Reindex the HD.

     

    Then if that does not fix or is not the issue.  Drag and drop the app (in my case it was just Garage Band) to the trash and reinstall from the app store.

     

    Here is the final email from Apple that fixed below.

     

    ******************************************************************************** **

     

    Thanks again for the details you provided. If you continue to have difficulty with the GarageBand updates from the Mac App Store, our engineers have sent some information that can help.

     

    Some similar reports have been resolved by re-indexing the affected system with Spotlight. With the affected Mac being almost new, you might check to see if it has indexed yet (It will be obvious if Spotlight shows "Indexing" in the upper right), or you can re-index your Applications or even the entire drive using the process described here:

     

    Spotlight: How to re-index folders or volumes

    http://support.apple.com/kb/HT2409

     

    If any difficulty continues on that same Mac, the steps below have also been helpful in some similar cases:

     

    1) Back up any data on the affected Mac.

     

    2) Open the Applications folder.

     

    3) Drag GarageBand, or any affected application, to the Trash.

     

    4) Go to the Mac App Store, and select GarageBand from the store as if you were going to buy it.

     

    You will be able to click "Install" and reinstall GarageBand without any charge, as the App Store will recognize that you've already accepted the application.

     

    Please let me know if you're still not able to update GarageBand to its latest version with these steps. Thanks for your patience during our investigation of this issue for you.

  • mattcandy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2012 12:23 PM (in response to Jared@Halifax)

    hmmm... have moved both iphoto and garageband to trash, and then gone to app store to re-install.

    But in app store, for both these apps, I dont get a button saying installed, but the button says 'Accept' instead.  when I press it it does nothing.

     

    Any ideas how I now re-installed and get these applications back?

     

    matt

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.