Previous 1 2 Next 29 Replies Latest reply: Jan 11, 2013 3:08 PM by oldkingdom Go to original post
  • Jared@Halifax Level 1 (10 points)

    Hey Matt,


    Sorry for the delayed responce.  I do not know.  Wish I did! 


    All I can tell you is my story. 

    As outlined above. 


    And I find it odd - really odd that ONE of the two apps just started updating in my case, while the other did not.  I cannot explain why.


    My coles notes version of the 6+ emails batted to Apple over two differnt reps?  Was like this:


    Did you accept them? (I do not even rememeber doing this?) So, I guess I did - likely referring to the license?

    Do they show up in the purchased list in the App store?  Yep.

    Ok.  Index the hard drive.  OK Yep.

    Solved?  Nope.

    Removed the app and when in the App store and redownloaded it.


    Fixed.  .  Yep I guess for now! 


    If all else fails you may need to do as I did - I guess? 


    Email them to get a case started.  It will be fixed eventually.





  • pdyholman Level 1 (0 points)



    I've also been hit by this - but because I only recently noticed my late-November 2012 isn't covered by Epresslane support.


    I've tried the suggestions here, to recap for me:


    I have a new MacBook Pro, purchased from the Apple store at the end of November 2011, pre-installed with ilife and Lion.


    Updates used to work - Iphoto is currently at 9.2.1, but  now System Update" says there are no updates (latest iphoto is 9.2.3)



    Instead App Store says I have an update for iphoto and garageband.


    However, in Purchases, only Lion for my old iMac can be seen (as epected)


    If I try and Update from the App Store, there is an error "You Have Updates available for other accounts"



    Console says:



    22/04/2012 22:55:54.768 Failed to authorize right '' by client '/System/Library/PrivateFrameworks/PackageKit.framework/Versions/A/Resources/in stalld' [1202] for authorization created by '/Applications/App' [1132]



    - Paul

  • bjosh Level 1 (0 points)

    Well I had the same situations but then I went to MAS->Purchases where I was asked to accept iLife applications, GarageBand, iPhoto, iMovie after that I could update the applications (well atleast GarageBand, iPhoto update is still downloading, its 759.75 MB )

  • nickcurran Level 1 (0 points)

    Worked like a charm. Thanks Dah.

  • pdyholman Level 1 (0 points)

    My problem solved - morale of the story is to login to the App Store with the primary Apple ID for the computer.


    My story:


    I make all my Apple purchases (hardware and software) using my own Apple ID,   



    However,  the primary user on our MacBook is my wife and when I configured the machine (from a TimeMachine backup of her older Mac mini), I think the AppStore associated her credentials with the (pre-installed)  ilife, even though the purchase of MacBook itself is associated with my ID.



    I was able to login to the App Store using her credentials (which I've never done before), and obtain the update.



    A little unexpected,  but at least I have the update.



    Perhaps the error messages could be updated to be a little more specific (I assume there is backend check looking up purchases using the MacBook serial number,  perhaps if there are other updates against other Ids, these could be listed explicitely).

  • kimwhoowin Level 1 (0 points)

    Hey guys,


    If you guys are still having the same problem, I think I might have a solution. I was experiencing the same problem. It would not let me update Garageband or Iphoto unless I bought it. Instead, I searched for Garageband and Iphoto in the search panel in the app store, clicked on update and it installed both of them without requiring me to purchase them. Hope this helps!

  • HK Joshua Level 1 (0 points)

    Thanks!  After scratching my head for weeks, going to purchases under the Mac App Store and hitting accept worked for me too!

  • Pete-AU Level 1 (0 points)

    I have iPhoto, GarageBand & iMovie all pre-installed on my Macbook Pro and just had this problem. Your solution worked perfectly for me. Thanks!!!

  • Jared@Halifax Level 1 (10 points)

    Good to hear the solution is working... and it happened to me AGAIN!


    So.  I made sure I was logged in and the purchases were all correct, Deleted iMovie AGAIN. 


    Reinstalling as I type this.





  • JDCastro Level 1 (0 points)

    I have just 3 words: YOU - FREAKING - ROCK!  ... I can finally update those punks, thanks!


    Pura vida,

  • kimwhoowin Level 1 (0 points)

    No problem. I'm glad it worked for you guys. (:

  • EnigMoiDesign Level 1 (0 points)

    I had this same problem with iLife updates on my new mac.


    I solved it by signing in to iTunes with my Mac App Store Apple ID and selecing "Authorize this Computer" from "Store" in the menubar. Now reading this I see that the console entries mention authorization, so this could be the definitive solution.

  • 1hcetih Level 1 (0 points)

    I to am having this same problem cannot update imovie keep getting this message You have updates available for other accounts To update this application, sign in to the account you used to purchase it.

    I just purchased this macbook pro retina spent alot of money. Now I am working with mac app store support by email trying to resolve this issue. I have tried all the suggestions listed above and no luck. I hate the fact that I have to waste time trying to update imovie. I was never expecting such a simple update from Apple to become such a major hassle. I am not feeling the excitement of owning an Apple computer. 

  • Dah•veed Level 7 (33,660 points)

    Do you use iMovie? If not, why let the update become a major issue.

  • oldkingdom Level 1 (0 points)

    I finally figured it out...


    Had to download and install iLife Support from here:


    Ran App Store and the update finally showed up.  Job done.  Good luck everybody.

Previous 1 2 Next