4 Replies Latest reply: Feb 27, 2013 9:58 AM by Skyrickk
DackMartini Level 1 Level 1 (0 points)

On Windows 7, I can't make sounds play through my headphones plugged into the audio jack; the internal speakers always do it instead. The headphones don't appear in the "Playback devices" column, even though RealTek recognises that something's been plugged in/unplugged to it.


Also, the latest version of Boot Camp software drivers I burned to a DVD after upgrading to Lion (v.4.0) refuses to start; it keeps saying that 'Boot Camp x64 is unsupported on this computer model"; I was able to install the v.3.0 drivers by using "Troubleshoot compatability" within the Drivers/Apple/BootCampx64 before, but now it insists I use setup.exe- which refuses to install, even in compatability mode!


It's incredibly aggravating, since I always use my good headphones for gaming so I don't disturb my wife! Help!

iMac, Mac OS X (10.7.3)
  • The hatter Level 9 Level 9 (60,800 points)

    ... you install RealTek driver manually yourself. As for the 'unsupported' then I assume you have 2008 iMac or something early?


    Yes, blocking installing a device driver is strange. And because you don't have 2011 iMac just use 3.0-3.3 instead.


    BCA in Lion should download Boot Camp 4.01+ set.

  • DackMartini Level 1 Level 1 (0 points)

    So the Bootcamp 4.0 drivers won't work with my 2008 iMac? I'm running 3.3 then, and the problem persists.


    I've just tried uninstalling the RealTek drivers; Windows seems to auto-install a "High Definition Audio Device" that DOES play sounds through the headphones... albeit incredibly quietly. Barely perceptible at full volume. I've tried to install the Cirrus drivers from the 4.0 Bootcamp disk; they claim to install correctly (in less than a second, which makes me skeptical), but they still don't appear.


    It seems I can have Realtek and no headphones, or no Realtek and minimal sound...

  • DackMartini Level 1 Level 1 (0 points)

    Fixed the problem, after giving myself a sodding headache trawling through 3 years of "solutions" for Macbook Pros. It seems the RealTek drivers included in the Bootcamp disk (that I had to install in compatability mode) don't quite cut the mustard.


    Get the drivers from the Realtek website directly, the 64-bit install works without using troubleshoot side-steps. Make sure you don't have any other audio drivers enabled in Device Manager (ie. High Definition Audio Device), reboot your system, spill coffee on your lap when your headphones suddenly start working very loudly.

  • Skyrickk Level 1 Level 1 (0 points)

    Thanks, but where could we take the driver on the RealTek website ?