6 Replies Latest reply: Aug 27, 2013 1:32 PM by fjoyner
ScuseMe Level 2 (215 points)

I've got to admit, this is the worst update of Safari that I ever had


After upgrading to 5.1.4, I opened Safari. After beachballing for several minutes, I was finally able to gain control. Much to my horror I had *no* bookmarks, *no* extensions, and hundreds of "untitled" tabs. Wow.


After deleting all the "untitled" tabs, I thought that I'd just go in and reinstall the extensions. I went to the Extensions Gallery and chose Adblock. After a few seconds I got an error "Safari can't install this extension. An error occurred while installing the extension "Adblock"". I tried the next extension Twitter and got the same error! Every extension I tried to install gave the same error!


I then reset every Safari item to start Safari from scratch. I thought this would work, but the same thing happened - every extension gives an install error. I have no idea how to proceed from here. Does anyone have any thoughts?



iMac, Mac OS X (10.7.3), 24" C2D 3.06 GHz;1 TB HD; 8 GB RAM
  • Carolyn Samit Level 10 (102,820 points)



    Safari preferences may be corrupted..


    Quit Safari.


    Go to ~/Library/Preferences


    Move the com.apple.Safari.plist file from the Preferences folder to the Desktop.


    Relaunch Safari. If that helped, move the .plist file to the Trash. If not, move it back to the Preferences folder.


    If that didn't work, go to ~/LIbrary/Safari/Extensions. Move the Extensions.plist file to the Trash. Quit, relaunch Safari to test.



    ~ (Tilde) character represents the Home folder.


    For Lion:   To find the Home folder in OS X Lion, open the Finder, hold the Option key, and choose Go > Library

  • ScuseMe Level 2 (215 points)

    Hi Carolyn,


    Thanks for trying to help.


    Moving the com.apple.Safari.plist file out of ~/Library/Preferences did nothing, so I put it back.


    Under ~/LIbrary/Safari/Extensions I don't have a plist file. In fact, there's nothing in that folder.


    I did notice something strange - that Extensions folder icon has a red dash in the bottom right. So do the folders Databases and LocalStoage under the same path. I think that red dash has to do with the folder permissions, which are drwx------ (700). I don't know if that has something to do with my problems, since I've never looked at those folders before.

  • Linc Davis Level 10 (184,375 points)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.


    Launch the Terminal application in any of the following ways:


    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    Open LaunchPad. Click Utilities, then Terminal in the page that opens.


    Drag or copy – do not type – the following line into the Terminal window, then press return:


    chmod -R -N ~


    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:


    sudo !!


    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.


    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.


    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.


    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.


    Select your boot volume if not already selected.


    Select your username from the menu labeled Select the user account if not already selected.


    Under Reset Home Directory Permissions and ACLs, click the Reset button.


    Select ▹ Restart from the menu bar.

  • ScuseMe Level 2 (215 points)

    Hi Linc,


    Thanks for your detailed reply, although after completely destroying my SL installation after trying to repair a home directory permission problem, I'm very leery to attempt what you suggest. I'm going to try evrything in my power to correct the situation before attempting what you suggest. But again, I appreciate the detailed directions.


    I also want to say Linc that I habsolutely *no* problems with my Lion installation, other that this borked Safari 5.1.4 upgrade. I have Time Machine plus 2 images of my working installation to make sure that I can recover from any disaster. I do realize that I can't uninstall the Safari 5.1.4 update, and I won't do so with Time Machine (unless someone with alot more experience in this area tells me specifically that I can use Time Machine to roll back the Safari update).


    I did try rebooting and reinstalling Safari 5.1.4 from a manual download of Safari, but the extensions still won't install. I am surprised though that the Safari installer did not require a reboot after installing Safari. I seem to remember always having to reboot after a Safari installation, but possibly Lion removed this requirement.


    To be honest, Chrome has become my browser of choice. I've been keeping up my Safari version to maintain my bookmarks between Mac Safari and iOS Safari. Unfortunately, since iCloud is refusing to sync my bookmarks (this happened way before Safari 5.1.4), I'll probably abandon Safari altougether until the next version is released.


    Please everyone, keep the comments and suggestions coming. I'll try almost anything (except for Linc's suggestion, as good as it sounds to me).

  • ScuseMe Level 2 (215 points)

    Hi Carolyn and Linc,


    Taking a cue from Carolyn (the Extrensions folder) and Linc (permissions fix), I corrected my Safari problem using a "surgical" method of correcting the permissions of the 3 folders I mentioned previously:






    Somehow, during the upgrade of Safari to 5.1.4, the installed dropped my userid from their permissions list. It's not that my permissions were changed, my permissions were completely gone. So I simply added myself as an owner (R/W) for those 3 folders and restarted Safari. When I did so, my extensions reappeared.


    I reported this installation problem to Apple.


    Thanks for all the feedback and help.

  • fjoyner Level 1 (0 points)

    Linc:  Your solution is the ONLY one that worked for me.  Thank you for the detailed instructions.  I follow excellent instructions excellently.  Likewise, I follow incomplete, presumptive or poor instructions poorly.  Perhaps it was radical using the restore partition and all, but finally I have regained the 1Password extension (and any others) in Safari.


    Thanks again,