Previous 1 2 3 Next 44 Replies Latest reply: Aug 4, 2012 2:11 AM by KrankyAgie
softee6698 Level 1 Level 1

Ever since the latest Apple TV software update (Apple TV Software 5.0 (4099)) my home share has been disconnecting in the middle of playing movies, or TV shows.  I have updated my iTunes software, running 10.6.  I'm just irritated, I rent a movie from iTunes and about 15 mins into the movie home share disconnects.  My laptop is not going to sleep, I have my energy settings set so that it never goes to sleep while I'm trying to watch a movie.  Any advice or any word on if Apple intends to fix this problem would be appreciated.  It is also happening to my roommate and her Apple TV.  Thank you.



AppleTV 2, Apple TV Software 5 (4099)
Solved by Winston Churchill on Mar 15, 2012 3:58 AM Solved

Intermittent problems are often a result of interference. Interference can be caused by other networks in the neighbourhood or from household electrical items.


You can download and install iStumbler (NetStumbler for windows users) to help you see which channels are used by neighbouring networks so that you can avoid them, but iStumbler will not see household items.


Refer to your router manual for instructions on changing your wifi channel or adjusting your multicast rate.


There are other types of problems that can affect networks, but this is by far the most common, hence worth mentioning first.

  • Winston Churchill Level 10 Level 10
    Mac OS X

    Intermittent problems are often a result of interference. Interference can be caused by other networks in the neighbourhood or from household electrical items.


    You can download and install iStumbler (NetStumbler for windows users) to help you see which channels are used by neighbouring networks so that you can avoid them, but iStumbler will not see household items.


    Refer to your router manual for instructions on changing your wifi channel or adjusting your multicast rate.


    There are other types of problems that can affect networks, but this is by far the most common, hence worth mentioning first.

  • Peter Hillman Level 4 Level 4

    You are not alone.  There must be a bug in the 5.0 software because the Home Sharing link with iTunes rarely broke with version 4.4.4.  It happens to me too.  I have a full signal on AppleTV2 and my iMac is on Ethernet to my Apple Extreme Base Station.  There are no interference problems because you can stream content from the internet sources, including Apple iCloud, without any problems.  However, the moment you try and play a video source from your Mac, the link breaks after about 5 minutes of playback, bumping back to the main menu with the Home Sharing message at the top telling you to add a computer to Home Sharing.  Quitting iTunes and relauching brings it back, hoping that it doesn't break again.  I reported the bug to Apple, but haven't heard back yet.  Immediately after updating to 5.0, the Home Sharing problem started.  The TV Shows out of order is also a known bug that has been confirmed by Apple.

  • Wadood Chaudhary Level 1 Level 1

    I have same problem for more than 2 years now. Nothing to do with WiFi because AppleTV, Windows machine (iTunes) and Mac are on the same wired network. iTunes diconnects itself and when I restart it then it begins to show again.

  • Peter Hillman Level 4 Level 4

    Problem solved with the iTunes 10.6.1 update.

  • Tweety_germany Level 1 Level 1



    I tried everythink, but same as before!


    - droppings ot the main screen

    - loosing Home Share


    now even on iPads !




    I'm now more than convinced that this is caused by the latest iTunes version.


    As some others stated in other threads .... it seems that Apple doesn't really take care of this problem. So what if, if we could make them feeling the same pain as we do. ... Just by dropping them a mail as soon as we have the problem again. Not more often, we don't want to be unfair, but everytime it happens.


    I found this feedback site


    I will start now with this.... maybe this will help to rise a little bit of attention




    This is the mailbody I always use


    Hello all,


    Since the last update to iTunes Version 10.6.1 (7) streaming content (Movies and TV shows) to Apple TVs and iPads has two major problems:


    - Home Sharing is lost during streaming (streaming stops even if a large portion of the content is already preloaded)


    - streaming stops and the main screen pops up (Home Sharing still available)


    This happens sometime after some minutes, sometimes after several hours, but it surely happens.


    I followed every advice I could found on this support website. There are now a lot of threads following this issue.


    Sometimes it seems getting better, but hours later the same isues occured again. Watching content on this enviroment is a real pain and very frustrating.


    As many others I'm now convinced that the latest update of iTunes caused this problem.


    Our family enviroment contains the following Apple products:

    - iTunes on a Win7 32 bit Noname PC (all content)

    - second iTunes on a iMac with OS 10.6.8 (all content)

    - third iTunes on a MacBook Pro with OS 10.6.8 (daughter, only selected content)

    - fourth iTunes on a Win7 32 Samsung Notebook (son, only selected content)

    - all iTunes sharing the same Home Sharing ID

    - 2 Apple TV second generation

    - 1 Apple TV first generation

    - 2 iPod touch (bought last year)

    - 2 iPads (second generation)

    all firmware or software are on latest available patchlevel.


    At this moment, I can not recomend to others to buy this products.


    I will drop this feedback everytime my famiily and I facing this problem... just to help you to get a better feeling of the urgency of this issue.


    Thanks for every effort in advanced.


  • SoundForSound Level 1 Level 1

    Home sharing with the new Apple TV / iTunes update is just broke.  Only works for a bit unless you restart iTunes or disable / re-enable Home Sharing.  Use to work great until the last updates.  This is not a network (router, firewall, ...) issue - just a (bad) regression in Apples software.  Hopefully they fix this soon, hard to believe its been broke this long already.  The Remote app update also fails to connect to Apple TVs (but does connect to iTunes) for many people as well.  Poor QA all around. :(


    I have yet to see any suggestion that actually works other than reverting to previous versions of fwr / iTunes - which is a pain / joke to do.


    There are a *ton* of posts about this:


  • Peter Hillman Level 4 Level 4

    The iTunes 10.6.1 update did not fix the Home Sharing link issue, but it does take longer before the link breaks.  The problem is with extended wireless networks.  If you have an AirPort Express in your house extending your Wi-Fi network, that is causing the Home Sharing link to break with the AppleTV 5.0 software.  I have an AE extending my network so my Blu-Ray player can access the internet using the Ethernet port on the AE.  The link was breaking within 5 minutes of watching video streaming from my Mac.  Once I unplugged the AE and the AppleTV connected to my main base station, the link no longer breaks.  After updating to iTunes 10.6.1, I tested it again, and this time it takes 20-30 minutes before the link eventually breaks.  Unplugging the AE fixes the problem once again.  So if you have an extended network set up, unplug the extended base station and your Home Sharing link will remain connected.  I haven't had any problems when my AE is unplugged, which removes the extended network from my Wi-Fi.

  • GS455 Level 1 Level 1

    I am not seeing this.  I am gigabit wired from the ATV2 to the media server running iTunes 7 Home Premium and I drop after a matter of seconds.  I have an Airport for the wireless devices, but that is out of the loop.  I use the wireless side as a workaround as I can use the remote app on my iPhone 4 to access the media server and send the video to the ATV2.  After the video launches, then I can use the ATV2 remote to pause/start the video and advance chapters, but I can't switch videos without going back to the iPhone.  My ATV1 on the wireless side does the same thing - drops quickly and that is running ATV 3.0.2, so I think it is an issue with iTunes and not necessarily ATV software.  Admittedly I have not used the ATV1 for months before this recent trouble shooting, so I have updated the iTunes on the server several times since I last used the ATV1.

  • Tweety_germany Level 1 Level 1

    Maybe you both are right ;-)


    Today I tested the last hint I found. Assigning a fixed IP Address to the ATV.


    It was a little bit of work, because I have to assign two fixed IP address on my router (who serves as a DHCP server), than assign them to the ATV and than reboot every PC, Mac, ATV and Airport-Devices at the same time ...


    Since than it works fine, seamless .. as you name it...


    so it COULD be a problem within the DHCP service ... and this might be a bigger problem on "extended WiFi" (as I use)..


    BUT: Yesterday I also had problems with my iPad .. it also lost the Home Sharing from time to time ...


    ... what ever it is, I read so many suggestions which worked for some people and worked not for others ... I think that's all sideffects suppressing symptoms but not healing the real problem ...


    I'm still convinced that the new iTunes version is the problem!

  • GS455 Level 1 Level 1

    Hmm...  Seems like the new version of iTunes has a DNS resolution problem.  That is your DHCP server will log the computer logical name (alphanumeric characters for the ATV) and amatch them to the IP address assigned by the DHCP server and then broadcast that to all the other computers so that network discovery and similar services such as Bonjour in the case of apple devices can find computers by their logical name.  As the DHCP server regularly broadcasts this list for non-fixed IP devices, the network name resolution function within all the clients receive these regular messages and keep their on-board list updated so that as computers come on and off the network, the list of the other clients is pretty fresh.  The home share probably drops on cue from the regular DHCP broadcast as that list is updated. 


    The iTunes Bonjour services does this and more because it handles other apple devices - particularly home share devices - in a special way.  That is video and audio sharing rights, album art, authorized computers, mother ship queries (iTunes store) and so on and so forth.  I'll bet the home share rights are enforced more rigorously when outside devices poll the iTunes host as opposed to being on the iTunes host computer and sending a media file to a user.  Everyone who has weighed in on this has had the problem from the ATV accessing the iTunes host.


    I wonder if this is the root of the problem if Apple will send me a consulting fee ;-).

  • Tweety_germany Level 1 Level 1



    well I don't know if you ever get payed ... but this morning its happened again .. but the easy cure was a reboot of the ATVs .. after this it was back to smoothly operation ....

  • Leduromax Level 1 Level 1

    Hey guys I might have something to explore. I contacted apple on the phone yesterday. The guy was quite knowledgable even if I was a little pis.... since I am too experiencing the same problem with my apple TV 3 with home sharing randomly disconnecting.


    We explored together what could be the problem. I told him not to bring stupid things like restarting the router or makin sure my apple tv was plugged in, etc.


    Then, we realized that it could be due to the automatic sleep of my new external drive a seegate where I have recently moved all my itune library. This drive as the genius idea to go to sleep after 1h or so...I don't know yet if it will solve the problem but I'll give it a try and let you know.


    I had a hard time finding a utility to turn the sleep mode to NEVER on mac os though. it is called seegate sleep override utility.


    I hope it is a solution...

  • timnic001 Level 1 Level 1

    Hi Guys, I too have spent hours on this problem and unfortunately I have narrowed it down to one of two problems.


    Firstly the firmware on ATV, its definitely not ATV 2-or 3 themselves as I have both and ATV 2 was working perfectly before the firmware upgrade, now it does the same as ATV3. I will try and investigate on how I can revert to the previous version, but would suggest its not simple. The other problem was I stupidly updated the airport firmware at about the same time or just before, so introducing two changes, now not allowing me to identify which one is causing the problem!


    What I do know, it is not the external disk. I am using a Promise R6 that doesn't sleep and its firmware has remained the same as before I introduced the ATV 3 to the mix. Its been working fine for the past 12 months. 


    There may well be some value in the extended network especially as I have updated the firmware, but due to the coverage, its a big hassle taking the Airport express out of the loop, but I think it has to be the next thing to try. That being said the common single point everyone appears to be focusing on is the ATV firmware. I am just about to contact apple and see what they say again.


    Unfortunately whilst I love Apple, the arrogance of the company rarely admit to problems, until it goes viral that is! Will update if I get the answer?    

  • timnic001 Level 1 Level 1

    After speaking with the business genius team they have suggested one of two options. They are saying, but not admiting that the network could be more sensative on the new firmware. So either choose a manual wireless channel at the lower end, say channel 3 or push everything out on the 5Ghz network!


    Easier said than done, as it is a lot weaker signal, but after an hour I managed to get an extended network set up on 5Ghz with a strong signal, so now we will just have to wait and see. They are calling me back next week to see if it resolved the situation and if not escalate it.


    What they are saying is the 2.4Ghz network has a lot of interferance, from digital phones, microwaves and other wireless networks in the area and maybe, just maybe the new firmware is more sensative, it could be BS, but it all sounded logical so worth a try.   

Previous 1 2 3 Next