2 Replies Latest reply: Apr 18, 2012 7:14 PM by thenobleshrew
thenobleshrew Level 2 (210 points)

My Snow leopard machine hangs during startup at the screen with the Grey Apple logo.  It appears there is a SW issue with my OS X boot partition.  Here are facts I have learned:

  • The computer boots fine if I hold option at startup and select my boot camp partition
  • The compute boots fine if I attach an external HD with OS X 10.6
  • Running a disk repair from the external HD, I see the following two issues that are repaired.  Also, note the last line about boot partitions
  • DriveRepair.png
  • After this disk repair, the disk will still not boot, it hangs at the Grey Apple logo.
  • Booting in safe mode does not resolve the issue, the machine will still not boot to a desktop
  • Booting in Verbose mode, drivers initialize with the last succesful line being the ethernet drives (I believe) and then the hangup occurs.  It is unclear what state the boot process is at on the hangup.


This situation has happen twice in the past few weeks.  The first time I did a reinstall of OS X to resolve the issue.  Then, the issue appeared again approximately two weeks later.  I'm hoping to avoid a second reinstall (And really, avoid this issue in the future).


Any thoughts on what is happening?  It seems perhaps something in the boot partition table or the OS partition, although disk utility says the partition is fine.  I have downloaded Test Disk 6.13 to look at the partition table, but I don't know how to interpret the outputs of that program. 


Any help appreciated.



MacBook Pro (15-inch Core 2 Duo), Mac OS X (10.6.3), 2 GB RAM, Boot Camp, Ex HD avail
  • thenobleshrew Level 2 (210 points)

    As a followup, I tried to run a combo updater install to correct this issue.  I booted from my External HD, and downloaded 10.6.8 to update the non-bootable drive.  However, 10.6.8 says it cannot be installed on this drive:



    I read that 10.6.5 changed something about the partition table, so I tried falling back to 10.6.4 instead, and got the following message at the end of the install process:



    I then tried 10.6.5 which says the disk is not properly configured to accepted the installation:



    So the non-bootable drive has 10.6.3 installed on it, and 10.6.8 cannot be installed because it is not the startup disk, 10.6.5 cannot be installed because "the requirements are not meet" and 10.6.4 fails during the install process.  Talk about nothing going my way!



  • thenobleshrew Level 2 (210 points)

    As an update, it seems the issue may have been caused by VPN software from Sonicwall.  Itw as the only piece re-installed between crashes, and on the most recent OS reinstall I choose not to install the VPN software and the issue has not reappeared in over a month.