8 Replies Latest reply: Nov 29, 2013 9:19 PM by Marc.Speth
adstrach Level 1 (0 points)

I have tried to create a new standard user on imac OS Lion but new user is unable to access internal hard drive.  When I check permissions, HDD says it is "fetching".  Have created new admin user and get same problem.  Already have 2 users (one admin & one standard) with no problems.

iMac, Mac OS X (10.7.3)
  • macjack Level 9 (50,790 points)

    Boot up holding command-r keys into Lion Recovery Volume.

    The screen should give you these choices...


    Restore from TM backup

    Reinstall Mac OS X

    Get help online

    Disk Utility


    Choose Disk Utility and try to Repair Permissions. If you still get the "fetching" issue then run Repair Disk and let us know your results.

  • adstrach Level 1 (0 points)

    Thanks for your advice.  I did repair permissions and repair disk.  I still have the fetching issue but have sorted out the access issue by creating another new user and then deleting the previous one.  I now have "fetching" displayed twice in the permissions section.

  • Glenn Leblanc Level 6 (9,135 points)

    Strange that you would have fetching on a new user, but try repairing user permissions for each user following this:


    1. Turn on the Mac whilst holding down cmd + R. You can let go once you see a spinning dial. You will then see the ”Mac OS X Utilities” screen.
    2. On the top menu, click Utilities, then click Terminal.
    3. Type resetpassword and press Enter.
    4. Click on your main hard drive.
    5. In the dropdown box under “Select the user account” make sure to select your username.
    6. Underneath where it says “Reset Home Directory Permissions and ACLs”, click the Reset button.
    7. Press cmd + Q to quit the Reset Password application.
    8. Press cmd + Q again to quit the Terminal.
    9. Press cmd + Q one more time and click Restart.
  • jsd2 Level 5 (6,200 points)

    I'm not sure where you are looking. If you are describing the Get Info window of your startup disk itself (usually Macintosh HD), then there may be something wrong with the ownerships there. If you look at those permissions from the user account that has "no problems", what do you see exactly? It should look like this:


    2Screen Shot 2012-03-16 at 7.13.25 AM.png

    If you see something different, please post a screenshot.

  • mtslights Level 1 (10 points)

    If anyone's still troubleshooting this, here's a screen shot of what it looks like for my startup disk.


  • vanclute Level 1 (5 points)

    I have this identical problem, with the identical scenario as depicted in the OP's screenshot post.  I have just migrated (using Migration Assistant) the stock internal HD of a 2007-era Macbook pro running 10.7.4, to a new SSD drive.  Running on it just fine, until I attempted to update Firefox.  The update wouldn't perform, and that's when I discovered the permissions issue on the .app itself.  I see it also on the entire Applications directory as well as System, Users, and Library.


    I deleted Firefox.app manually and reinstalled, and the new copy has the correct permissions, and in general everything is working.  A repair of the Home folder ACLs and permissions (2 actually) has done nothing, and general permissions repairs also claim to find a few minor incorrect permissions and claim to fix them, but actually don't fix anything and will find them again immediately.


    I'm not sure if this is actually something to be concerned about or not... does anyone know?  It's certainly not normal that's for sure.

  • Marc.Speth Level 1 (0 points)

    I am having this same problem with Mavericks.  I have an external drive with files that I share with my family, and sharing with another Mac is no problem, but we now have a roomer that is using Win XP and, while my wife's Win8 computer can access this shared external drive with no trouble, the WinXP machine always asks for a name and password and can't see the Guest account (that works just fine for Win8) and login fails.


    So some searching on the internet said to setup a new user account and then give that new user privelages to access the shared volume.  OK, new user created, check, give the new user privelages on the shared drive ... perpetual "Fetching"


    No solution in sight yet.

  • Marc.Speth Level 1 (0 points)

    I think I've figured it out.


    After I created the new account on my Mac, I immediately went to the hard drive I wanted to share with that new account and when I tried to add that new user to the "permissions" it gave me the perpetual "Fetching"


    I then shut down my Mac (complete power off - not a Restart) and started it back up.  NOW I was able to add the new account to the shared drives permissions with no problem.


    I suspect it takes a shutdown and startup for the new account to be fully recognized by the Mac OS.


    The second part (since I am running Mavericks OSX 10.9) is to go into the Sharing control panel and click on Options, and in there I had to put a check beside the new users name and supply their account password.


    NOW I can log in from WinXP by logging in using that account name and password!