Previous 1 2 3 4 5 Next 63 Replies Latest reply: Aug 27, 2014 12:54 AM by alaena Go to original post
  • Hibernian56 Level 1 (15 points)

    Its pathetic, you would wonder if anyone in Apple actually listens to its customers anymore.


    Before I upgraded to iTunes 11 (which is actually quite nice) I dragged the kext to the desktop, then upgraded and only then did I reload the old kext (2.2.0) into Kext Utility.


    Works again.


    This is extremely shabby product testing from Apple, if any.

  • stedm Level 1 (0 points)

    Hi all, I used "Hibernian56 solution" with iTunes 10.7-3GS 5.1.1-mac 10.6.8 and it works well but after the iTunes11 update i got the same issue so I tried the same hotfix but it doesn't work. Any advice?

  • depomnic Level 1 (0 points)

    It works for me (macbookpro 10.6.8) under iTunes 11.

    Maybe you can delete the previous appleusbethernet.kext before installing the old 2.20 extension.


    Remember it's better to restart the Mac after the installation.


    All the best


  • stedm Level 1 (0 points)

    Solved! Thanks

  • ElCampeador Level 1 (0 points)



    I solved this issue.


    I had the same problem : my MBP under OS X SnowLeopard 10.6.8 with Itunes 10.7 and an iPhone 3GS with iOS 6.0.1.


    One day i decided (i wonder why... onless to have a good configuration of my iphone under itunes, cause it bugged under 10.7... an other topic...) to install brand new iTunes 11.


    Itunes installation successful, then i got access to all my iphone applications under iTunes GUI.


    BUT since then USB tethering did not work (my iphone 3GS perfectly working under iOS 6.0.1, 3G network ok) : my iphone was not detected under network settings, unless being seen by itunes 11 perfectly.


    I decided to enter TIME MACHINE and replace current AppleUSBEthernetHost.kext file (within system/extensions) that was in version 2.3.6 after installing iTunes 11, by the former version under itunes 10.7 : V 2.3.0.


    With v2.3.0 of AppleUSBEthernetHost.kext it works again!


    Conclusion : Was the V2.3.6 of this file been tested under SnowLeopard by Apple? I guess no.


    This is not acceptable from Apple.


    Tx to Apple for loosing my time  (again)



  • depomnic Level 1 (0 points)

    Dear all


    It seems that iTunes 11.0.1 update released yesterday doesn't address the issue with AppleUSBEthernetHost.kext, as the version included with this update is 2.3.6...the same that cause the overall issue.


    Somebody who have updated itunes 11 to 11.0.1 could tell us the consequence for the iphone usb tethering function ?



    King regards




  • ElCampeador Level 1 (0 points)



    What could it change if the newly installed version of AppleUSBEthernetHost.kext by iTunes 11.0.1 is still V2.3.6?


    Would you mean they could have not change the version number although the newly ...kext could solve the issue?

    If so it would mean 2 things : apple does not "version" its software component (which would definitly indicates that "there is a big mess... in its software procédure" OR "Appe is trying to hide this issue in some way". I cannot believe it.


    Anyway, I won't install iTunes 11.0.1 for trying to check that because I have spent enough time trying to find out what and where is the issue.


    At last, i have now a configuration that runs well under iTunes 11... (until the next compulsory upgrade?)


    Now the big job is to move from my SnowLeopard 10.6.8 to Mountain Lion (not that easy... i have also opened a ticket to the apple support... and spent hours installing then restoring SL because ML does not boot (grey screen).

    But this is an other story.





  • chapados Level 1 (0 points)

    Same here — the upgrade to iTunes 11.0.1 messed up (again!) the USB tethering with my iPhone. Restored /System/Library/Extensions/AppleUSBEthernetHost.kext from Time Machine and it worked great.


    For the record, I'm using Snow Leopard on a MacBook pro (early 2011).

  • Chinajochen Level 1 (0 points)

    THANKS!! USB tethering works perfectly fine now....appreciate your instructions!!

  • Elboe Level 1 (0 points)

    This worked for me, thanks.

  • abrahamsz Level 1 (0 points)

    Can you show me a video on how to fix this? Im a newbie o mac :p

  • MaKr-0617 Level 1 (0 points)

    Hi, just started a new topic on the same issue. I have iTunes 11.0.2 installed - tried two versions of AppleUSBEthernetHost.kext but not 2.3.0. I don´t use TimeMachine - any idea how I can retreive this file?!



  • Chris45 Level 1 (0 points)

    You can download it via, or more directly from  (The original post linking to this is at search for Dopey Dupe).


    I've kept a copy for myself, and have used it successfully 3 or 4 times since then, every time a new iTunes comes out.


    Regards, Chris

  • MaKr-0617 Level 1 (0 points)

    Thanks Chris,

    Tried this version but still no luck - I can only connect to internet using wi-fi...:(

  • MaKr-0617 Level 1 (0 points)