Skip navigation

How to disable Genius Mixes on IOS - Ipad2?

49030 Views 67 Replies Latest reply: Aug 14, 2013 5:09 AM by refaea RSS
1 2 3 ... 5 Previous Next
zbbeck Calculating status...
Currently Being Moderated
Mar 16, 2012 10:59 AM

All of a sudden my playlists on IPad (Itunes Match enabled) are showing a whole bunch of Genius Mixes -- (what is "Stoner Rock?)

 

It seems like Genius was recently added to Itunes Match, however, I have it hidden on my Mac (doesn't look like there is a way to turn off Genius with Itunes Match).

 

Is there a way to remove these Genius Mixes from the Ipad?  I don't want to have them clutter my playlist selection screen.

 

They are not showing up on Iphone.

iPhone 4, iOS 5.0.1, Itunes Match
  • Kevin O\'Shea Level 2 Level 2 (445 points)
    Currently Being Moderated
    Mar 17, 2012 12:40 AM (in response to zbbeck)

    Yes please! Same problem here. I wish I could turn off Genius, but that's not an option with iTunes Match.

     

    FYI, they're on the iPhone too. It's just that the iPhone (thankfully) has a separate category for Genius Mixes, whereas the iPad merges them with Playlists.

  • Kevin O\'Shea Level 2 Level 2 (445 points)
    Currently Being Moderated
    Mar 17, 2012 9:26 AM (in response to zbbeck)

    I don't know that the Genius Mixes really sync at all. I think they may be created locally. The iPhone has the same thing, but not under Plylists. There's a separate category which may or may not be shown by default (e.g. You might have to hit the 'More' button to see it) which behaves similarly to the iPad.

     

    I'm in the same boat as you. Can't get rid of them on the iPad (or iPhone, but at least you can effectively hide them there).

  • ESN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2012 4:04 PM (in response to zbbeck)

    Exact same issue.  Noticed that I have all these extra genius playlists on my iPad (was just focusing on the music on my iPad b/c I upgraded to a 3).  On my 4S (which I use all the time for music), I didn't see them but like Kevin said, they have been there just in a separate category than Playlists.  I tried "unhiding" genius in iTunes preferences and then deleting all the genius mixes hoping that this would then somehow erase them on my iOS devices (since I think in iTunes you are just hiding, not eliminating genius).  Was able to delete all but one (weird).  Then tried turning iCloud off and back on on each iOS device and all of the original genius mixes (most of which I had since deleted) were still there.  Doesn't seem like you can hold your finger on the genius mixes in the iPad music app and just delete them.  Haven't tried on the iPhone but I'm sure it is the same.

     

    Very annoying.  Basically I would like to totally disable genius in iTunes (must be slowing my PC down) and not have my iOS devices cluttered w/ all this garbage.

     

    I recently converted to iTunes match / iCloud for all my music which I like (despite the 5 days it took me to get my music up there)....please help.

     

    Before coming here, I just googled the issue and there were a ton of complaints about not being able to use Genius w/ iTunes match / iCloud - guess they must have "fixed" it...should be some sort of toggle option to disable in iTunes and on each iOS device.

  • ESN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2012 5:51 PM (in response to zbbeck)

    Seems like Apple must have "fixed" something on their end to get Genius playlists and mixes working w/ iTunes Match.  The timing I think was coincidental for me.  I rarely used my 1G iPad for music so never paid attention to the genius mixes being combined w/ my other playlists.  On my 4S, which I use regularly, I wouldn't have noticed the Genius button in the "More" menu because I never go there (and not sure it was even there before - see below). 

     

    Since I got a new iPad on Friday and needed to basically turn iCloud on for the first time, I think that must have triggered the Genius mixes getting synced with my new iPad (see posts in the thread below - seems like you need to toggle iCloud off and back on on the individual iOS devices to get it to sync if you had been using iCloud before).  In messing around w/ my iPhone today I then toggled iCloud off and back on (hadn't done that in a couple of weeks when I first started using iCloud), and that brough the "Genius" button to one of the four visible items in the Music app.  I now buried it in the "More" menu so it is a lot less annoying.

     

    https://discussions.apple.com/message/17864687#17864687

     

     

    So what I still want to know is how we turn it off!!  And why can't you disable Genius altogether in iTunes (just hide it). I think in older versions of iTunes there was an option in the "Store" menu to "Disable Genius".

     

    Annoying.

  • Grandparr Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 18, 2012 10:23 PM (in response to ESN)

    I'm so pleased to find out that others are trying to get rid of the Genius Playlists. While getting acquainted with my new iPad this weekend, I found that I now have 15 Genius Playlists included on my Playlist Tab. Tried everything I could think of to remove or turn off the Genius Playlist, including all the actions mentioned here.

  • Grandparr Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 19, 2012 10:01 AM (in response to Grandparr)

    UPDATE: I NOW HAVE 22 GENIUS MIXES ON MY NEW iPad. This is Crazy!!!

     

    Apple Please provide a way to hide this mess of Genius Mixes.

     

    If I wanted random music I'd use PANDORA.

     

    I'm so pleased to find out that others are trying to get rid of the Genius Playlists. While getting acquainted with my new iPad this weekend, I found that I now have 15 Genius Playlists included on my Playlist Tab. Tried everything I could think of to remove or turn off the Genius Playlist, including all the actions mentioned here.

  • David Illig Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 19, 2012 10:25 AM (in response to zbbeck)

    Same here, but we need to get over this. It is not possible to use iTunes Match without having "Genius" lists -- except perhaps by turning on Home Sharing with a computer that has Genius turned off -- but that won't help you when you're away from home.

     

    What an oxymoron! Idiot lists, because they assume that we are not smart enough to create or own playlists.

  • pstadler Calculating status...
    Currently Being Moderated
    Mar 25, 2012 2:52 AM (in response to zbbeck)

    Same problem here. There's simply no way to get rid of Genius with iTunes Match. Apple should provide a way to turn this off again.

  • slifty Calculating status...
    Currently Being Moderated
    Mar 26, 2012 9:19 PM (in response to zbbeck)

    AHHHHHHHHHHHHHHHHHHHH!!!

     

    I have to say, I don't appreciate stuff being jammed down my throat with no way to delete it.  This includes apps AND playlists.

  • Beverly Martin Calculating status...
    Currently Being Moderated
    Mar 27, 2012 7:15 AM (in response to zbbeck)

    Same problem. I don't use genius, I don't like genius, but I have to schroll trough 31 genius folders to get to the music I want to listen to. How can it be turned off.

  • chaosplan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2012 5:49 PM (in response to zbbeck)

    I think I figured this out - partly.

     

         Tap on the unwanted Genius list in the Playlist.

         In the resulting Playlist, tap on the Save button.

         Tap on the <Playlist button to get to your colleciton of Playlists

         Tap and Hold on unwanted Genius list

         Tap the X to delete the list.

     

    This only seems to work on secondary Genius lists, I have an original Genius list that can't be deleted, nor can I view it's contents.

  • sabvalleygirl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2012 1:23 AM (in response to zbbeck)

    GRRRRRR! I hate this feature too! I tried to follow the directions posted by chaosplan but when i click on a genius playlist it just starts playing music and I can't actually see the playlist. So that was a no go.

     

    HOWEVER just before I started typing this I turned off Genius on iTunes on my Macbook Pro (where i sync my new iPad) and started a sync with the iPad and BAM they were gone!! So try that!!

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.