7 Replies Latest reply: Jul 4, 2015 5:50 AM by Yvonne_UK
Stephenm54 Level 1 Level 1 (0 points)

I am having problems with Outlook Mac.  I am on a 1.7 GHz i5 4GB Macbook Air.  When I switch from mail or calendar to contacts, the spinning wheel goes for about 15 seconds before I can search a contact.  I can seach for a contact just fine using spotlight, but I am not accustom to this and am using it more as a workaround.  I have about 3,000 contacts so I don't think this is some sort of volume issue.  On spotlight, it searches fast, just if I click on contacts while in Outlook does it seem to take forever before I can start searching.  Once I'm past the 15 seconds of waiting, it operates as one would expect.  if I click on calendar or mail and then right back to contacts, I'll need to wait again.  Has anyone experienced this?  Any suggestions on how to resolve it? 


Thanks, Stephen

Outlook:Mac 2011, Mac OS X (10.7.3)
  • VanSmaq Level 1 Level 1 (0 points)

    It has been quite some time since this question has been asked, and like many others, I have scoured the net looking for a solution and I believe that I have found one.


    I deleted the Outlolok preferences out of ~/Library/Preferences and restarted Outlook. Behold, the problem was gone. Until I switched the sorting of the Contacts from the default "Name" to "Last Name". When I did that, the problem came back. In fact, if I changed the sorting to anything other than "Name", the delay would reappear. I tested this on three different MacBooks and the results were replicated across all three.


    If you are still having this problem, check to see how your contacts are sorted. It would be interesting to know if this "fix" helps anyone else.

  • BillPennock Level 1 Level 1 (0 points)

    I could not find any Outlook preferences under library/preferences (I am on Maverick) but I did add the "name" column to my column headings and changed the sort to use that and it fixed the problem. 


    Kind of annoying since the most standard sort would be last name first but this is FAR better than waiting (mine was more like 20 or 30 seconds) every time I switch to contacts.

  • BillPennock Level 1 Level 1 (0 points)

    I just tried changing the sort after opening it to last name and it was 55 seconds to give me back my contacts.  They must be using the "slow-and-slower sort" algorithym. 


    do Iterations

    switches = 0

    For i in <listofcontacts>


         x = next listofcontacts

         if x > i

              leave alone


               switches = switches + 1

              switch x and i



    if switches = 0



    next iteration

  • fishlaw Level 1 Level 1 (5 points)

    Fascinating- iI have had this problem on my iMac since I bought it two years ago, but not on my MacBook Pro-[urchased at about the same time.


    Now I can't wait to see if they are set to sort differently.  I wonder if the actual contacts are pre-sorted under the default rule, and a different rule requires them to be re-sorted before they can be loaded.  Will update when I check the machines, which are at home. (PCs only in the office)

  • BillPennock Level 1 Level 1 (0 points)

    I'm just guessing but I'll bet that's what you find.  Of course the default sort is not the one I would hope for but the search is more reliable on the MAC than on the PC so that makes up for it. 


    I don't know why resorting the contacts takes as long as it does though, it really must be a slow sort algorythm and not taking any advantage at all of creating an index into the data rather than copying the whole contact databases around. 

  • fishlaw Level 1 Level 1 (5 points)

    It definitely speeds things up-now Contacts just opens with its list fully populated, versus the 30-90 seconds it used to take to open.

    I think the problem is that the Apple database index is based on "name" by default, and it stores the index for quick population of the table of information. If you change the index, then it needs to re-sort based on your custom index every time you open the program.

    This is the last bug I had to work out on my iMac-now it will probably die on me!

    (One year to go on AppleCare)

  • Yvonne_UK Level 1 Level 1 (0 points)

    Yep - simply going to Outlook preferences and changing the default to 'first name' instead of 'last name' has instantly resolved this problem!