3 Replies Latest reply: Mar 19, 2012 12:34 PM by flabama
flabama Level 1 Level 1 (0 points)

To start off, it is an iPhone 4S running iOS 5.1 with Verizon's network.

 

My iPhone is NOT downloading apps at all. Their download icon appears on my screen but never gets past "Waiting..." Now I am connected to a wifi network, with iCloud supporting my 4th Generation iPod Touch running iOS 5.1 and the iPhone 4S.

 

So I've plugged my iPhone into iTunes to attempt getting the results I wish to acquire and it went alright until the download stopped a little under halfway through the download. it does not resume, it just stops. So after getting irritated, I go to my iPod to see if it can download apps, and sure enough the apps I want are sitting there on the screen. How is it possible that my iPhone 4S that is brand new can download apps, but my iPod that is slightly older can just download apps off of iCloud sync...? Please help, I need to download apps, my birthday is coming up and I plan on spending $50 on apps & music, I can't do that if I can't download any content!


iPhone 4S, iOS 5.1
  • 1. Re: Why isn't my iPhone 4S downloading apps properly?
    Vir3x Level 1 Level 1 (0 points)

    I have the same problem with iOS 5.1 on a 3GS. Since a few days I cannot download any content anymore, be it updates, apps, music or ibooks. Every download stays in the "Waiting..." state forever.

     

    The 'solution' you get across frequently (holding the wake/sleep and home button for a few seconds to restart the iPhone) does not work for me. I've tried that several times.

     

    Also, it can't be my network connection, as I've tried via 3G and in different WiFi networks and with other devices using the same account.

     

    All I can do is start the update/download from iTunes. But that's no solution, only a work-around.

     

    Any suggestions?

     

    Thanks!

  • 2. Re: Why isn't my iPhone 4S downloading apps properly?
    Myke Bates Level 1 Level 1 (0 points)

    Sorry this isn't a solution post - but I have the same issue and came across this from a google search.

     

    Sprint - iPhone 4S 16GB only noticed after upgrading to 5.1 on a mac.

  • 3. Re: Why isn't my iPhone 4S downloading apps properly?
    flabama Level 1 Level 1 (0 points)

    Alright guys I found a solution. I got this help from a friend, and it worked :)

     

    Step One: Back your phone up.

    Step Two: You need to reset your settings, this can be done by going to Settings>General>Reset>Reset All Settings>Enter your passcode. This will not delete your media, this ONLY affects the settings.

    Step Three: Wait for it to finish, and when it finishes you'll have to set your settings again, like you did when you first got your phone.

    Step Four: You're done, you should be able to download apps again.

     

    I hope this helps :)