Previous 1 2 3 Next 30 Replies Latest reply: Jun 2, 2013 7:28 PM by Cawas Go to original post
  • b j t Level 4 Level 4 (3,670 points)

    Good to here you fixed it.

  • saxlax Level 1 Level 1 (0 points)

    Hey! I'm missing com.apple.remotepairtool.plist too... Can't find it anywhere though :/ How to I find this one?!

    Dont have any Mac friends either... hehe

     

    Cheers!

  • abross86 Level 1 Level 1 (15 points)

    Here's a copy of the plist from my computer (it doesn't appear to be machine/os specific in any way, so I believe it will work for you):

    http://www.mediafire.com/file/8eib2lixa9vziie/com.apple.remotepairtool.plist

     

    Put this file in your /Library/LaunchDaemons folder. You'll probably need to fix the permissions on the file too. Run this command in terminal:

    sudo chown root /Library/LaunchDaemons/com.apple.remotepairtool.plist

     

    Last, you'll want to start the daemon with this command (it should also start automatically when you reboot):

    sudo launchctl load -w /Library/LaunchDaemons/com.apple.remotepairtool.plist

  • schpink Level 1 Level 1 (0 points)

    I would LOVE to do this operation also, but I have to confess I can't find the Library/LaunchDaemons folder.  Could you help a less experienced person with this?

     

    Thanks!

  • abross86 Level 1 Level 1 (15 points)

    Lion hides the library folders by default. The quickest way to get there is to open finder, use "Go To Folder..." (cmd-shift-G), and enter /Library/LaunchDaemons

  • The Narcissist Level 1 Level 1 (0 points)

    Thank you, abross86 that was awesome! I have very limited knowledge of programming stuff, so your detailed answers were great. FYI, what button combo worked for me is MENU + Back button for 2 seconds. What a sight for sore eyes after all that trouble. Thanks again!

  • lambock Level 1 Level 1 (0 points)

    On my MacBook (Mid'09) the problem with pairing a white remote was aparently the BetterTouchTool. I first added the file mentioned before to the LaunchDeamons folder though. Thanks and good luck to all the others

  • mariosangiorgio Level 1 Level 1 (0 points)

    Can you please tell me how you fixed the issue with better touch tool?

     

    I tried everything I read on the web, I tried to pair with better touch tool enabled, disabled but without success.

     

    The remote is working, it is just not pairing.

    I even did the iSight test, and if I hold Menu and Next after 5 seconds I can see a signal emitted, but, I don't know why, it is not received by my Mac.

  • lambock Level 1 Level 1 (0 points)

    My "solution" wasn't really a good one. I just quit BBT and the remote worked again. Sorry, not too versed to solve that probelm in an accurate way...

  • mariosangiorgio Level 1 Level 1 (0 points)

    Ok. Thanks for your reply!

  • ianji Level 1 Level 1 (0 points)

    I bought an iMac in late 2009 with which I could not pair the supplied remote. I tried a couple of times since then without luck and just decided to have another go, which brought me here. I checked in /Library/LaunchDaemons and there was no com.apple.remotepairtool.plist so I found a copy online somewhere and added it. After rebooting I tried pairing and nothing still happened. So then I started trying different button combinations and bingo, it paired! Well now I didn't know whether adding the plist file had had any effect so I deleted it and rebooted again then unpaired the remote from security prefs and tried pairing again. It still worked.

     

    My conclusion is that at least on a late 2009 iMac the plist file is not required for pairing to work, all that is required is pressing the correct two buttons simultaneously for about 5 seconds. So why had I been going wrong? Clicking on "Pair..." in the Advanced settings under Security & Privacy -> General pops up a box telling you to use the "Menu" and "Next" buttons. Well on my remote there is a circle with four outer direction buttons and an inner unlabelled button. Below that are two buttons, "MENU" on the left, and one on the right with play/pause symbols. For some reason I had got it into my head that I had to press those two and I might not have even tried any other button combinations, or at least not for long enough to work. So the correct combination is the "MENU" button together with the unlabelled button. Three years to solve that!


  • mac_user1986 Level 1 Level 1 (0 points)

    I know it's month ago but I have the same issue. Can you tell me where I find the com.apple.remotepairtool.plist file? I don't find one and the link above just gives me a .txt file.

     

    Thanks.

  • ianji Level 1 Level 1 (0 points)

    I just tried the mediafire link from the above post by abross86 and I got the plist file. It did have a .txt extension appended but you just need to remove that. In my case though the plist file was a red herring and was not required in order to pair the remote (my problem was that I had been pressing the wrong buttons).

  • Cawas Level 1 Level 1 (10 points)

    In my case, it was some app being initialized on Login Items that was conflicting somehow with the remote.

     

    No need to use the remotepairtool plist file here.

     

    My advice to find out if it's a conflicting software: create a Guest User or an alternate clean Admin User, whatever, and try to pair in there.

     

    Also, use Photo Booth to see if the infra red light is actually working. Digital cameras can see the infra red light.

     

    It's pretty interesting seeing how, when I press any 2 buttons at same time it holds the light for 5 seconds, then emits a much faster blinking light. Which means, in my case, it probably actually pairs up with any of two buttons combination.

     

    Just spend almost 3 hours researching around and trying to make this work, for the very first time.

  • clydesdale91 Level 1 Level 1 (0 points)

    You just saved my life with this file.  I have been searching a long time for a way to fixing the pairing problem I've had with my 2007 macbook ever since I upgraded in to lion. Thanks!