1 2 Previous Next 23 Replies Latest reply: Mar 18, 2012 10:19 PM by peterpumpkin
peterpumpkin Level 1 Level 1 (0 points)

When I try to boot from an external HD with 10.6 installed I get a kernel panic "unable to find a driver for this platform". My internal drive has 10.7 installed. Any suggestions as to how to resolve the issue?

 

Here's a bit of background. I have some files on my computer that are produced by applications no longer supported on the Mac. They worked fine under Rosetta with 10.6 but when I upgraded to 10.7 and Rosetta was dropped, so did my ability to access the files. I'm really keen to be able to at least open the files and see if I can export them to useful format, or even print them.

 

Today I purchased an external 1TB HD in the hope that this would solve my problem. I intended to boot up using Snow Leaopard. I installed it using the DVD purchased as part of the Mac Boxed Set a while back. There are two partitions on the HD, a 50GB section with 10.6 on it and a 950GB which is blank.

 

When the installation was complete the Mac automatically rebooted. Unfortunately it panicked midway through the restart. I've tried re-initialising the drive and checking the firmware. Everything seems ok there. I'm not sure what to do next.

 

Peter


iMac, Mac OS X (10.7.3)
  • 1. Re: External HD Boot fails with Snow Leopard
    den.thed Level 7 Level 7 (23,955 points)

    Did your iMac come preinstalled with 10.7 or did you update from 10.6 to 10.7....?

     

    Here's the thing, Snow Leopard will not run on a new iMac that shipped with Lion.

     

    see > Don't install a version of Mac OS X earlier than what came with your Mac

     

    If however your iMac is pre-Lion, then perhaps you have not properly setup the External Hard Drive (GUID Partition Table / Mac OS Extended (Journaled) so that the Intel iMac will boot from it...?

     

    see > OSX Tips: Using Disk Utility 1. Format, Erase, or Reformat a Drive

  • 2. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    Thanks. It's an early 2008 iMac so I think it came with Tiger, thus Snow Leopard is not a problem. I also set up the hard drive correctly.

  • 3. Re: External HD Boot fails with Snow Leopard
    den.thed Level 7 Level 7 (23,955 points)

    A Mid 2007 originally came with Tiger and a Early 2008 came with Leopard, but that's not all that important in this case.

     

    Is that Snow Leopard Install DVD a white Retail Upgrade DVD or a gray System Specific Install disc for a different iMac?

     

    If it is gray, please note that the system specific disc sets only support the orignal iMac model that they shipped with.

  • 4. Re: External HD Boot fails with Snow Leopard
    X423424X Level 6 Level 6 (14,190 points)

    Today I purchased an external 1TB HD in the hope that this would solve my problem. I intended to boot up using Snow Leaopard.

     

    Assuming you formatted as Mac OS Extended, journaled, GUID partitioned, it may be that the enclosure itself is the problem.  Some enclosure bridge firmware are not necessarily compatible with all models of macs.

     

    Are you using firewire or usb to the enclosure?  If it supports both try the other kind.

     

    As an additional experiment clone your current boot drive on to the external using, say, Carbon Copy Cloner.  See if that will boot.

  • 5. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    Cheers. The enclosure is a LaCie Porsche USB only. I have another LaCie drive that has both FireWire and USB connections. I'll try that and the cloning strategy.

  • 6. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    It's the full retail version. I purchased it from Apple as part of the "Mac Boxed Set" that included full versions of iWork and iLife as well.

  • 7. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    When I do a CCC clone, do I just clone the system folder?

  • 8. Re: External HD Boot fails with Snow Leopard
    den.thed Level 7 Level 7 (23,955 points)

    Try Startup Manager and see if can boot the OS X 10.6 volumn on the external hard drive. > Startup Manager: How to select a startup volume

  • 9. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    Thanks. I have tried using the Startup Manager to select the volume and it fails. I have also turned the external disk on/off as the startup in the Startup Disk pane in System Preferences

  • 10. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    CCC showed me what to do. There is a list of folders & files to clone. I have selected the correct ones and currently cloning about 30GB across to the external. I'll let you know how I go.

  • 11. Re: External HD Boot fails with Snow Leopard
    peterpumpkin Level 1 Level 1 (0 points)

    Well, the clone didn't work. I copied the following files/folders to the external as advised by CCC:

    /Library, /System, /bin, /etc, /mach_kernel, /private, /sbin, /tmp, /usr, and /var

     

    There was a panic on startup with the following info displayed:

     

    panic(cpu 1 caller 0xffffff7f807b1f9a): "No HPETs available...CPU(s) configured incorrectly\n"@/SourceCache/AppleIntelCPUPowerManagement/AppleIntelCPUPowerMana gement-167.3/pmThread.c:156

    Backtrace (CPU 1), Frame : Return Address

    0xffffff807987bef0 : 0xffffff8000220702

    0xffffff807987bf70 : 0xffffff7f807b1f9a

    0xffffff807987bfb0 : 0xffffff8000820057

          Kernel Extensions in backtrace:

             com.apple.driver.AppleIntelCPUPowerManagement(167.3)[E08EC0D7-C364-3C57-A377-88 7B36241B1C]@0xffffff7f807ac000->0xffffff7f807d5fff

     

     

    BSD process name corresponding to current thread: kernel_task

     

     

    Mac OS version:

    Not yet set

     

     

    Kernel version:

    Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64

    Kernel UUID: 7B6546C7-70E8-3ED8-A6C3-C927E4D3D0D6

    System model name: iMac8,1 (Mac-F227BEC8)

     

    I will try installing a copy of the 10.6.3 operating system on my firewire HD and see if that works.

  • 12. Re: External HD Boot fails with Snow Leopard
    X423424X Level 6 Level 6 (14,190 points)

    Just clone the entire boot drive to the external to make a duplicate bootable external drive for this experiment.  Don't try to editorialize on what and what not to copy.  You're just trying to verify that what is bootable on the internal is bootable on the external.

  • 13. Re: External HD Boot fails with Snow Leopard
    artistree Level 1 Level 1 (0 points)

    My 2009 did not have OS X 10.6 snowleapord installed new,

     

    It had 10.5 I am not sure what that was but I had to purchase the 10.6 for my late 2009 macbook pro.

     

    Just FYI.

  • 14. Re: External HD Boot fails with Snow Leopard
    artistree Level 1 Level 1 (0 points)

    I know nothing but just restored from my 10.6 crash and reformatted a 500. gig and a 80. gig western digital portable HDD from walmart ,

     

    they both checked out as fine and for a week trying around the clock at times kept freezing, I even was able to replace the original drive internally with them to try booting up,

     

    As I actually had given up and decided to purchase a drive with 10.6 installed?

     

    But could not resist another try and amazed to my situation it loaded and booted on the 500. G WD drive off the !).^ DVD

     

    And with the 80. g I ran time machine long enough to complete 3 back ups

     

    During the first 45 minutes running updates, with 3 hours of them I managed almost the first hour  before it froze.

     

    I am waiting for some help with managing what I have so far, but just to share I too have had difficulties loading the 10.6 to reboot

     

    (loading the 10.6 was no trouble, booting it up has been.

     

    Hope you don't mind me cutting in, I am looking for clues myself. Thanks

1 2 Previous Next