11 Replies Latest reply: Nov 10, 2013 2:30 PM by MotoWorf
rossfromcomber Level 1 Level 1 (0 points)

Hi, i have been trying to find a solution so i can login into icloud on mac preferences but can't, i get this error message;

 

"You can't sign in at this time. Try signing in again later."

 

I can login to the app store and on my iPhone and iPad. Any help really appreciated! icloud.jpg


MacBook Pro (13-inch Mid 2010), Mac OS X (10.7.3), iCloud
  • Roger Wilmut1 Level 9 Level 9 (72,425 points)

    Many people have two IDs, one for iTunes, the App Store and these forums, and another for MobileMe/iCloud It's easy to get them confused. Is this the case for you, and if so are you signing in with the correct ID?

  • rossfromcomber Level 1 Level 1 (0 points)

    good suggestion but i only have 1 account and have made sure App Store, iTunes etc are all on the same account, on iPad, iPhone and Mac...

  • Roger Wilmut1 Level 9 Level 9 (72,425 points)

    Well, I would guess that one of three things is happening:

     

    You are mistyping your ID

    You are mistyping your password (watch out for case sensitivity)

    You have them both correct but have hit a server glitch.

     

    If the third, you may find it will clear itself up.

     

    It if doesn't, you could try MobileMe Support (I know you're on iCloud but there is no free support for that unless you happen to have AppleCare, and MobileMe Support have helped some people). Go to http://www.apple.com/support/mobileme/ww/ and select your country. In the next window click on a category to expand it, then on a subject to get a link to 'live chat'.

  • rossfromcomber Level 1 Level 1 (0 points)

    Thanks I'll try that now!

  • rossfromcomber Level 1 Level 1 (0 points)

    after talking to someone i found out that it is a problem with my actual mac and was recommended to re-install lion, will let you know how it goes

  • rossfromcomber Level 1 Level 1 (0 points)

    re-installed and experiencing the same problem...

  • AnthonyP Level 1 Level 1 (0 points)

    I have the same issue.  Just installed Lion, moved to iCloud by cant access it on my iMac.  Strangely, I can access iCloud on my iPad and laptop.  Must be something with the imac.  I have the same error message "you can't sign in at this time, try signing in again"  Help!

  • rossfromcomber Level 1 Level 1 (0 points)

    i just got it fixed today, this is what i did,

     

    *note*

    when i refer to account 1, i mean the original account you have problems with

    when i refer to account 2, i mean the new one you will create

     

    1. create a new user account (account 2)

    2. check to see if you can login to icloud on the new account

    3. if so, go back to your original account

    4. go to users and groups in sys. prefs.

    5. click on login items

    6. click join a network account server

    7.

    1. Click the "Open Directory Utility..." button.
    2. Click the lock in the Directory Utility window.
    3. Enter an administrator account name and password, then click OK.
    4. Choose Enable Root User from the Edit menu.

     

    8. then select show fast user swtiching top right and show login window

    click other user and type the password you provided for root user

    9. go to finder and search for users on "this mac"

    10. select the users folder for the new account you created. "account 2", take the exact note of file name.DELETE this file

    11. then select get info on the account 1 file, ok?

    then rename this folder by clicking name and extensions, NAME THIS FOLDER THE EXACT SAME AS THE ONE YOU JUST DELETED

    12. restart your computer

    you may want to redo step 6 and disable the root user

    thisworked for me... good luck =D

  • AnthonyP Level 1 Level 1 (0 points)

    Hi,

     

    I realize the issue is definitely with my current profile as administrator. I created a 2nd account as suggested below and could login into iCloud from there. However, I am still not clear on the fix for the current profile, as I dont want to have to change everything.

     

    In step 7 I enabled "root user" and had to create a password.  Is the root user the same as account 1? Because when I switched to account 2 it did not accept the password I just entered for root user and can only enter the account 2 password?

     

    The other issue I had was on account 1 profile when I went to " get info" I can't change/ edit the name extension as it is greyed out.

     

    I have also realized that mobile Me is still in the system presences and it won't let me logout? It crashes every time and I have to force quit. I have run repair disk permissions etc. should I delete everything relating to mobile me from the key chain and see if I can actually get logged out?

     

    I am hoping if I could actually escape from MobileMe it will allow me to add the iCloud account....

     

    Thanks for any more suggestions!

  • rossfromcomber Level 1 Level 1 (0 points)

    Hi ,

     

    I think you seem to be confused, the root user is the computer account, the very main account if you like, which can change anything, eg user account files. Account 1 is the account you are having problems with, and account 2 is a brand new account you have just created. I think you seem to think the root user and account are the same, think it like this;

     

    http://i1179.photobucket.com/albums/x391/random646/a58329d3.jpg

     

    The green square with what's meant to be a crown is the root user, it can control anything, but it's password CANNOT overwrite any other user password, the blue box is account 1 and red, 2. What you are trying to do it basically paint (change the name of the file) account 1s file red, this file is your personal stuff, documents pics etc. and delete the red folder, so when the computer starts up, the brand new account, without any problems will load your old personal file.

     

    I hope I have helped you understand, please let me know if you can't get it working.

  • MotoWorf Level 1 Level 1 (0 points)

    SOLVED....for me, anyway

     

    Okay, here's what worked for me after upgrading to Mavericks (it should work for you, too):

     

    (1) Deleted all the files in:

    User(your name)/Library/Application Support/iCloud/Accounts/

    (2) Shut down the computer, waited 15-20 seconds and turned it back on.

    (3) Then I went to

    System Preferences

    iCloud icon

    (4) Input the requested information and followed the directions to be back in business.

     

    But, first you must be able to see the folder because it is hidden:

    Use Finder and click on Utilities then Terminal

    Type in (very carefully) the following exactly:

    Chflaga nohidden ~/Library

     

    Then

    Finder

    Go

    Computer

    User account name/Library/Application Support/iCloud/Accounts

     

    Remember, the files are under your user account and not the harddrive.